"Location is not available" error when you access a mapped network drive after Windows standby or resume

Symptoms

Consider the following scenario:
  • You have a Windows 7 or Windows Server 2008 R2 computer that supports the sleep and resume functionality and joined to a domain.
  • You access a mapped network drive from Explorer on a Windows 7 or Windows Server 2008 R2 computer.
  • You put the computer to sleep and wake the computer again after some time.
In this situation, you cannot access the mapped network drive for a short time, and you cannot save open Microsoft Office files (Word, Excel) within the first 30 seconds after you resume from hiberation. Additionally, you may receive error messages such as the following: 
Location is not available.

Can't Access x:\

The specified network name is no longer available.



The local device name is already in use.

This connection has not been restored.

Cause

This issue occurs because the Server Message Block (SMB) session is deleted on the server-side.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

This hotfix introduces a new registry key.

Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
Name: InvalidFileServerCacheLifeTime
Type: REG_DWORD
Default value: 30 (seconds)
Max value: 30

In order to reduce the time of the unavailable network share or drive mapping, you can set a lower value, such as 10 seconds.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information
Propriétés

ID d'article : 2907020 - Dernière mise à jour : 10 mars 2014 - Révision : 1

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