Impossible d’établir une connexion TLS à un serveur de messagerie distant dans Exchange Online ou Exchange Server

Numéro de la base de connaissances d’origine : 3027536

Symptômes

Vous ne pouvez pas établir de connexion TLS (Transport Layer Security) à un serveur de messagerie distant à l’aide des services et applications suivants :

  • Microsoft Exchange Online
  • Microsoft Exchange Server 2016
  • Microsoft Exchange Server 2013
  • Microsoft Exchange Server 2010

Par exemple, dans Exchange Server, vous voyez des messages dans la file d’attente de messages qui sont dans un état Nouvelle tentative.

Cause

Ce problème se produit si un algorithme de signature non sécurisé est utilisé dans la chaîne de certificats du serveur de messagerie distant. Lorsque TLS 1.2 est activé sur les serveurs qui exécutent Exchange Server, des vérifications de sécurité supplémentaires sont introduites lors d’une négociation TLS. Cela signifie que la chaîne de certification du serveur de messagerie distant est soumise à des vérifications pour les algorithmes de signature non sécurisés. Si un certificat dans la chaîne de certificats utilise des algorithmes de hachage MD5 ou MD2, la négociation TLS échoue.

L’analyse de la chaîne de certificats envoyée par le serveur de messagerie distant montre qu’un algorithme non sécurisé est utilisé.

Résolution

Pour résoudre ce problème, mettez à jour le certificat sur le serveur de messagerie distant.

Informations supplémentaires

Pour contourner ce problème, vous pouvez configurer le serveur distant pour qu’il ne publie pas de publicité tant que le certificat n’a pas été mis à jour. Toutefois, dans cette configuration, aucune connexion au serveur n’est chiffrée.

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