Calendrier Outlook n’est pas affiché dans le volet des dossiers ou la liste des dossiers

Symptômes

Lorsque vous essayez d’afficher le calendrier dans Microsoft Outlook, vous rencontrez les problèmes suivants :

  • Le calendrier n’apparaît pas dans le volet des dossiers ou la liste des dossiers.
  • Lorsque vous cliquez sur le calendrier, le volet des dossiers à gauche change à votre liste Mes calendriers . Toutefois, le calendrier ne s’affiche pas. Au lieu de cela, le contenu du dossier que vous consultiez dernier est affiché. En outre, le ruban ne change pas pour des commandes spécifiques au calendrier ; Il affiche à la place des commandes qui sont spécifiques au dernier dossier que vous consultiez.
  • Si vous cliquez sur calendrier , puis sélectionnez Ouvrir dans une nouvelle fenêtre, le calendrier est affiché dans la nouvelle fenêtre. Si vous sélectionnez ensuite un deuxième ou un calendrier partagé à afficher également, le nom du calendrier d’origine n’est pas répertorié sous l’onglet calendrier .

Cause

Ce problème peut se produire si la propriété PR_ATTR_HIDDEN du dossier calendrier est définie sur True. La valeur par défaut de cette propriété est False.

Résolution

Procédez comme suit pour confirmer que vous rencontrez ce problème et à réinitialiser la propriété PR_ATTR_HIDDEN du dossier affecté :

  1. Téléchargez et extrayez l’outil MFCMapi à partir de http://mfcmapi.codeplex.com.
  2. Démarrer mfcmapi.exe, puis cliquez sur OK sur l’écran d’introduction.
  3. Dans le menu Outils , cliquez sur Options.
  4. Sélectionnez l’option indicateur de MAPI_NO_CACHE d’utilisation lors de l’appel de OpenEntry , puis cliquez sur OK.
  5. Dans le menu Session , cliquez sur ouverture de session.
  6. Sélectionnez le profil Outlook pour la boîte aux lettres concernée, puis cliquez sur OK.
  7. Double-cliquez sur l’adresse de messagerie qui représente la boîte aux lettres en question.
  8. Dans le volet de navigation, développez le Conteneur racine.
  9. Développez la partie supérieure de la banque d’informations.
  10. Recherchez et sélectionnez le dossier calendrier dans le volet de navigation et recherchez la propriété PR_ATTR_HIDDEN .
  11. Vérifiez la valeur de la PR_ATTR_HIDDEN pour déterminer si elle est définie sur True, comme illustré dans la capture d’écran suivante :

    PR_ATT_HIDDEN Property is set to True for the Calendar Folder.

  12. Si PR_ATTR_HIDDEN affiche la valeur True, avec le bouton droit de la propriété PR_ATTR_HIDDEN et sélectionnez Modifier une propriété.
  13. Désactivez la case à cocher Boolean , puis cliquez sur OK.
  14. Fermez toutes les fenêtres MFCMAPI, puis redémarrez Outlook.

Plus d'informations

Pendant que vous examinez les propriétés du dossier, vous devez également vérifier PR_ATTR_SYSTEM. Sa valeur par défaut est également False. Par conséquent, si vous vous trouvez actuellement la valeur True après avoir terminé les étapes 1 à 13 dans la section « Résolution », vous devez également modifier cette valeur. Pour ce faire, procédez comme suit :
  1. Si PR_ATTR_SYSTEM affiche la valeur True, avec le bouton droit de la propriété PR_ATTR_SYSTEM et sélectionnez Modifier une propriété.
  2. Désactivez la case à cocher Boolean , puis cliquez sur OK.
  3. Fermez toutes les fenêtres MFCMAPI, puis redémarrez Outlook.
Propriétés

ID d'article : 3089539 - Dernière mise à jour : 27 janv. 2017 - Révision : 1

Commentaires