Données Excel ne conservent pas sa mise en forme dans les opérations de fusion et publipostage dans Word

Symptômes

Si vous effectuez une fusion et publipostage dans Microsoft Word et que vous utilisez une feuille de calcul Microsoft Excel comme source de données pour la liste de destinataires, certaines données numériques peuvent ne pas conservent leur mise en forme lorsqu’il est fusionné.

Ce problème concerne les pourcentages, les valeurs monétaires et les codes postaux, comme indiqué dans le tableau suivant :
   Format          In Excel data     In Word MergeField
----------------------------------------------------
Percentage 50% .5
Currency $12.50 12.5
Postal Code 07865 7895

Cause

Ce problème se produit car les données de la liste de destinataires dans Word apparaissent au format natif dans lequel Excel les stocke, sans la mise en forme qui est appliquée aux cellules de la feuille de calcul qui contiennent les données.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1

Protection continue des données (DDE, Dynamic Data Exchange) permet de se connecter à la feuille de calcul Excel qui contient les données que vous souhaitez utiliser. Pour ce faire, procédez comme suit.

Word 2002 et Word 2003

  1. Démarrez Word, puis ouvrez un nouveau document vierge.
  2. Dans le menu Outils , cliquez sur Options, puis cliquez sur l’onglet Général .
  3. Activez la case à cocher Confirmation des conversions lors de l’ouverture , puis cliquez sur OK.
  4. Dans le menu Outils , pointez sur lettres et publipostage, puis cliquez sur Assistant Fusion et publipostage.
  5. Dans le volet Office fusion et publipostage , sélectionnez le type de document que vous souhaitez utiliser, puis cliquez sur suivant.
  6. Sous sélection du document, sélectionnez le document de départ que vous souhaitez utiliser, puis cliquez sur suivant.
  7. Sous sélection des destinataires, cliquez sur utiliser une liste existante, puis cliquez sur Parcourir.
  8. Dans la boîte de dialogue Sélectionner la Source de données , recherchez le dossier qui contient le classeur Excel que vous souhaitez utiliser comme source de données, sélectionnez le classeur, puis cliquez sur Ouvrir.
  9. Dans la boîte de dialogue Confirmer la Source de données , cliquez sur Feuilles de calcul MS Excel via un DDE (*.xls), puis cliquez sur OK.
  10. Dans la boîte de dialogue Microsoft Excel, sous nom ou plage de cellules, sélectionnez la plage de cellules ou la feuille de calcul qui contient les données que vous souhaitez utiliser, puis cliquez sur OK.
    Remarque: vos données apparaissent maintenant dans la boîte de dialogue Destinataires du publipostage avec la même mise en forme qui s’affiche dans la feuille de calcul Excel.

Word 2007 et Word 2010

  1. Démarrez Word, puis ouvrez un nouveau document vierge.
  2. Accédez aux Options de Word
    • Dans Word 2007, cliquez sur le Bouton Office, puis cliquez sur Options Word.
    • Dans Word 2010, cliquez sur fichier, puis cliquez sur Options.
  3. Sous l’onglet Avancé , passez à la section Général .
  4. Activez la case à cocher Confirmation des conversions de format de fichier lors de l’ouverture , puis cliquez sur OK.
  5. Sous l’onglet publipostage , cliquez sur Démarrer la fusion et le publipostageet sélectionnez Assistant de fusion et publipostage pas à pas.
  6. Dans le volet Office Fusion et publipostage, sélectionnez le type de document que vous souhaitez utiliser, puis cliquez sur suivant.
  7. Sous sélection du document, sélectionnez le document de départ que vous souhaitez utiliser, puis cliquez sur suivant.
  8. Sous sélection des destinataires, cliquez sur utiliser une liste existante, puis cliquez sur Parcourir.
  9. Dans la boîte de dialogue Sélectionner la Source de données , recherchez le dossier qui contient le classeur Excel que vous souhaitez utiliser comme source de données, sélectionnez le classeur, puis cliquez sur Ouvrir.
  10. Dans la boîte de dialogue Confirmer la Source de données , cliquez pour sélectionner la case à cocher Afficher tout . Cliquez sur Feuilles de calcul MS Excel via un DDE (*.xls), puis cliquez sur OK.
  11. Dans la boîte de dialogue Microsoft Excel, sous nom ou plage de cellules, sélectionnez la plage de cellules ou la feuille de calcul qui contient les données que vous souhaitez utiliser, puis cliquez sur OK.
    Remarque: vos données apparaissent maintenant dans la boîte de dialogue Destinataires du publipostage avec la même mise en forme qui s’affiche dans la feuille de calcul Excel.

Méthode 2

Mettre en forme le champ Excel qui contient le Code du Code ZIP/Postal sous forme de texte. Pour ce faire, procédez comme suit.

Word 2002 et Word 2003

  1. Dans Excel, sélectionnez la colonne qui contient le champ de Code ZIP/Postal Code.
  2. Dans le menu Format, cliquez sur Cellules.
  3. Cliquez sur l’onglet nombre .
  4. Sous catégorie, cliquez sur texte, puis cliquez sur OK.
  5. Enregistrer la source de données. Ensuite, passez à l’opération de fusion et publipostage dans Word.

Word 2007 et Word 2010

  1. Dans Excel, sélectionnez la colonne qui contient le champ de Code ZIP/Postal Code.
  2. Sous l’onglet accueil , ouvrez le groupe de cellules . Ensuite, cliquez sur Format, puis cliquez sur Format de cellule.
  3. Cliquez sur l’onglet nombre .
  4. Sous catégorie, cliquez sur texte, puis cliquez sur OK.
  5. Enregistrer la source de données. Ensuite, passez à l’opération de fusion et publipostage dans Word.

Références

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

304387 date, numéro de téléphone et les champs de devise sont fusionnés correctement lorsque vous utilisez une source de données Access ou Excel dans Word 2002 ou Word 2003

Propriétés

ID d'article : 320473 - Dernière mise à jour : 27 janv. 2017 - Révision : 2

Commentaires