Internet Explorer ne réessaie pas le serveur proxy défectueux pendant 30 minutes

Important Cet article contient des informations sur la façon de modifier le Registre. Assurez-vous que vous sauvegardez le Registre avant de le modifier. Assurez-vous que vous savez comment restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 comment sauvegarder et restaurer le Registre dans Windows

Symptômes

Si la connexion réseau à votre serveur proxy est déconnectée, la navigation ne fonctionne pas, et ce comportement est normal. Toutefois, après le premier échec, vous ne pouvez pas naviguer pendant 30 minutes. Cela peut se produire même si vous avez rétabli une connexion à votre serveur proxy.

Cause

Ce problème peut se produire une fois Internet Explorer ajoute votre serveur proxy dans la liste de proxy défectueux. Un serveur proxy est ajouté à la liste de proxy défectueux lorsque Internet Explorer ne peut pas se connecter au serveur proxy. Après l’ajout d’un serveur à la liste de proxy défectueux, Internet Explorer ne réessaie pas l’il pendant 30 minutes.

Résolution

Avertissement Des problèmes graves peuvent survenir si vous modifiez le Registre incorrectement à l’aide de l’Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent nécessiter que vous réinstalliez le système d’exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Modifiez le Registre à vos risques et périls.
Après avoir appliqué le correctif approprié pour votre version d’Internet Explorer, vous pouvez définir un intervalle de tentative personnalisé pour les serveurs proxy défectueux sous la clé de Registre suivante :

Paramètres HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
Créez une valeur DWORD de la valeur BadProxyExpiresTime dans cette clé et affectez la valeur 0, 1ou un autre numéro à cette valeur. Notez que ces valeurs sont exprimées en secondes.

Internet Explorer 6

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue. La version anglaise de ce correctif pour Internet Explorer 6 doit avoir les attributs de fichier suivants ou une version ultérieure :
   Date         Time   Version        Size     File name
-------------------------------------------------------
15-Apr-2002 19:31 6.0.2716.1500 582,656 Wininet.dll

Un correctif pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est conçu pour résoudre uniquement le problème décrit dans cet article. Il s’applique uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème, contactez les Services de Support technique Microsoft pour obtenir le correctif. Pour obtenir une liste complète des numéros de téléphone des Services de Support technique Microsoft et des informations sur les coûts de support, visitez le site Web de Microsoft à l’adresse suivante :Remarque Dans des cas particuliers, des frais généralement encourus pour les appels au support technique peuvent être annulés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Internet Explorer 5.5 Service Pack 2 (SP2)

Un correctif pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est conçu pour résoudre uniquement le problème décrit dans cet article. Il s’applique uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème, contactez les Services de Support technique Microsoft pour obtenir le correctif. Pour obtenir une liste complète des numéros de téléphone des Services de Support technique Microsoft et des informations sur les coûts de support, visitez le site Web de Microsoft à l’adresse suivante :Remarque Dans des cas particuliers, des frais généralement encourus pour les appels au support technique peuvent être annulés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question. La version anglaise de ce correctif pour Internet Explorer 5.5 SP2 devrait avoir les attributs de fichier suivants ou une version ultérieure :
   Date         Time   Version         Size     File name
--------------------------------------------------------
25-Apr-2002 11:09 5.50.4916.2500 481,040 Wininet.dll

Internet Explorer 5.01 SP2

Un correctif pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est conçu pour résoudre uniquement le problème décrit dans cet article. Il s’applique uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème, contactez les Services de Support technique Microsoft pour obtenir le correctif. Pour obtenir une liste complète des numéros de téléphone des Services de Support technique Microsoft et des informations sur les coûts de support, visitez le site Web de Microsoft à l’adresse suivante :Remarque Dans des cas particuliers, des frais généralement encourus pour les appels au support technique peuvent être annulés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question. La version anglaise de ce correctif pour Internet Explorer 5.01 SP2 devrait avoir les attributs de fichier suivants ou une version ultérieure :
   Date         Time   Version        Size     File name
-------------------------------------------------------
25-Apr-2002 14:55 5.0.3502.4856 461,072 Wininet.dll

État

Microsoft a confirmé qu’il s’agit d’un problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé dans Windows XP Service Pack 1.
Propriétés

ID d'article : 320507 - Dernière mise à jour : 27 janv. 2017 - Révision : 1

Commentaires