Erreur 0x800f0831 lors de l’installation d’une mise à jour

Cet article résout un problème selon lequel l’erreur 0x800f0831 se produit quand vous installez une mise à jour cumulative.

Version de produit d’origine : Configuration Manager (Current Branch), Windows Server Update Services
Numéro de l’article d’origine dans la base de connaissances : 4477073

Symptôme

Lorsque vous essayez d’installer une mise à jour Windows, en particulier une mise à jour cumulative, le message d’erreur suivant s’affiche dans WindowsUpdate.log :

FATAL: CBS called Error with 0x800f0831 (IRRÉCUPÉRABLE : CBS a appelé une erreur avec 0x800f0831)

Ce problème est plus susceptible de se produire lorsqu’il n’y a pas d’accès à Microsoft Update.

En outre, vous recevez des messages d’erreur qui ressemblent à ce qui suit dans CBS.log :

Store corruption, manifest missing for package: <Missing_Package>
Failed to resolve package <Missing_Package> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Mark store corruption flag because of package: <Missing_Package> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to resolve package [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to get next package to re-evaluate [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to execute execution chain. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to process single phase execution. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
WER: Generating failure report for package:<Failed_Package> status: 0x800f0831, failure source: Execute, start state: Staged, target state: Installed, client id: DISM Package Manager Provider

Remarque

              <Failed_Package> correspond au package qui ne peut pas être installé.               <Missing_Package> correspond au package dont le manifeste est manquant.

Cause

Ce problème se produit, car la mise à jour qui ne peut pas être installée nécessite le manifeste d’un package de mise à jour précédent.

Résolution

Pour résoudre le problème, utilisez l’une des méthodes suivantes.

Méthode 1 : Réparer le magasin de composants avec des commandes DISM

Pour réparer le magasin de composants à l’aide de la DISM RestoreHealth commande , procédez comme suit :

  1. Ouvrez une invite de commandes avec élévation de privilèges et exécutez les commandes suivantes :

    DISM /ONLINE /CLEANUP-IMAGE /SCANHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /CHECKHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH
    
    Sfc /Scannow
    
  2. Redémarrez lʼappareil.

Méthode 2 : réparer manuellement avec la charge utile du composant partiellement installé

  1. Accédez au Catalogue Microsoft Update.
  2. Dans la zone de recherche, entrez l’ID de package de <Missing_Package>.
  3. Recherchez la mise à jour qui s’applique à votre système d’exploitation dans les résultats de la recherche, puis sélectionnez le bouton Télécharger.
  4. Dans la fenêtre Catalogue Microsoft Update, sélectionnez le lien du fichier pour télécharger la mise à jour.
  5. Sélectionnez Fermer une fois le téléchargement terminé. Vous trouverez alors un dossier contenant le package de mise à jour dans l’emplacement spécifié.
  6. Ouvrez le dossier, puis double-cliquez sur le package de mise à jour pour installer la mise à jour.