Calcul automatique de l'âge

Exclusion de responsabilité du contenu obsolète de la base de connaissances

Cet article a été rédigé sur les produits pour lesquels Microsoft n’offre plus aucune prise en charge. Par conséquent, cet article est proposé « en l’état » et ne sera plus mis à jour.

Résumé

QUESTION:
Comment calculer automatiquement l'âge d'une personne en fonction de sa
date de naissance ?

Résolution

Dans le tableur ou la Base de Données de Works pour Windows, vous pouvez
calculer automatiquement, par rapport à la date du jour, l'âge d'une
personne en fonction de sa date de naissance.

Pour cela, utilisez la formule suivante :

=SI(<champ><>"";ENT((MAINTENANT()-<champ>)/365,24);"")

où <champ> est le nom du champ (Base de Données) ou la référence de la
cellule (feuille de calcul) contenant la date de naissance.


Exemple pour la Base de Données :
---------------------------------
"Anniversaire" est le nom du champ contenant la date de naissance.

=SI(Anniversaire<>"";ENT((MAINTENANT()-Anniversaire)/365,24);"")

L'affichage en mode liste de la Base de Données donnera :
(dans notre exemple, la date du jour est le 19/06/1995)

Anniversaire Age

15/05/1985 10
28/02/1960 35
18/08/1970 24
20/09/1980 14


Exemple pour le tableur :
-------------------------
A1 contient la date de naissance.
B2 contient la formule =SI(A1<>"";ENT((MAINTENANT()-A1)/365,24);"")
Le résultat donnera :
(dans notre exemple, la date du jour est le 19/06/1995)

A B

1 15/05/1985 10

Vous pouvez utiliser la commande Recopier vers le bas du menu Edition
afin de recopier la formule sur autant de lignes que vous le désirez.

Remarque :
La formule donnée ci-dessus fait référence à la date système (date du
jour) en utilisant la fonction MAINTENANT().
Vous pouvez également utiliser cette formule pour calculer un nombre
d'années entre deux dates.
Dans ce cas vous remplacerez la fonction MAINTENANT() par le nom du champ
ou la cellule contenant la date de référence pour le calcul.

Propriétés

ID d'article : 463685 - Dernière mise à jour : 26 juin 1995 - Révision : 1

Commentaires