User of a Disabled Account Is Prompted to Change the Password Before the "Account Has Been Disabled" Message Appears

Symptoms

When a user of a disabled user account that is set to require a password change on the next logon tries to log on to the account, the user receives the following message, regardless of whether the password that is provided is correct:
You are required to change your password at first logon.
If the password that is provided is correct and the user changes the password, the user receives the following message:
Your account has been disabled. Please see your system administrator.
Note When a user tries to log on to a disabled account, the expected behavior is that the "account has been disabled" message is displayed immediately.

Cause

This problem occurs because Windows uses incorrect priorities when it processes the logon of a disabled account.

Resolution

Windows 2003

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
There are no prerequisites to install this hotfix.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name Platform
-------------------------------------------------------------
12-Aug-2003 22:47 5.2.3790.77 225,792 Kdcsvc.dll X86
12-Aug-2003 22:47 5.2.3790.77 584,704 Kdcsvc.dll Ia64
Note This hotfix is a server-side hotfix that should be applied to all authenticating domain controllers.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

More Information

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages

Propriétés

ID d'article : 826133 - Dernière mise à jour : 28 mai 2008 - Révision : 1

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