Vous recevez un Message d’erreur d’initialisation « Échec de User32.dll », ou l’Interface utilisateur n’actualise pas correctement

N° de bogue : 48762 (Windows SE)

Symptômes

Si un programme (par exemple, Microsoft Word) utilise une fonction de Graphics Device Interface (GDI) API qui crée un pinceau, comme CreateSolidBrush, et si le programme retire une fenêtre avant de supprimer le pinceau, ressources GDI peuvent devenir insuffisante, et vous pouvez rencontrer un ou plusieurs des problèmes suivants :
  • Vous recevez un message d’erreur semblable au suivant :
    Nom_service - Échec de l’initialisation de DLL l’initialisation de la bibliothèque de liaisons dynamique c:\windows\system32\user32.dll a échoué. Le processus de fin d’exécution anormale.
  • L’interface utilisateur ne peut pas mettre à jour correctement. Par exemple, menus ne s’affichent pas correctement, texte du bouton est perdue ou images d’icône ne réaffichent pas.

Cause

Ce problème se produit car le système d’exploitation peut perdre un handle à un objet brush GDI si une fenêtre est supprimée avant que le pinceau est supprimé.

Pour plus d’informations sur la façon de résoudre les problèmes liés à cette fuite, reportez-vous à la section «Plus d’informations» de cet article.

Résolution

Windows Server 2003

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
Conditions préalables
Aucunes conditions préalables ne sont requises.
Nécessité d’un redémarrage
Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif
Ce correctif ne remplace aucun autre correctif.
Informations sur les fichiers
La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans le Panneau de configuration.
  Date         Time   Version       Size       File name   -------------------------------------------------------
08-Dec-2003 06:11 5.2.3790.110 1,811,456 Win32k.sys

Windows 2000

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n’apparaît pas, soumettez une demande au Service Clients et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
Conditions préalables
Pour appliquer ce correctif, vous devez disposer de Windows 2000 Service Pack 4 (SP4) est installé sur votre ordinateur. Pour plus d’informations sur la façon d’obtenir le dernier service pack, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

Nécessité d’un redémarrage
Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif
Ce correctif ne remplace aucun autre correctif.
Informations sur les fichiers
La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans le Panneau de configuration.
   Date         Time   Version            Size    File name
--------------------------------------------------------------
10-Sep-2003 18:52 5.0.2195.6738 42,256 Basesrv.dll
17-Jan-2003 16:06 5.0.2195.6656 236,304 Cmd.exe
10-Sep-2003 18:52 5.0.2195.6762 222,992 Gdi32.dll
10-Sep-2003 18:52 5.0.2195.6816 711,440 Kernel32.dll
10-Sep-2003 18:52 5.0.2195.6807 333,584 Msgina.dll
10-Sep-2003 18:52 5.0.2195.6701 90,232 Rdpwd.sys
04-Sep-2003 17:06 5.0.2195.6801 5,232,128 Sp3res.dll
10-Sep-2003 18:52 5.0.2195.6799 380,176 User32.dll
10-Sep-2003 18:52 5.0.2195.6794 385,808 Userenv.dll
08-Sep-2003 17:21 5.0.2195.6817 1,628,464 Win32k.sys
03-Sep-2003 22:13 5.0.2195.6815 182,032 Winlogon.exe
10-Sep-2003 18:52 5.0.2195.6775 243,984 Winsrv.dll
10-Sep-2003 18:52 5.0.2195.6816 711,440 Kernel32.dll
08-Sep-2003 17:21 5.0.2195.6817 1,628,464 Win32k.sys
10-Sep-2003 18:52 5.0.2195.6775 243,984 Winsrv.dll

État

Microsoft a confirmé qu’il s’agit d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à » de cet article.

Plus d'informations

Pour résoudre ce problème, utilisez l’outil Gdiobj.exe pour analyser la colonne pinceau PID 0. PID 0 représente les objets GDI qui ne sont pas privées. Si la colonne de pinceau augmente en permanence mais ne diminue pas, vous pouvez être confronté à la fuite de mémoire qui est décrit dans cet article. Dans ce cas, vous pouvez voir la fuite de mémoire lorsque vous démarrez et arrêtez Microsoft Word ; la colonne de pinceau augmente de 2, mais lorsque vous quittez le programme, il ne diminue pas.

Pour télécharger l’outil Gdiobj.exe, visitez le site Web de Yuan Feng :Pour plus d’informations sur les objets GDI, visitez le site Web de Microsoft à l’adresse suivante :Pour plus d’informations sur la façon de nommer les packages de correctifs, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

816915 d’affectation de noms pour les Packages de correctifs Microsoft Windows

Propriétés

ID d'article : 826518 - Dernière mise à jour : 27 janv. 2017 - Révision : 1

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