Print jobs that you send to a Windows Server 2003 print queue when the printer is out of paper take a long time after you add paper

Symptoms

When you try to print through a Microsoft Windows Server 2003-based print server, and the print queue indicates that the printer is out of paper, the print queue takes a long time to change from the Out of Paper status to the Ready status after you add paper to the printer.

You may notice this problem because there are long delays for print jobs that are sent to the printer. The print jobs remain in the queue until the print queue status changes to Ready.

Cause

This problem may occur when the following conditions are true:
  • Your Windows Server 2003-based computer uses the standard port monitor to control the ports for several TCP/IP printers.
  • The TCP/IP printer ports have Simple Network Management Protocol (SNMP) status enabled.
When the standard port monitor prints to a TCP/IP printer, the standard port monitor uses SNMP to read the configuration of the target printer and to determine the status of the target printer. When the standard port monitor controls many printer ports, the polling scheme for the SNMP status of these printer ports is inefficient. The number of standard TCP/IP ports on a print server directly affects SNMP performance. The more ports there are, the longer it takes to clear an SNMP print-blocking error. Additionally, the standard port monitor waits for blocking SNMP API calls to time out for each unresponsive printer.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
Date         Time   Version            Size    File name
--------------------------------------------------------------
02-Jun-2004 16:21 5.2.3790.178 14,336 Mgmtapi.dll
02-Jun-2004 16:21 5.2.3790.178 16,896 Tcpmib.dll
02-Jun-2004 16:21 5.2.3790.178 46,592 Tcpmon.dll
02-Jun-2004 16:21 5.2.3790.178 43,520 Tcpmonui.dll
02-Jun-2004 16:21 5.2.3790.178 41,472 Wsnmp32.dll
Windows Server 2003, 64-bit editions
Date         Time   Version            Size    File name        Platform
------------------------------------------------------------------------
02-Jun-2004 16:17 5.2.3790.178 42,496 Mgmtapi.dll IA-64
02-Jun-2004 16:17 5.2.3790.178 42,496 Tcpmib.dll IA-64
02-Jun-2004 16:17 5.2.3790.178 142,336 Tcpmon.dll IA-64
02-Jun-2004 16:17 5.2.3790.178 105,984 Tcpmonui.dll IA-64
02-Jun-2004 16:17 5.2.3790.178 116,224 Wsnmp32.dll IA-64
02-Jun-2004 16:21 5.2.3790.178 14,336 Wmgmtapi.dll x86
02-Jun-2004 16:21 5.2.3790.178 16,896 Wtcpmib.dll x86
02-Jun-2004 16:21 5.2.3790.178 46,592 Wtcpmon.dll x86
02-Jun-2004 16:21 5.2.3790.178 43,520 Wtcpmonui.dll x86
02-Jun-2004 16:21 5.2.3790.178 41,472 Wwsnmp32.dll x86

Workaround

To work around this problem, turn off SNMP port status for the print queues. To do this, follow these steps:
  1. Click Start, and then click Printers and Faxes.
  2. Right-click the printer, and then click Properties.
  3. Click the Ports tab.
  4. Click Configure Port.
  5. Click to clear the SNMP Status Enabled check box, click OK, and then click Close.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Propriétés

ID d'article : 835933 - Dernière mise à jour : 29 mai 2008 - Révision : 1

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