L’état d’un expéditeur n’est pas mis à jour fermé et l’écran de la visionneuse du journal expéditeur mise à jour (40.460.00) n’inclut pas une entrée pour l’ID de l’expéditeur dans la gestion des commandes dans Microsoft Dynamics SL

S’applique à : Dynamics SL 2011Dynamics SL 2015

Symptômes


Après avoir terminer ou annuler un expéditeur, la valeur dans la zone de statut n’est pas mis à jour fermé dans la gestion des commandes dans Microsoft Dynamics SL.

Remarque la zone d’état s’affiche sur l’onglet Autres informations dans l’écran de Messagers (40.110.00) .  En outre, l’écran de la visionneuse du journal expéditeur mise à jour (40.460.00) n’inclut pas une entrée pour l’ID de l’expéditeur.

Cause


Cause 1
Le paramètre de mise à jour de retard expéditeur est incorrect. Reportez-vous à la résolution 1.

Cause 2
Le paramètre de durée de mise en veille pour le Gestionnaire de processus est trop petit. Reportez-vous à la section Résolution 2

Cause 3
L’étape de l’expéditeur de la mise à jour sous l’onglet étapes , dans l’écran Types de commande (40.200.00) est configuré correctement. Reportez-vous à la résolution 3.

Cause 4
Le type de commande a été modifié sur l’onglet étapes , dans l’écran Types de commande (40.200.00) avant de chargeurs existants ont été fermés. Consultez résolution 4.

Cause 5
Les personnalisations ont été ajoutées à l’écran de Messagers (40.110.00) qui a interrompu le traitement des enregistrements de l’expéditeur. Consultez résolution de 5.

Cause 6
Toute cause provoquer autre que 1 à la cause 5.  Dans ce cas, ce problème se produit quel que soit le type de commande. Consultez résolution 6 ou 7 de résolution.


Résolution


Resolution 1
Vérifiez que le paramètre pour retarder la mise à jour de l’expéditeur n’est pas trop grand. Pour ce faire, procédez comme suit :

  1. Dans le menu Module , cliquez sur commande gestion.
  2. Dans le volet Gestion des commandes , cliquez sur Paramètres de gestion de commande dans le programme d’installation.
  3. Sous l’onglet autre , assurez-vous que la valeur dans la zone de Mise à jour de l’expéditeur de délai (en minutes) n’est pas trop grande.

    Remarque Si la valeur de la Mise à jour de l’expéditeur de délai (minutes) est définie sur 30, l’expéditeur ne se fermera pas 30 minutes après avoir terminé l’enregistrement de l’expéditeur.

Résolution 2
Augmenter le temps de mise en veille pour le processus du Gestionnaire de processus. Pour ce faire, procédez comme suit :

  1. Dans le menu Module , cliquez sur commande gestion.
  2. Dans le volet Gestion des commandes , cliquez sur Paramètres de gestion de commande dans le programme d’installation.
  3. Sous l’onglet autre , tapez 15 dans la zone Durée de veille de gestionnaire de processus (secondes) si la valeur de la zone est inférieure à 15.

Résolution 3
Corriger l’état de l’étape dans le type de commande. Pour ce faire, procédez comme suit :

  1. Dans la liste des Modules , cliquez sur commande gestion.
  2. Dans le volet Gestion des commandes , cliquez sur Types de commande en cours de Maintenance.
  3. Dans la zone Type de commande , tapez l’ID de type de commande que vous souhaitez modifier.
  4. Sous l’onglet étapes , cliquez sur obligatoire dans l' état de l’étape de l’expéditeur de la mise à jour.
  5. Cliquez sur Enregistrer. Puis fermez l’écran Types de commande (40.200.00) .

Resolution 4
Annuler les chargeurs et les commandes ventes associées. Pour ce faire, procédez comme suit :

  1. Dans la liste des Modules , cliquez sur Gestion des commandes.
  2. Dans le volet Gestion des commandes , cliquez sur Confirmation de livraison sous entrée.
  3. Dans la zone ID de l’expéditeur , tapez l’ID de l’expéditeur que vous souhaitez annuler.
  4. Activez les cases à cocher suivantes :
    • Annuler l’expéditeur
    • Annuler la commande
  5. Cliquez sur Terminer. Ensuite, fermez la Confirmation de livraison (40.117.00) écran.

Résolution 5
Supprimer les personnalisations de l’écran Shippers(40.110.00) . Pour ce faire, procédez comme suit :

  1. Fermez tous les écrans, à l’exception de l’écran Shippers(40.110.00) .
  2. Dans le menu Personnaliser , cliquez sur Personnaliser le Mode.
  3. Dans le menu Personnaliser , cliquez sur Supprimer les modifications d’écran.
  4. Cliquez sur Oui, puis cliquez sur OK.
  5. Fermez l’écran Shippers (40.110.00) . Ouvrez l’écran.

Resolution 6
Modifier l’ordre des chargeurs à une commande qui est reconnue par le Gestionnaire de processus. Pour ce faire, procédez comme suit.

Remarque Avant de suivre les instructions de cette procédure, assurez-vous que vous disposez d’une copie de sauvegarde complète de la base de données que vous pouvez restaurer si un problème survient.

  1. Dans l’écran Gestionnaire de processus (40.400.00) , cliquez sur Arrêter.
  2. À l’aide de l’Analyseur de requêtes SQL Microsoft ou Microsoft SQL Server Management Studio, exécutez l’instruction appropriée sur la base de données de l’application.
    • Microsoft SQL Server 7.0
    • Microsoft SQL Server 2000 ou Microsoft SQL Server 2005 ou Microsoft SQL Server 2008
  3. Copier les résultats de l’instruction dans une nouvelle fenêtre. Exclure les en-têtes de colonnes ou les lignes de comptage. Exécutez ensuite l’instruction new pour requeue les expéditeurs qui sont répertoriés.

    Remarque L’instruction suivante est un exemple des résultats que vous copiez.
  4. Dans l’écran Gestionnaire de processus (40.400.00) , cliquez sur Démarrer.

Resolution 7
Annuler l’expéditeur. Pour ce faire, procédez comme suit :

  1. Dans la liste des Modules , cliquez sur Gestion des commandes.
  2. Dans le volet Gestion des commandes , cliquez sur expéditeurs sous l’entrée.
  3. Sous l’onglet Autre , cliquez pour sélectionner la case à cocher annulé , puis cliquez sur Terminer.