Message d’erreur « Erreur 633 : le modem (ou tout autre périphérique de connexion) est déjà utilisé » lorsque vous essayez d’établir une connexion VPN

Cet article fournit une solution de contournement au problème dans lequel vous ne pouvez peut-être pas établir une connexion VPN en raison d’un conflit de port TCP.

Produit concerné : Windows Server 2003
Numéro de la base de connaissances d’origine : 885959

Importante

Cet article contient des informations sur la modification du Registre. Avant d’effectuer cette opération, veillez à sauvegarder le Registre et à bien comprendre comment le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows

Symptômes

Lorsque vous essayez d’utiliser une connexion de réseau privé virtuel (VPN) sur un ordinateur Microsoft Windows Server 2003, le message d’erreur suivant peut s’afficher :

Erreur 633 : le modem (ou tout autre périphérique de connexion) est déjà utilisé ou n’est pas configuré correctement.

Cause

Ce problème peut se produire si le port TCP utilisé par la connexion VPN est déjà utilisé par un autre programme. La connexion VPN utilise le port TCP 1723 pour établir une connexion. Si un autre programme utilise déjà ce port, vous ne pouvez pas établir de connexion VPN.

Solution de contournement

Avertissement

Toute mauvaise utilisation de l’Éditeur du Registre risque de générer de graves problèmes, pouvant vous obliger à réinstaller votre système d’exploitation. Microsoft ne peut garantir que les problèmes résultant d’une mauvaise utilisation de l’Éditeur du Registre puissent être résolus. Vous assumez l’ensemble des risques liés à l’utilisation de cet outil.

Pour contourner ce problème, appliquez l’une des méthodes suivantes :

  • Réservez explicitement le port TCP utilisé pour la connexion VPN. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer, sur Exécuter, tapez regedit.exe dans la zone Ouvrir , puis cliquez sur OK.
    2. Dans la Rédacteur du Registre, recherchez et cliquez sur la sous-clé de Registre suivante :HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    3. Dans le menu Modifier , pointez sur Nouveau, puis cliquez sur Valeur multi-chaîne.
    4. Renommez la valeur multi-chaîne « ReservedPorts », puis double-cliquez sur ReservedPorts.
    5. Dans la zone Données de la valeur , tapez 1723-1723, puis cliquez sur OK.
    6. Quittez l’Éditeur du Registre.
  • Utilisez la commande netstat pour rechercher le programme qui utilise le port 1723. Ensuite, mettez fin au processus pour ce programme. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer, sur Exécuter, tapez cmd.exe dans la zone Ouvrir , puis cliquez sur OK.

    2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
      netstat -aon

    3. Dans la sortie qui s’affiche, identifiez l’ID de processus du programme, le cas échéant, qui utilise le port TCP 1723.

    4. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
      taskkill /PID PID /F

      Remarque

      La commande taskkill met fin au processus qui correspond au numéro d’ID du processus. L’option /F est utilisée pour mettre fin avec force au processus.

    5. À l’invite de commandes, tapez exit, puis appuyez sur Entrée pour quitter l’invite de commandes.

  • Restart your computer. Cela peut entraîner l’utilisation d’un port différent par le programme qui utilise le port TCP 1723.