L’onglet Versions précédentes pour un fichier ou un dossier dans un partage DFS ne s’affiche pas dans Windows Server 2003 et Windows XP

Symptômes

Prenons le scénario suivant : vous utilisez une session de Services Terminal Server sur un ordinateur Microsoft Windows Server 2003 ou sur un ordinateur Microsoft Windows XP pour vous connecter à un partage de système de fichiers distribués (DFS, Distributed File System) dans une racine DFS de domaine. En outre, les conditions suivantes sont remplies :
  • La racine DFS est hébergée sur un contrôleur de domaine Windows Server 2003 ou sur un contrôleur de domaine Microsoft Windows 2000.
  • Si la racine DFS est hébergée sur un contrôleur de domaine Windows Server 2003, la fonctionnalité clichés instantanés de dossiers partagés n’est pas activée sur ce contrôleur de domaine.
  • Le partage DFS est un dossier partagé sur un ordinateur qui exécute Windows Server 2003. La fonctionnalité clichés instantanés de dossiers partagés est activée sur ce serveur.
Lorsque vous affichez les propriétés d’un fichier ou d’un dossier qui se trouve dans le dossier partagé, l’onglet Versions précédentes n’est pas affiché dans la boîte de dialogue Propriétés de FileNameOrFolderName . Vous pensez que l’onglet Versions précédentes , si la fonctionnalité clichés instantanés de dossiers partagés est activée sur le serveur.

Cause

Lorsque vous affichez les propriétés d’un fichier ou d’un dossier, l’ordinateur client Windows vérifie pour déterminer si les captures instantanées sont disponibles. Les informations sur les instantanés sont mises en cache sur l’ordinateur client. Si la fonctionnalité clichés instantanés de dossiers partagés n’est pas activée sur le serveur qui héberge la racine DFS, le client détecte que les captures instantanées ne sont pas disponibles. Ces informations sont mises en cache sur l’ordinateur client et sont appliquées à tous les dossiers et les sous-dossiers situés sous la racine DFS, même si les captures instantanées sont disponibles pour les dossiers et les sous-dossiers.

Résolution

Windows Server 2003

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
Conditions préalables

Aucunes conditions préalables ne sont requises.
Nécessite un redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.
Informations sur les fichiers
La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans le Panneau de configuration.

Windows Server 2003, éditions 32 bits

Date         Time   Version       Size    File name---------------------------------------------------
06-Jan-2005 02:06 6.0.3790.245 69,120 Twext.dll

Windows Server 2003, Édition 64 bits

Date         Time   Version        Size    File name  Platform--------------------------------------------------------------
06-Jan-2005 02:02 6.0.3790.245 154,112 Twext.dll IA-64
06-Jan-2005 02:06 6.0.3790.245 69,120 Wtwext.dll x86

Windows XP

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
Conditions préalables

Aucunes conditions préalables ne sont requises.
Nécessite un redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.
Informations sur les fichiers
La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans le Panneau de configuration.

Windows XP, éditions 32 bits

Date         Time   Version        Size    File name  SP level--------------------------------------------------------------
15-Dec-2004 18:50 6.0.3800.2580 45,056 Twext.dll SP2
15-Dec-2004 19:04 6.0.3800.1613 39,936 Twext.dll SP1

Windows XP Édition 64 bits

Date         Time   Version         Size    File name  Platform---------------------------------------------------------------
15-Dec-2004 18:59 6.0.3800.1613 130,560 Twext.dll IA-64
15-Dec-2004 19:04 6.0.3800.1613 39,936 Wtwext.dll x86

Solution de contournement

Pour contourner ce problème, activez la fonctionnalité de clichés instantanés de dossiers partagés sur le contrôleur de domaine Windows Server 2003 qui héberge la racine DFS. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, cliquez sur Poste de travail, puis cliquez sur Gérer.
  2. Développez Outils système , si ce n’est pas déjà fait.
  3. Droit sur les Dossiers partagés, pointez sur Toutes les tâches, puis cliquez sur Configurer les clichés.
  4. Cliquez sur le volume qui héberge la racine DFS, puis cliquez sur Activer.
  5. Si vous êtes invité à confirmer l’opération, cliquez sur Oui.
  6. Cliquez sur OK.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d’informations sur le Service cliché instantané de Volume, visitez le site Web de Microsoft à l’adresse suivante :Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft
Propriétés

ID d'article : 887189 - Dernière mise à jour : 18 févr. 2017 - Révision : 2

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