A scheduled task that is running under a specific account cannot access a shared network resource in Windows XP

Symptoms

On a Microsoft Windows XP-based computer, a scheduled task that is running under a specific account cannot access a shared network resource. This symptom occurs when the following conditions are true:
  • The specific account has an interactive session that was opened by using a smart card. Specifically, the user uses a personal identification number (PIN) instead of a password to open the interactive session.
  • The Kerberos ticket (TGT) has expired.
After the scheduled task cannot access the shared network resource, an event that is similar to the following may be logged in the Application event log:
Event Type: Warning
Event Source: LSASRV
Event Category: SPNEGO (Negotiator)
Event ID: 40960
Date: 5/19/2004
Time: 9:25:51 AM
User: N/A
Computer: DEVXPVMWARE

Description:
The Security System detected an attempted downgrade attack for server cifs/secur012.SECURDOM2.com. The failure code from authentication protocol Kerberos was "No PIN was presented to the smart card (0xc0000382)".

Cause

When the Task Scheduler service runs a job by using a specific account, the Task Scheduler service tries to determine whether this account is also the account of the current logged-on user. If the account is that of the current logged-on user, the security context of the scheduled task is mapped to the security context of that user. This process directs scheduled jobs to that user's desktop.

Additionally, if the scheduled task user account is the account of the current logged-on user, and if that user uses a smart card to log on, the network access attempt by the scheduled task may fail. This network access failure occurs when the TGT ticket is expired. In this scenario, the TGT update process fails. Because the security context comers through a smart card logon, the TGT update process requires that the user provide a PIN. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
323931 User token expires when you log on by using a smart card for a long time

Note Assume that the TGT update process fails because the user did not type a PIN. In this scenario, the NTLM authentication protocol is not used, even if the Simple and Protected GSS-API Negotiation (SPNEGO) security package is used. For more information about SPNEGO, visit the following IETF Web site: .

Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP Service Pack 1 (SP1)

Date Time Version Size File name
--------------------------------------------------------------
30-Apr-2005 01:43 5.1.2600.1677 258,560 Mstask.dll
29-Apr-2005 23:40 5.1.2600.1677 10,752 Mstinit.exe
30-Apr-2005 01:43 5.1.2600.1677 173,568 Schedsvc.dll
29-Apr-2005 23:47 5.1.2600.1677 594,432 Xpsp2res.dll
Windows XP Service Pack 2 (SP2)

Date Time Version Size File name
--------------------------------------------------------------
30-Apr-2005 01:07 5.1.2600.2667 192,000 Schedsvc.dll
This hotfix creates the following new registry subkey:
HKEY_LOCAL_MACHINE\Software\Microsoft\SchedulingAgent\DisableUSeOfTokenFromSession
This subkey lets you disable the correlation between the following two items:
  • The Task Scheduler security context, where the security principal is specified by a password
  • The security context that is related to the existing user session, where the security principal is specified by a smart card and a PIN
To enable the hotfix, set the value of the DisableUSeOfTokenFromSession registry entry to
1.
Note The new UseOfSessionTokenDisabled registry entry and the Run only if logged on option in Windows XP Service Pack 2 (SP2) are mutually exclusive and should not be used at the same time.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Propriétés

ID d'article : 887572 - Dernière mise à jour : 9 oct. 2011 - Révision : 1

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