Sons ne sont pas lus après la reprise de Windows à partir de la mise en veille prolongée sur un ordinateur qui exécute Windows XP Service Pack 2

Symptômes

Sur un ordinateur qui exécute Microsoft Windows XP Service Pack 2 (SP2), sons ne sont pas lus après la reprise de Windows à partir de la mise en veille prolongée.

Si vous redémarrez l’ordinateur, Windows lit les sons comme prévu.

Cause

Ce problème se produit car il existe une condition de concurrence dans le pilote Portcls.sys. Ce pilote est un pilote de classe Audio de Windows. Un scénario de concurrence peut se produire lorsque les conditions suivantes sont remplies :
  • Le pilote Portcls.sys reçoit une demande IRP_MJ_DEVICE_CONTROL après que Windows sort de la mise en veille prolongée.
  • Le pilote Portcls.sys n’a pas encore renvoyé à la PowerDeviceD0 état de l’alimentation (D0).

    Remarque Un périphérique est Advanced Configuration and Power Interface (ACPI) conforme a quatre états de l’alimentation. L’état D0 représente l’état d’alimentation. La catégorie D1 à travers les États d’alimentation D3 représentent les États d’alimentation en mode veille.
Dans ce scénario, le pilote Portcls.sys peut marquer le paquet de demande de contrôle d’e/s (IRP) comme STATUS_PENDING. Toutefois, il ne termine jamais l’IRP. Les composants de niveau supérieur de la pile Audio qui attendent que cet IRP à compléter bloquent toutes les demandes audio supplémentaires. Par conséquent, des fichiers audio ne sont pas lus après la reprise de Windows à partir de la mise en veille prolongée.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans le Panneau de configuration.
   Date         Time   Version            Size    File name   --------------------------------------------------------------
22-Mar-2005 03:43 5.1.2600.2637 145,920 Portcls.sys
25-Feb-2005 03:53 6.1.22.4 371,936 Updspapi.dll

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft


Obtenir des informations connexes :

Résolution des problèmes : Pas de son dans Windows

Musique et son aident avec Windows 7
Propriétés

ID d'article : 892559 - Dernière mise à jour : 27 janv. 2017 - Révision : 1

Commentaires