Une instance de l’hôte de BizTalk Server échoue et une erreur de « Réseau général » est écrite dans le journal des applications lorsque le serveur basé sur BizTalk Server traite un volume élevé de documents

Symptômes

Une instance de l’hôte de Microsoft BizTalk Server échoue et puis redémarre de lui-même, et les erreurs qui sont semblables aux suivants sont écrits dans le journal d’Application de BizTalk Server :
Type d’événement : erreur

Événement Source : BizTalk Server 2004

Événement Category:(1)

Événement ID:6913

Computer:BizTalkServer
Description :
SQLServer, BizTalkMsgBoxDb, [DBNETLIB] [ConnectionWrite (send()).] Erreur de réseau générale. Consultez votre documentation réseau...
Type d’événement : avertissement

Événement Source : BizTalk Server 2004

Événement Category:(1)

Événement ID:5410

Computer:BizTalkServer
Description : Une erreur s’est produite qui nécessite le service BizTalk pour terminer. Les causes les plus courantes sont une erreur de mémoire et une incapacité à se connecter ou une perte de connectivité à une base de données BizTalk. Le service va s’arrêter, puis redémarrera automatiquement dans 1 minute. Si la base de données à l’origine du problème n’est pas disponible, ce cycle se répète.



Message d’erreur : [DBNETLIB] [ConnectionWrite (send()).] Erreur de réseau générale. Consultez votre documentation réseau.


Source de l’erreur :


Nom de l’hôte BizTalk : BizTalkHost
Nom du service Windows de BizTalk : BTSSvc$ BizTalkHost.
Ce problème se produit généralement lorsque le serveur basé sur BizTalk Server traite un volume élevé de documents.

Cause

Ce problème se produit car Windows Server 2003 et les versions ultérieures implémentent une fonctionnalité de sécurité qui réduit la taille de la file d’attente pour les connexions TCP/IP simultanées au serveur. Cette fonctionnalité permet d’éviter les refus de service. Dans des conditions de charge importante, le protocole TCP/IP peut identifier incorrectement une connexions TCP/IP valide sous la forme d’une attaque par déni de service. Ce comportement peut entraîner le problème qui est décrit dans la section « Symptômes ».

Résolution

Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Vous pourriez alors restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder et de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 comment sauvegarder et restaurer le Registre dans Windows


Pour résoudre ce problème, désactivez cette fonctionnalité en ajoutant l’entrée SynAttackProtect sur la clé de Registre suivante sur l’ordinateur qui exécute Microsoft SQL Server qui héberge vos bases de données BizTalk Server.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Définissez l’entrée SynAttackProtect sur une valeur DWORD de 00000000. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez regedit, puis cliquez sur OK.
  2. Recherchez, puis cliquez sur la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. Dans le menu Edition , pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  4. Tapez SynAttackProtectet appuyez sur ENTRÉE.
  5. Dans le menu Edition, cliquez sur Modifier.
  6. Dans la zone données de la valeur , tapez 00000000. Cliquez sur OK.
  7. Quittez l’Éditeur du Registre.
Remarque Pour effectuer cette modification du Registre, vous devez redémarrer l’ordinateur qui exécute SQL Server.

État

Ce comportement est voulu par la conception.
Propriétés

ID d'article : 899599 - Dernière mise à jour : 27 janv. 2017 - Révision : 1

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