Word n'enregistre pas les modifications ou vous recevez un message d'erreur dans un programme Office après avoir installé Adobe Acrobat 7.0


Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows

Symptômes


Lorsque vous utilisez l'un des programmes Microsoft Office figurant dans la liste des produits concernés par cet article, vous pouvez rencontrer un ou plusieurs des problèmes suivants :
  • Lorsque vous modifiez l'espace de travail dans Microsoft Word, les modifications ne sont pas enregistrées lorsque vous quittez Word. Ces modifications de l'espace de travail peuvent notamment inclure les exemples suivants :
    • Vous créez une macro.
    • Vous modifiez la police par défaut.
    • Vous ajoutez une insertion automatique.
    • Vous ajoutez une barre d'outils.
    Lorsque vous redémarrez Word, les éléments que vous avez modifiés ou ajoutés ne sont pas disponibles.

    Remarque Ce problème se produit même si la case à cocher Confirmer l'enregistrement de Normal.dot est activée.
  • Lorsque vous essayez de démarrer un programme Office, vous recevez un message d'erreur semblable à l'un des suivants :
    Erreur d'exécution Visual C++
    Bibliothèque d'exécution Microsoft Visual C++

    Program files\Microsoft office\office10\nom_produit.exe

    Cette application a demandé une interruption anormale de l'exécution.
  • Lorsque vous ouvrez un document Word, le message d'erreur suivant s'affiche :
    Mémoire ou espace disque insuffisants. Impossible d'afficher la police demandée.

Cause


Ces problèmes peuvent se produire après l'installation d'Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard ou Adobe Acrobat 7.0 Elements.

Acrobat 7.0 installe un complément COM dans le dossier suivant :
\Acrobat 7.0\PDFMaker\Office
Ce complément COM fournit des icônes PDFMaker et des commandes de menu pour les programmes Office.

Contournement


Pour contourner ce problème, appliquez l'une des méthodes ci-dessous selon votre situation. Si les modifications ne sont pas enregistrées lorsque vous fermez Word, utilisez la méthode 1 ou 2. Si vous recevez un message d'erreur lorsque vous essayez de démarrer un programme Office ou d'ouvrir un document Word, utilisez la méthode 3 ou 4.

Méthode 1 : Enregistrement des macros, des préférences et des paramètres personnalisés dans Word à l'aide de la commande « Enregistrer tout » du menu Fichier

Remarque Cette méthode ne concerne pas Microsoft Office Word 2007.

Pour enregistrer manuellement des macros, des préférences et des paramètres personnalisés dans Word 2003 et les versions antérieures de Word, procédez comme suit :
  1. Appuyez sur la touche MAJ et maintenez-la enfoncée.
  2. Dans le menu Fichier, cliquez sur Enregistrer tout.
Les modifications sont enregistrées. En outre, elles sont disponibles dans d'autres documents Word.

Méthode 2 : Ajout de la commande « Enregistrer tout »

Dans Word, cliquez sur la commande Enregistrer tout chaque fois que vous créez une macro, une préférence ou un paramètre personnalisé.

Pour ajouter la commande Enregistrer tout dans Word, effectuez l'une des opérations suivantes :

  • Dans Word 2007, suivez ces étapes pour ajouter la commande Enregistrer tout à la barre d'outils Accès rapide :
    1. Cliquez sur le bouton Microsoft Office, puis sur Options Word.
    2. Cliquez sur Personnaliser.
    3. Dans la zone Choisir les commandes dans les catégories suivantes, cliquez sur Toutes les commandes.
    4. Dans la liste sous la zone Choisir les commandes dans les catégories suivantes, cliquez sur Enregistrer tout, puis sur Ajouter.
    5. Cliquez sur OK pour fermer la boîte de dialogue Options Word.
  • Dans Word 2003 et les versions antérieures de Word, suivez ces étapes pour ajouter la commande Enregistrer tout au menu Fichier :
    1. Dans le menu Outils, cliquez sur Personnaliser.
    2. Sous l'onglet Commandes, cliquez sur Fichier sous Catégories.
    3. Sous Commandes, faites glisser Enregistrer tout dans le menu Fichier. Lorsque le menu Fichier s'ouvre, placez la commande Enregistrer tout à l'emplacement souhaité.
    4. Fermez la boîte de dialogue Personnaliser.

Méthode 3 : Contacter Adobe

Contactez Adobe Systems Incorporated pour déterminer si une mise à jour est disponible pour Acrobat 7.0.

Pour obtenir les coordonnées d'Adobe Systems Incorporated, cliquez sur le numéro approprié ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
65416 Liste des fournisseurs tiers de matériels et de logiciels, A-K

60781 Liste des fournisseurs tiers de matériels et de logiciels, L-P

60782 Liste des fournisseurs tiers de matériels et de logiciels, Q-Z
Microsoft fournit les coordonnées de sociétés tierces afin de vous aider à trouver un support technique. Ces informations peuvent être modifiées sans préavis. Microsoft ne garantit en aucun cas l'exactitude des informations concernant les sociétés tierces.

Méthode 4 : Suppression du complément Adobe d'Office

Si vous supprimez le complément Adobe, vous ne pourrez pas enregistrer un fichier au format PDF (Portable Document File) dans un programme Office.

Pour supprimer le complément Adobe, procédez comme suit :

Remarque Dans la mesure où il existe plusieurs versions de Microsoft Windows, la procédure suivante peut varier en fonction de votre ordinateur. Si tel est le cas, consultez la documentation de votre produit pour effectuer ces opérations.
  1. Quittez tous les programmes.
  2. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  3. Double-cliquez sur Ajout/Suppression de programmes.
  4. Dans la liste Programmes actuellement installés, cliquez sur Adobe Acrobat Professional 7.0, puis sur Modifier.
  5. Cliquez sur Modifier, puis sur Suivant.
  6. Développez Créer un document PDF Adobe.
  7. Développez Acrobat PDFMaker.
  8. Cliquez sur la flèche en regard de Microsoft Office, puis sur Non installé.
  9. Dans l'Assistant Installation d'Adobe Acrobat Professional 7.0, cliquez sur OK.
  10. Fermez l'outil Ajout/Suppression de programmes.
Si vous continuez à rencontrer les problèmes mentionnés plus haut après avoir effectué ces étapes, vous souhaiterez peut-être supprimer manuellement le complément COM du Registre.

Important Avant de supprimer le complément COM manuellement, contactez Adobe pour obtenir des informations supplémentaires.

Avertissement Toute modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou d'une autre méthode peut entraîner des problèmes sérieux. Ces problèmes peuvent vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Pour supprimer le complément Adobe manuellement, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter. Tapez regedit, puis cliquez sur OK.
  2. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin
  3. Dans le menu Fichier, cliquez sur Exporter, tapez un nom de fichier, puis cliquez sur Enregistrer.
  4. Cliquez avec le bouton droit sur l'entrée de Registre PDFMaker.OfficeAddin, puis cliquez sur Supprimer.
  5. Effectuez les étapes 3 et 4 pour supprimer les entrées de Registre du complément dans les sous-clés de Registre suivantes :
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin



    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook
  6. Quittez l'Éditeur du Registre.

Plus d'informations


Le modèle global (fichier Normal.dotm dans Word 2007 et Normal.dot dans Word 2003 et les versions antérieures de Word) est le modèle par défaut qui est utilisé par Word. Par défaut, les modifications qui affectent tous les nouveaux documents sont enregistrées dans le modèle global. Ceci se produit à moins que vous ne spécifiez un autre modèle lorsque vous enregistrez les modifications. Acrobat 7.0 peut empêcher Word d'enregistrer automatiquement les modifications dans modèle global.

Pour plus d'informations sur ce problème, reportez-vous au site Web d'Adobe à l'adresse suivante :