Comment faire pour utiliser l’outil Debug Diagnostics Tool pour résoudre les problèmes d’utilisation élevée du processeur par un processus dans IIS


Résumé


Cet article décrit comment utiliser l’outil Debug Diagnostics Tool v1.2 pour résoudre les problèmes d’utilisation élevée du processeur par un processus dans Microsoft Internet Information Services (IIS).

INTRODUCTION


Forte utilisation du processeur par un processus dans IIS se produit lorsqu’un processus IIS utilise 80 pour cent ou plus de cycles processeur disponibles pour un intervalle de temps constant. Un processus IIS sont W3wp.exe, Dllhost.exe et Inetinfo.exe. En cas de forte utilisation du processeur par un processus IIS, vous rencontrez un ou plusieurs des problèmes suivants :
  • Une page Web ne se charge pas correctement. Par exemple, la page Web est vide ou ne répond pas.
  • Vous rencontrez le ralentissement des performances sur un serveur qui exécute IIS. Par exemple, l’indicateur de progression se déplace très lentement lorsque vous essayez d’afficher une page Web.
Cet article explique comment installer et configurer l’outil Debug Diagnostics Tool pour résoudre les problèmes d’utilisation élevée du processeur par un processus IIS.

Plus d'informations


Si un processus IIS utilise un pourcentage élevé de cycles de processeur disponibles, nous vous conseillons de créer un fichier de vidage mémoire complet du processus IIS lorsque IIS traite les demandes des clients. Vous pouvez utiliser l’outil Debug Diagnostics Tool pour capturer et analyser les fichiers de vidage mémoire lorsque IIS traite les demandes des clients.


Étape 1 : Téléchargez et installez l’outil Debug Diagnostics Tool v1.2

Pour télécharger et installez l’outil Debug Diagnostics Tool, visitez le site Web de Microsoft à l’adresse suivante :

Étape 2 : Configurer la journalisation de l’Analyseur de performances

Pour configurer la journalisation de l’Analyseur de performances, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez le chemin d’accès de l’outil Debug Diagnostics Tool, puis cliquez sur OK.

    Remarque Par défaut, l’outil Debug Diagnostics Tool se trouve dans le dossier suivant :
    C:\Program Files\DebugDiag
  2. Dans le menu Outils , cliquez sur Options et les paramètres.
  3. Sous l’onglet Journal de performances , cliquez sur Activer le compteur de données la consignation des performances, puis cliquez sur OK.

    Remarque La valeur dans la zone Intervalle d’échantillonnage de données dépend de si le problème d’utilisation élevé du processeur se produit. La taille du journal augmente à mesure que les données sont collectées. Pour plus d’informations sur la configuration de la valeur dans la zone Intervalle d’échantillonnage de données , contactez un professionnel du Support Microsoft.

Étape 3 : Désactiver débogage de l’interception des exceptions

Remarque  Si vous configurez l’outil Debug Diagnostics Tool pour utiliser l’outil avec IIS 6.0 ou version ultérieure, passez à le « étape 4 : créer un fichier de vidage. »

Si vous configurez l’outil Debug Diagnostics Tool pour utiliser l’outil avec IIS 5.1 ou IIS 5.0, désactivez l’interception des exceptions de débogage. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, entrez Inetmgr.exeet puis cliquez sur OK.
  2. Avec le bouton droit à l’ordinateur que vous souhaitez configurer, puis cliquez sur Propriétés.
  3. Dans la liste Propriétés principales , cliquez sur Le Service WWW, puis cliquez sur Modifier.
  4. Sous l’onglet Répertoire de base , cliquez sur Configuration.
  5. Sous l’onglet Options du processus , cliquez pour désactiver la case à cocher Activer l’interception des exceptions de débogage , puis cliquez sur OK.

Étape 4 : Créer un fichier de vidage

Pour créer un fichier de vidage, utilisez une des méthodes suivantes.

Méthode 1 : Créer une règle de blocage

Pour créer une règle de blocage, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez le chemin d’accès de l’outil Debug Diagnostics Tool, puis cliquez sur OK.

    Remarque Par défaut, l’outil Debug Diagnostics Tool se trouve dans le dossier suivant :
    C:\Program Files\DebugDiag
  2. Dans l’onglet règles , cliquez sur Ajouter une règle.
  3. Cliquez sur performances, puis sur Les temps de réponse HTTP, puis cliquez sur suivant.
  4. Cliquez sur Ajouter une URL, sélectionnez les options ETW ou Ping, tapez l’URL du site Web dans lequel vous rencontrez le problème, définir les heures de Ping et le délai d’attente appropriée et puis cliquez sur OK. Ensuite, cliquez sur Oui pour tester l’URL.
  5. Cliquez sur OK, puis cliquez sur suivant.
  6. Cliquez sur Ajouter image cible.
  7. Dans la liste Type de cible , cliquez sur le type de cible que vous souhaitez, cliquez sur OK, puis cliquez sur suivant.
  8. Tapez un nom pour la règle, tapez un chemin d’accès de l’emplacement de fichier de vidage utilisateur, puis cliquez sur suivant.
  9. Cliquez sur Activer maintenant la règle, puis cliquez sur Terminer.

    Dans l’onglet règles , notez que la règle est Active dans la colonne État.

Méthode 2 : Créez un fichier IIS blocage vider manuellement

Pour créer un fichier IIS blocage vider manuellement, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez le chemin d’accès de l’outil Debug Diagnostics Tool, puis cliquez sur OK.

    Remarque Par défaut, l’outil Debug Diagnostics Tool se trouve dans le dossier suivant :
    C:\Program Files\DebugDiag
  2. Dans le menu Outils , cliquez sur créer IIS / COM + blocage Dump.

Méthode 3 : Créer un fichier de vidage pour un processus utilisateur dans l’outil Debug Diagnostics Tool

Pour créer un fichier de vidage pour un processus utilisateur, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez le chemin d’accès de l’outil Debug Diagnostics Tool, puis cliquez sur OK.

    Remarque Par défaut, l’outil Debug Diagnostics Tool se trouve dans le dossier suivant :
    C:\Program Files\DebugDiag
  2. Sous l’onglet processus , cliquez sur le processus que vous souhaitez résoudre les problèmes et puis cliquez sur Créer un total Userdump.

Étape 5 : Désactiver la journalisation de l’Analyseur de performances

Environ deux minutes, une fois terminé le processus de capture de fichier de vidage utilisateur, désactiver l’enregistrement de l’Analyseur de performances. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez le chemin d’accès de l’outil Debug Diagnostics Tool, puis cliquez sur OK.

    Remarque Par défaut, l’outil Debug Diagnostics Tool se trouve dans le dossier suivant :
    C:\Program Files\DebugDiag
  2. Dans le menu Outils , cliquez sur Options et les paramètres.
  3. Sous l’onglet Journal de performances , cliquez sur Désactiver le compteur de données la consignation des performances.

Étape 6 : Analyser le fichier de vidage

Pour analyser le fichier de vidage, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez le chemin d’accès de l’outil Debug Diagnostics Tool, puis cliquez sur OK.

    Remarque Par défaut, l’outil Debug Diagnostics Tool se trouve dans le dossier suivant :
    C:\Program Files\DebugDiag
  2. Sous l’onglet Analyse avancée , cliquez sur Ajouter des fichiers de données.
  3. Recherchez, puis cliquez sur le fichier image que vous souhaitez analyser. Cliquez sur Ouvrir.
  4. Sous l’onglet Analyse avancée , cliquez sur Incident/blocage des analyseurs, puis cliquez sur Démarrer l’analyse.
  5. Passez en revue le rapport qui s’affiche dans Microsoft Internet Explorer. Une copie de ce rapport est également stockée dans le dossier suivant :
    C:\Program Files\DebugDiag\Reports
Remarque Si vous souhaitez résoudre les problèmes liés à un fichier .dll personnalisé, inclure les fichiers .pdb personnalisé. Pour inclure les fichiers .pdb personnalisé, cliquez sur Outilset cliquez sur Options et les paramètres, cliquez sur le dossier et les chemins de recherche, tapez le chemin d’accès dans la zone Chemin de recherche de symboles pour le débogage , puis cliquez sur OK.

Références


Pour plus d’informations sur l’utilisation de IIS, visitez le site Web de Microsoft à l’adresse suivante :Pour afficher Microsoft Developer Network (MSDN) Web effectue un cast de savoir comment gérer les problèmes avec IIS, reportez-vous aux sites Web MSDN suivants :
Comment faire pour résoudre les situations où IIS ne répond pas
http://go.microsoft.com/fwlink/?LinkId=40968
Comment faire pour diagnostiquer la mémoire fuites dans IIS
http://go.microsoft.com/fwlink/?LinkId=40969
Comment faire pour résoudre les situations où IIS se ferme de façon inattendue
http://go.microsoft.com/fwlink/?LinkId=40967
Pour plus d’informations sur l’utilisation de l’outil Debug Diagnostics pour dépanner un processus IIS, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :

919792 comment utiliser l’outil Debug Diagnostics pour dépanner un processus qui ne répond plus dans IIS

919790 comment utiliser l’outil IIS Debug Diagnostics pour dépanner une fuite de mémoire dans un processus IIS

919789 comment utiliser l’outil Debug Diagnostics pour dépanner un processus IIS qui s’arrête de façon inattendue