Le client Microsoft.NET Framework 2.0 ferme une connexion persistante à un serveur Web lorsque vous essayez d’accéder à une ressource interdite à partir du serveur Web qui renvoie un code d’état HTTP 403

Symptômes

Lorsque vous essayez d’utiliser HTTP pour accéder à une ressource interdite à partir d’un serveur Web qui renvoie un code d’état HTTP 403, le client de Microsoft.NET Framework 2.0 ferme la connexion permanente au serveur Web. Dans la mesure où une nouvelle connexion doit être négociée pour la demande suivante, ce comportement peut diminuer les performances du serveur Web et client.

Remarques
  • Ce comportement se produit également lorsque vous essayez d’accéder à la ressource interdite à l’aide de HTTPS. Toutefois, ce comportement est voulu par la conception lorsque vous utilisez le protocole HTTPS. Pour afficher les ressources, le client peut avoir à rétablir une nouvelle connexion HTTPS et ré-authentifier sur le serveur Web.
  • Ce problème se produit uniquement lorsque le serveur Web renvoie un code d’état HTTP 403. Le client.NET Framework 2.0 ne ferme pas la connexion permanente lorsque le serveur Web renvoie les autres codes d’état.
  • Ce problème ne se produit pas lorsque vous utilisez les versions de Microsoft.NET Framework 1.1 ou une version antérieures du.NET Framework.

Cause

Ce problème se produit car le 2.0 de.NET Framework répond de façon incorrecte pour le code d’état HTTP 403 lorsque le.NET Framework n’utilise pas communication de Secure Sockets Layer (SSL) HTTP.

Résolution

Un correctif est désormais disponible auprès de Microsoft, mais il ne vise qu'à corriger le problème décrit dans cet article. Doit être appliqué uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ce problème, nous vous recommandons d’attendre le prochain service pack.NET Framework 2.0 qui comprendra ce correctif.

Pour résoudre ce problème immédiatement, contactez les Services de Support technique Microsoft pour obtenir le correctif. Pour obtenir une liste complète des numéros de téléphone des Services de Support technique Microsoft et des informations sur les coûts de support, visitez le site Web de Microsoft à l'adresse suivante :Remarque Dans des cas particuliers, des frais généralement encourus pour les appels au support technique peuvent être annulés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Conditions préalables

La liste suivante contient les conditions préalables pour le correctif :
  • Le Microsoft.NET Framework 2.0

Nécessite un redémarrage

Vous n'êtes pas obligé de redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et d’heure dans le panneau de configuration.

Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
System.dll2.0.50727.1633,018,75204-Jun-200609:24x86

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

Propriétés

ID d'article : 919804 - Dernière mise à jour : 17 janv. 2017 - Révision : 1

Commentaires