Vous pouvez rencontrer divers problèmes lorsque vous travaillez avec des fichiers sur le réseau sur un ordinateur basé sur Windows 2000 Server ou Windows Server 2003

Symptômes

Sur un ordinateur basé sur Microsoft Windows 2000 Server ou Microsoft Windows Server 2003, vous pouvez rencontrer un ou plusieurs des problèmes suivants lorsque vous travaillez avec des fichiers sur le réseau :
  • Un serveur de fichiers Windows configuré comme serveur de fichiers et impression cesse de répondre. Puis, la fonctionnalité de serveur de fichiers et d’impression s’arrête temporairement.
  • Vous observez un délai lorsque vous ouvrez, enregistrez, fermez, supprimez ou imprimez des fichiers qui sont trouvent sur une ressource partagée.
  • Vous rencontrez une baisse temporaire des performances lorsque vous utilisez un programme sur le réseau. En règle générale, les performances sont lentes pour environ 40 à 45 secondes. Toutefois, certains délais peuvent durer jusqu'à 5 minutes.
  • Vous rencontrez un délai lorsque vous copiez une copie du fichier ou lorsque vous effectuez des opérations de sauvegarde.
  • Lorsque vous vous connectez à une ressource partagée, l’Explorateur Windows soit cesse de répondre ou si vous voyez un X rouge sur le lecteur réseau connecté.
  • Un programme cesse de répondre que soit utilise l’appel de procédure distante (RPC) ou qui utilise des canaux nommés pour se connecter à un serveur de fichiers.
  • Le serveur temporairement cesse de répondre et un ou plusieurs messages d’ID d’événement qui ressemblent aux messages suivants s’affichent dans le journal système sur le serveur de fichiers :
    Event ID: 2022 Source: Srv Type: Error Description: Server was unable to find a free connection <number> times in the last <number> seconds. 
    Event ID: 2021 Source: Srv Type: Error Description: Server was unable to create a work item <number> times in the last <number> seconds. 
    Event ID: 2020 Source: Srv Type: Error Description: The server was unable to allocate from the system paged pool because the pool was empty. 
    Event ID: 2019 Source: Srv Type: Error Description: The server was unable to allocate from the system nonpaged pool because the pool was empty.  
    Event ID: 2510 Source: Server Event Type: Error Description: The server service was unable to map error code 1722. 
    En outre, l’événement suivant peut s’afficher dans le journal système sur l’ordinateur client :
    Event ID: 3013 Event Type: Error Event Source: MrxSmb /Rdr Description: The redirector has timed out a request to <ComputerName>. 
  • Vous recevez un des messages d’erreur suivants lorsque vous essayez de vous connecter à une ressource partagée :
    Erreur système 53. Le chemin d’accès réseau est introuvable. (ERROR_BAD_NETPATH)
    Erreur système 64. Le nom réseau spécifié n’est plus disponible. (ERROR_NETNAME_DELETED)
  • Vous êtes déconnecté par intermittence des ressources réseau, et vous ne pouvez pas vous reconnecter aux ressources réseau sur le serveur de fichiers. Toutefois, vous pouvez contacter le serveur, et vous pouvez utiliser une session de Services Terminal Server pour se connecter au serveur.
  • Si plusieurs utilisateurs tentent d’accéder aux documents Microsoft Office sur le serveur, la boîte de dialogue fichier est verrouillé pour modification n’apparaît pas toujours lorsque le deuxième utilisateur ouvre le fichier.
  • Une trace réseau indique qu’est un de 30 à 40 seconde entre une commande de client de Service server message block (SMB) et une réponse du serveur de fichiers.
  • Dans Windows Server 2003 et Windows 2000 Service Pack 4 (SP4), le serveur peut cesser de répondre de façon arbitraire.
  • Lorsque vous essayez d’ouvrir un fichier de base de données Microsoft Access 2.0 (.mdb) dans Microsoft Access 97, Access 2000 ou Access 2002, vous pouvez recevoir un message d’erreur semblable au suivant :
    Erreur disque ou réseau.
  • Lorsque vous ouvrez Microsoft Excel, le message d’erreur suivant s’affiche :
    fichier n’a pas été enregistré.
  • Lorsque vous ouvrez l’Explorateur Windows, le message d’erreur suivant s’affiche :
    Impossible d’accéder < chemin d’accès et nom de fichier >. La session a été annulée.
  • Lorsque vous ouvrez un fichier Microsoft Word, Word peut échouer. Ensuite, vous pouvez recevoir le message d’erreur suivant :
    Échec de la lecture de ce fichier < nom du fichier >. Veuillez restaurer la connexion réseau ou remplacez la disquette, puis réessayez.
    En outre, après la restauration de la connexion réseau et que vous cliquez sur OK, le message d’erreur suivant s’affiche :
    Données ont été perdues en raison d’une connexion réseau défectueuse ou d’un disque endommagé. Les documents correspondant à ces données seront enregistrés et fermés.

Cause

Ces problèmes peuvent se produire lorsqu’une des conditions suivantes est remplie :
  • La version du pilote de gestionnaire d’événements Symantec (Symevent.sys) est obsolète. Par conséquent, deux ou plusieurs threads sont bloquées dans le pilote Symevent.sys dans la fonction Symevent_GetSubTask .
  • Il existe un Computer Associates (CA) INO_FLTR. SYS OpLock problème d’interopérabilité avec le fichier Srv.sys.

Résolution

Pour résoudre ces problèmes, mettez à jour le pilote de filtre de système de fichiers d’antivirus tiers. Par exemple, si vous avez le pilote de gestionnaire d’événements Symantec (SymEvent.sys) installé sur l’ordinateur, mettre à jour vers la version 11.6.4.1 ou une version ultérieure. Pour obtenir une version mise à jour du fichier Symevent.sys, ou pour obtenir de l’aide avec la reconfiguration, visitez le site Web de Symantec suivant :

Remarque : La version du fichier SymEvent.sys 11.6.4.2 comporte un bogue qui peut rendre certains serveurs à redémarrer de façon arbitraire. Pour plus d’informations sur le fabricant de votre matériel, visitez le site Web suivant :

Plus d'informations

Tous les messages d’erreur qui sont mentionnés dans le point de la section « Symptômes » à l’échec des connexions SMB. Ces échec des connexions peuvent être le réseau. Ou les connexions défectueuse peuvent se produire lorsque le serveur cesse de répondre de façon arbitraire.

Les versions suivantes de pilote antivirus peuvent également entraîner des serveurs à cesser de répondre :
  • Ce problème est connu pour se produire lorsque les versions de pilotes suivantes sont installées sur le serveur de fichiers.
    NomSociétéVersion francaiseDateDescription
    Symevent.sysSymantec Corporation11.4:0.605-Mar-2004Bibliothèque d’événements de Symantec
    Symtdi.sysSymantec Corporation5.3:6.13
    23-Dec-2004Pilote d’envoi réseau
    Ces versions sont installées avec Symantec Antivirus 9.0.

    La page Web suivante sur le site Web de Symantec (ID de Document Symantec : 2005062909055948) explique comment mettre à jour les fichiers Symevent :
  • Ce problème est connu pour se produire lorsque les versions de pilote de filtre de système de fichiers Antivirus/InoculateIT CA eTrust suivantes sont installées sur le serveur de fichiers.
    NomSociétéVersion francaiseDateDescription
    Ino_flpy.sysComputer Associates5.0:6100.10619-Jun-2003CA eTrust Antivirus/InoculateIT fichier système de montage filtre du pilote pour Windows 2000/XP/.Net
    Ino_fltr.sysComputer Associates5.0:6100.13608-Aug-2004CA eTrust Antivirus/InoculateIT fichier système filtre de pilote pour Windows 2000/XP/2003
    Le problème fait référence à la page Web suivante sur le site Web de Computer Associates :
Si vous examinez les traces réseau, vous pouvez constater que le serveur de fichiers ne répond pas de requêtes SMB. Par exemple, après avoir effectué une opération de suivi réseau, vous recevez le code suivant :
15:28:14  client -> server SMB Read AndX Request, FID 0x000215:28:14   server -> client  TCP [ACK]
Après environ 45 secondes, l’ordinateur client met fin à la Session TCP (FIN), et le serveur envoie ensuite un « [FIN ACK]. » Après avoir effectué l’opération de suivi réseau, vous recevez le code suivant :
15:29:05  client  -> server TCP [FIN ACK]15:29:05   server -> client  TCP [FIN ACK]
Dans ces traces, vous pouvez voir que le serveur ne répond pas à la demande des PME/PMI. Toutefois, le serveur envoie toujours un accusé de réception TCP pour la demande du client. Cela signifie que le service serveur sur le serveur de fichiers Windows ne répond pas aux requêtes SMB. Cela signifie également que la connectivité réseau n’est pas la cause du problème.

Références

Pour plus d’informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
816071 comment désactiver temporairement le pilote de filtre en mode noyau dans Windows

240309 comment faire pour empêcher des logiciels antivirus de filtrer les fichiers

822219 que vous rencontrez des performances de serveur de fichiers est lent et délais lorsque vous travaillez avec des fichiers qui sont trouvent sur un serveur de fichiers

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ID d'article : 923360 - Dernière mise à jour : 17 janv. 2017 - Révision : 1

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