Les blocs de construction de document peut être manquants dans un modèle qui fait partie d’un modèle de groupe de travail dans Word 2007 ou Word 2010

S’applique à : Microsoft Word 2010

Important Cet article contient des informations sur la façon de modifier le Registre. Veillez à sauvegarder le Registre avant de le modifier. Assurez-vous que vous savez comment restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
256986 description du Registre Microsoft Windows

Symptômes


Dans Microsoft Office Word 2007 et Word 2010, les blocs de construction de document peut être manquantes dans un modèle qui fait partie d’un modèle de groupe de travail.

Cause


Ce problème se produit car le chemin d’accès de groupe de travail pour les modèles de bloc de construction est différente du chemin d’accès pour les modèles standard.

Solution de contournement


Pour contourner ce problème, appliquez l’une des méthodes suivantes :

Méthode 1

Avertissement Des problèmes graves peuvent survenir si vous modifiez le Registre incorrectement à l’aide de l’Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent nécessiter que vous réinstalliez votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Modifiez le Registre à vos risques et périls.

Utilisez l’Éditeur du Registre pour définir la clé de SharedDocumentParts dans la sous-clé de Registre suivante pour le chemin d’accès du modèle partagé :

Office 2007 :
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Common
Office 2010 :

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Common


Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez regedit, puis cliquez sur OK.
  2. Recherchez, puis cliquez sur la clé suivante dans le Registre :
    Office 2007 :
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0 Office 2010 :
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0
  3. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur clé.
  4. Tapez communeet appuyez sur ENTRÉE.
  5. Recherchez, puis cliquez sur la clé suivante dans le Registre :
    Office 2007 :
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0 Office 2010 :
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0
  6. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur clé.
  7. Tapez Généralet appuyez sur ENTRÉE.
  8. Dans le menu Edition , pointez sur Nouveau, puis cliquez sur Valeur de chaîne.
  9. Dans le menu Edition, cliquez sur Modifier.
  10. Tapez SharedDocumentParts, puis cliquez sur OK.


    Remarque Définissez la valeur de chaîne de la clé à \\server\share.

Méthode 2

Activer la stratégie de groupe pour définir l’emplacement partagé des modèles. Pour ce faire, procédez comme suit :

Remarque Les étapes décrites dans la méthode 2 entraînent le même paramètre de Registre selon la méthode 1.
  1. Téléchargez et puis installer les Modèles d’administration à partir du Kit de ressources Office 2007 ou le Kit de ressources Office 2010.
  2. Copie le fichier office12.adm ou office14.adm dans le dossier suivant :
    c:\windows\inf
  3. Cliquez sur Démarrer, sur exécuter, tapez gpedit.msc, puis cliquez sur OK.
  4. Dans l’éditeur d’objets de stratégie de groupe, cliquez sur Modèles d’administration sous Configuration utilisateur, puis cliquez sur Ajout/Suppression de modèles.
  5. Dans la boîte de dialogue Ajout/Suppression de modèles , cliquez sur Ajouteret tapez c:\windows\inf\office12.adm pour Office 2007, pour Office 2010 type c:\windows\inf\office14.adm dans la zone nom de fichier , puis cliquez sur Ouvrir.
  6. Cliquez sur Fermer pour fermer la boîte de dialogue Ajout/Suppression de modèles .
  7. Dans l’éditeur d’objets de stratégie de groupe, développez Modèles d’administration sous Configuration utilisateur, développez système de Microsoft Office 2007 ou Microsoft Office 2010, puis cliquez sur chemins d’accès de Shared.
  8. Dans le volet des chemins d’accès de partage, double-cliquez sur le chemin de blocs de génération de groupe de travail.
  9. Dans la boîte de dialogue chemin de blocs de génération de groupe de travail , sous l’onglet paramètre , cliquez sur le bouton radio Activer et tapez l’emplacement des blocs de construction dans ce format\\server\share.

Plus d'informations


Étapes pour reproduire le problème

Pour reproduire ce problème, procédez comme suit :
  1. Créer un modèle qui contient un ou plusieurs blocs de construction. Pour ce faire, procédez comme suit :
    1. Démarrez Word 2007 ou Word 2010.
    2. Cliquez sur le bouton Microsoft Office, puis cliquez sur Nouveau.
    3. Dans la boîte de dialogue Nouveau Document , cliquez sur Modèles installés.
    4. Dans le volet Modèles installés, double-cliquez sur un nom de modèle.
    5. Sélectionnez une zone du modèle dans lequel vous allez créer un bloc de construction.
    6. Cliquez sur l’onglet Insertion , cliquez sur Composants QuickPart, puis cliquez sur Enregistrer sélection à rapide galerie de composants WebPart.
    7. Dans la boîte de dialogue créer un nouveau bloc de construction , tapez BuildingBlockName dans la zone nom .
    8. Sélectionnez GalleryName dans la zone de liste déroulante pour la Galerie, puis cliquez sur pour sélectionner nom de catégorie dans la zone de liste déroulante pour la catégorie.
    9. Cliquez sur pour sélectionner le nom du modèle à partir de l’étape d sous la zone de liste déroulante Enregistrer dans , puis cliquez sur OK.

      Remarque Répétez les étapes une à i pour stocker tous les blocs de construction que vous souhaitez partager.
  2. Créer une structure de dossiers, par exemple \\server\share et partagez le dossier que vous utiliserez pour votre emplacement de groupe de travail.
  3. Copiez le modèle que vous avez créé à l’étape 1D, dans le dossier partagé que vous avez créé à l’étape 2.
  4. Définir les modèles de groupe de travail à l’emplacement de \\server\share . Pour ce faire, procédez comme suit :
    1. Cliquez sur le bouton de Microsoft Office ou l’onglet fichier, puis cliquez sur Options Word.
    2. Dans la fenêtre Options Word, cliquez sur Avancé, puis cliquez sur Emplacements de fichiers.
    3. Dans la boîte de dialogue Emplacements de fichiers , sélectionnez modèles groupe de travail, puis cliquez sur Modifier.
    4. Dans la boîte de dialogue Modifier l’emplacement , type \\server\share dans la zone Nom du dossier , puis cliquez sur OK.
    5. Cliquez sur OK pour fermer la boîte de dialogue Emplacements de fichier .
  5. Word 2007 pour approuver l’emplacement dans lequel sont stockés les modèles qui contiennent des blocs de construction de la valeur. Pour ce faire, procédez comme suit :
    1. Cliquez sur le bouton de Microsoft Office ou l’onglet fichier, puis cliquez sur Options Word.
    2. Dans la fenêtre Options Word, cliquez sur Centre de gestion, puis cliquez sur Paramètres du centre de confiance.
    3. Dans la boîte de dialogue Centre de gestion , cliquez sur Emplacements approuvés, activez la case à cocher Autoriser les emplacements approuvés sur mon réseau (non recommandé), puis cliquez sur Ajouter un nouvel emplacement.
    4. Dans la boîte de dialogue Microsoft Office 2007 ou 2010 les emplacement approuvé , tapez \\server\share dans la zone de texte chemin d’accès , activez la case à cocher les sous-dossiers de cet emplacement sont également approuvéset puis cliquez sur OK.
    5. Cliquez sur OK pour fermer la boîte de dialogue Centre de gestion .
    6. Cliquez sur OK pour fermer les Options de Word.