Problèmes fichiers communs et du Registre la virtualisation dans Windows Vista ou Windows 7

Prise en charge de Windows Vista sans service Pack installé a pris fin le 13 avril 2010. Pour continuer à recevoir des mises à jour de sécurité pour Windows, assurez-vous que vous exécutez Windows Vista avec Service Pack 2 (SP2). Pour plus d'informations, reportez-vous à cette page web de Microsoft : Fin du support pour certaines versions de Windows

Symptômes

Lorsque vous utilisez la fonctionnalité de virtualisation de Windows Vista ou de Windows 7, vous pouvez le fichier de l’expérience et la virtualisation de Registre les problèmes qui sont décrits dans les scénarios suivants.

Scénario 1 : Messages d’erreur lorsque vous installez, mettez à niveau ou utilisez une application

Lorsque vous installez, mettez à niveau ou utilisez une application, vous pouvez recevoir divers messages d’erreur indiquant que l’accès a été refusé. Par exemple, vous pouvez rencontrer un des problèmes suivants :
  • Après avoir installé une application dans un dossier autre que le dossier % ProgramFiles%, vous recevez des messages d’erreur « accès refusé ». En outre, l’application ne fonctionne pas comme prévu.
  • Vous recevez des messages d’erreur d’application semblables aux suivants :
    Impossible de créer le dossier sous C:\MyApp\Temp
    Impossible de créer le fichier sous C:\MyApp\Temp\output.dat
  • Vous recevez des messages d’erreur semblables aux suivants :
    Erreur d’écriture de MyFile.exe
    Ce problème peut se produire lorsque vous effectuez l’une des actions suivantes :
    • Vous créez des liens dans des emplacements virtualisés.
    • Vous utilisez le système EFS (ENCRYPTING File System) pour chiffrer des fichiers.
    • Vous essayez d’afficher des fichiers compressés.
    • L’invite de commande vous permet de copier un .exe, .sys ou fichier .dll dans un emplacement virtualisable.
  • Les parties de l’application qui requièrent le fichier d’entrée ou de sortie ne fonctionnent plus correctement.

Scénario 2 : Impossible de trouver le fichier ou le dossier que vous venez de créer.

Lorsque vous utilisez une application pour laquelle la virtualisation est activée, vous créez des fichiers de données dans un emplacement virtualisable du système de fichiers. Lorsque vous utilisez une autre application ou l’Explorateur Windows pour accéder à ces fichiers créés récemment, vous ne pouvez pas le retrouver. Par exemple, si vous enregistrez un fichier dans une application dans % ProgramFiles%, % racine_système %, % lecteur_système % ou dossiers programdata % d’édition de photos, vous ne pouvez pas localiser ce fichier.

Scénario 3 : Vous mettre à niveau une application et que vous rencontrez un comportement inattendu du programme

Une fois que vous mettez à niveau une application, vous recevez un message d’erreur semblable au suivant :
Erreur. Mettez à niveau votre application.
En outre, l’application ne fonctionne pas comme prévu. L’application semble utiliser des données incorrectes ou de pré-mise à niveau.

Scénario 4 : Après la désinstallation d’une application, les fichiers d’application sont toujours présents sur l’ordinateur

Dans ce scénario, vous rencontrez un des problèmes suivants :
  • Dans une autre application, vous remarquez que les informations de fichier et de dossier pour la désinstallé application existent toujours dans % ProgramFiles%, programdata %, % systemdrive % ou dossiers de % racine_système %.
  • Le dossier %userprofile%\AppData\Local\VirtualStore est plus grand que prévu. Lorsque vous avez désinstallé l’application, les fichiers virtualisés créés lors de l’exécution de l’application ne sont pas supprimées.

Cause

Ces problèmes sont dus à une ou plusieurs des conditions suivantes :
  • L’application tente de créer des fichiers ou dossiers en dehors de certains dossiers virtualisés spécifiés.
  • Les fichiers qui sont enregistrés par une application dans le dossier %ProgramFiles% peuvent être dirigés vers un autre dossier que le dossier de stockage virtuel de l’utilisateur.
  • L’application utilise un fichier qui n’est pas prise en charge de la virtualisation.

Résolution

Scénario 1

Pour déterminer si le problème qui est décrit dans le scénario 1, recherchez dans l’Observateur d’événements pour les événements FileCreateVirtualExclude . Pour ce faire, procédez comme suit :
  1. Cliquez sur DémarrerStart button , tapez eventvwr dans la zone Rechercher , puis cliquez sur eventvwr.exe dans la liste programmes.

    User Account Control permission Si vous êtes invité à rentrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
  2. Développez des Applications et les journaux des Services, développez Microsoft, développez Windows, développez UacFileVirtualizationet puis sélectionnez opérationnel. Si l’ID d’événement est 5000, un événement FileCreateVirtualExclude s’est produite.
Pour résoudre ce problème, appliquez l’une des méthodes suivantes :
  • Réinstallez l’application dans le dossier %ProgramFiles% si le programme n’est pas déjà installé dans le dossier % ProgramFiles%.
  • Utilisez un compte disposant des autorisations nécessaires pour exécuter cette application. Pour ce faire, recherchez et puis cliquez sur le raccourci de l’application et puis cliquez sur Exécuter en tant qu’administrateur.

    User Account Control permission Si vous êtes invité à rentrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
  • À une invite de commandes avec élévation de privilèges, exécutez l’application. Pour ce faire, procédez comme suit :
    1. Cliquez sur DémarrerStart button et puis tapez cmd dans la zone Rechercher , puis cliquez sur cmd.exe dans la liste programmes.
    2. Dans la liste programmes , droit sur cmd, puis cliquez sur Exécuter en tant qu’administrateur.

      User Account Control permission Si vous êtes invité à rentrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
    3. Tapez MonCheminApp/MonAppet appuyez sur ENTRÉE. MonCheminApp/MonApp représente le chemin d’accès et le nom de l’application.
  • Modifier les paramètres de sécurité sur le dossier de l’application. Pour ce faire, procédez comme suit :
    1. Ouvrir une session en tant qu’utilisateur disposant des informations d’identification administratives, puis utilisez l’Explorateur Windows pour ouvrir le dossier de l’application.
    2. Cliquez droit sur le dossier de l’application, puis cliquez sur Propriétés.
    3. Sous l’onglet sécurité , cliquez sur Modifier.

      User Account Control permission Si vous êtes invité à rentrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
    4. Sous noms d’utilisateur ou de groupe, cliquez sur votre compte d’utilisateur.
    5. Sous autorisations pour les utilisateurs, cliquez sur Autoriser pour les autorisations suivantes :
      • Modifier
      • Lire & exécuter
      • Afficher le contenu du dossier
      • En lecture
      • Écriture
    6. Cliquez sur OK.

Scénario 2

Pour résoudre ce problème, appliquez l’une des méthodes suivantes :
  • Cliquez sur le bouton Fichiers de compatibilité qui s’affiche dans la barre de l’Explorateur pour afficher les fichiers virtualisés dans le dossier. Le bouton de Fichiers de compatibilité s’affiche que s’il existe des fichiers virtualisés dans le dossier.
  • Recherchez dans le dossier \AppData\Local\VirtualStore C:\Users\User_namepour localiser les fichiers et les dossiers.
  • Enregistrer les données de votre application dans un dossier sous votre profil utilisateur.

Scénario 3

Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Vous pourriez alors restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder et de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 comment sauvegarder et restaurer le Registre dans Windows


Pour résoudre ce problème, appliquez l’une des méthodes suivantes :
  • À une invite de commandes avec élévation de privilèges, exécutez l’application. Pour ce faire, procédez comme suit :
    1. Cliquez sur DémarrerStart button , tapez cmd dans la zone Rechercher , puis cliquez sur cmd.exe dans la liste programmes.

      User Account Control permission Si vous êtes invité à rentrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
    2. Type MonCheminApp/MonApp. MonCheminApp/MonApp représente le chemin d’accès et le nom de l’application et appuyez sur entrée
  • Ouvrez le magasin virtuel et supprimez les anciens fichiers de données d’application. Pour ce faire, utilisez l’Explorateur Windows pour ouvrir le dossier MonApp de \AppData\Local\VirtualStore\Program Files\ C:\Users\nom_utilisateuret puis supprimez tous les fichiers qui ne sont pas vos documents ou fichiers de données.
  • Supprimez le magasin virtuel du Registre.

    Pour localiser le magasin virtuel dans le Registre et supprimer les clés inutiles, procédez comme suit :
    1. Cliquez sur DémarrerStart button , tapez regedit dans la zone Rechercher , puis cliquez sur regedit.exe dans la liste programmes.

      User Account Control permission Si vous y êtes invité pour un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
    2. Recherchez et cliquez sur la sous-clé de Registre suivante :
      HKEY_CURRENT_USER\Software\Classes\VirtualStore
    3. Pour n’importe quelle application des clés de Registre qui ne sont plus nécessaires avec le bouton droit de la clé et cliquez sur Supprimer, puis cliquez sur Oui.

Scénario 4

Pour résoudre ce problème, utilisez l’Explorateur Windows pour ouvrir le dossier de \AppData\Local\VirtualStore\MyApp C:\Users\nom_utilisateuret puis supprimez les données d’application obsolètes.

Plus d'informations

Écrire des fichiers et du Registre la virtualisation permet aux utilisateurs qui ont un accès limité au Registre et au système de fichiers sur ces zones protégées. La virtualisation crée une copie « par utilisateur », puis redirige les opérations sur les données successives. Par exemple, supposons qu’une application s’exécute sous un compte d’utilisateur limité ou sous des comptes qui requièrent des autorisations de contrôle de compte d’utilisateur. Lorsque cette application écrit dans un emplacement du système, tels que pour le dossier % ProgramFiles%, Windows Vista et Windows 7 rediriger les opérations d’écriture et lecture vers un emplacement spécifique à l’utilisateur dans le dossier du profil utilisateur (% localappdata%\VirtualStore). Par défaut, cet emplacement est C:\Users\nom_utilisateur\AppData\Local\VirtualStore\Program Files\nom de l’application. La virtualisation du Registre fonctionne de la même façon, mais s’applique aux clés de Registre sous la sous-arborescence HKEY_LOCAL_MACHINE\SOFTWARE . Les clés et les données sous cette arborescence sont redirigées vers la sous-clé HKEY_CURRENT_USER\Software\Classes\VirtualStore .

Pour plus d’informations, visitez le site Web de Microsoft à l’adresse suivante :

Références

Pour une aide sur des tâches de maintenance courantes du système dans Windows Vista, visitez la page Web de Microsoft à l’adresse suivante :
Propriétés

ID d'article : 927387 - Dernière mise à jour : 17 janv. 2017 - Révision : 2

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