Impossible d'afficher les informations de certificat dans Windows Internet Explorer 7 dans le Gestionnaire de certificats après avoir importé avec succès un certificat sur un ordinateur Windows Vista

Symptômes

Après avoir importé avec succès un certificat sur un ordinateur Windows Vista, vous ne pouvez pas afficher les informations de certificat dans Windows Internet Explorer 7 ou dans le Gestionnaire de certificats.

Cause

Ce problème se produit si vous ne disposez pas des autorisations de lecture pour la sous-clé de Registre suivante :
HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots

Résolution

Informations sur le téléchargement

Les fichiers suivants sont disponibles pour téléchargement à partir du Microsoft Download Center :

Mise à jour pour Windows Vista
Download Télécharger le package de mise à jour pour Windows Vista (KB932156) maintenant.

Mise à jour pour Windows Vista version x64
Download Télécharger la mise à jour pour Windows Vista pour basée sur les x64 le package Systems (KB932156) maintenant.

Remarque Après avoir appliqué la mise à jour à l’ordinateur, recherchez le fichier Portreg.exe dans le chemin suivant :
< lecteur > : outil clé de Registre ProtectedRoots de mise à jour de Corporation\Microsoft \Program Files\Microsoft (KB932156)
Pour activer ce correctif logiciel, double-cliquez sur le fichier Portreg.exe.

Pour plus d'informations sur la façon de télécharger des fichiers de support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :Microsoft a vérifié que ce fichier ne comportait pas de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date à laquelle le fichier a été validé. Le fichier est stocké sur des serveurs sécurisés, ce qui empêche toute modification non autorisée du fichier.


Pour plus d’informations sur la façon de résoudre ce problème, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
942543 vous ne pouvez pas afficher les informations de certificat dans Windows Internet Explorer 7 ou dans le Gestionnaire de certificat si vous utilisez un fichier de réponses sans assistance à l’installation de Windows Vista

Comment faire pour résoudre ce problème en modifiant le Registre

Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Vous pourriez alors restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder et de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 comment sauvegarder et restaurer le Registre dans Windows


Pour résoudre ce problème, affectez des autorisations de lecture pour la clé de Registre ProtectedRoots à l’utilisateur qui est actuellement connecté à l’ordinateur. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer  Start button , tapez regedit dans la zone Rechercher , puis cliquez sur regedit.exe dans la
    Liste des programmes .

     User Account Control permission Si vous êtes invité à rentrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe, ou cliquez sur Continuer.
  2. Recherchez, puis cliquez sur la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root\ProtectedRoots
  3. Cliquez sur autorisations.
  4. Utilisez une des méthodes suivantes :
    • Si l’utilisateur qui est actuellement connecté à l’ordinateur est répertorié dans la zone noms d’utilisateur ou de groupe , cliquez sur le nom de l’utilisateur, activez la case à cocher lecture dans la
      Colonne Autoriser , puis cliquez sur OK.
    • Si l’utilisateur qui est actuellement connecté à l’ordinateur n’est pas répertorié dans la zone noms d’utilisateur ou de groupe , procédez comme suit :
      1. Cliquez sur Ajouter.
      2. Tapez le nom de l’utilisateur qui est actuellement connecté à l’ordinateur, puis cliquez sur OK.
      3. Dans la zone noms d’utilisateur ou de groupe , sélectionnez le nom d’utilisateur, puis activez la case à cocher lecture dans la colonne Autoriser , puis cliquez sur OK.
  5. Quittez l'Éditeur du Registre.
Remarque Si un utilisateur de domaine est connecté à l’aide des informations d’identification mises en cache et n’est pas connecté au domaine, l’utilisateur de domaine ne pourront pas ajouter des autorisations pour leur compte d’utilisateur de domaine pour la clé de Registre dans les étapes suivantes. Vous devez ouvrir une session sur l’ordinateur local et ajouter le compte de l’utilisateur local les autorisations pour la clé de Registre. Vous pouvez installer puis correctement le certificat.

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Propriétés

ID d'article : 932156 - Dernière mise à jour : 17 janv. 2017 - Révision : 1

Commentaires