Message d’erreur lorsque vous utilisez la fonctionnalité Intégration Outlook pour Microsoft Dynamics NAV 5.0 pour tester la connexion : « Dépassement dans la conversion de type de texte à texte »

S’applique à : Microsoft Dynamics NAV 5.0

Cet article s’applique à Microsoft Dynamics NAV 5.0 pour tous les pays et tous les paramètres régionaux de langue.

Symptômes


Lorsque vous utilisez la fonctionnalité Intégration Outlook pour Microsoft Dynamics NAV 5.0 pour tester la connexion, le message d’erreur suivant s’affiche :
La connexion à « Demo Database NAV (5-0) » échoué de la base de données Microsoft Dynamics NAV.
Le programme a renvoyé l’erreur suivante :

Exécution du Codeunit Microsoft Dynamics NAV pour la réponse Erreur :

Dépassement dans la conversion du type texte vers texte.
Remarque La fonctionnalité Intégration Outlook pour Microsoft Dynamics NAV 5.0 est un complément Microsoft Office Outlook pour Microsoft Dynamics NAV 5.0.

Ce problème se produit si vous utilisez les produits suivants :
  • Microsoft Dynamics NAV 5.0
  • Microsoft Office Outlook 2007
  • La fonctionnalité Intégration Outlook pour Microsoft Dynamics NAV 5.0.
  • Windows Vista

Cause


Ce problème se produit car la fonctionnalité Intégration Outlook a retourné une longueur incorrecte pour la somme de contrôle. La longueur de la somme de contrôle est de 32 caractères dans Windows XP. Toutefois, la longueur de la somme de contrôle est de 40 caractères dans Windows Vista.

Résolution


Un correctif pris en charge est désormais disponible auprès de Microsoft. Le correctif résout le problème qui est décrit dans cet article. Appliquez le correctif uniquement aux systèmes rencontrant ce problème spécifique.

Pour résoudre ce problème immédiatement, contactez le Support technique pour Microsoft Dynamics et les produits connexes obtenir le correctif. Vous pouvez ouvrir une session sur le site de Microsoft Dynamics et créer une demande de support. Pour ce faire, visitez le site Web de Microsoft à l'adresse suivante :Vous pouvez également contacter le Support technique pour Microsoft Dynamics et les produits associés par téléphone au (888) 477-7877.

Remarque Dans certains cas, les frais généralement encourus pour la prise en charge des appels peuvent être annulés si un technicien du Support technique pour Microsoft Dynamics et les produits associés détermine qu’une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.



Comment faire pour obtenir le correctif logiciel de Microsoft Dynamics NAV ou mettre à jour des fichiers

Une fois que vous demandez un correctif de Microsoft Dynamics NAV ou un fichier de mise à jour à partir d’un Support technique pour Microsoft Dynamics, un lien hypertexte sera envoyé dans un message électronique pour vous.


Le message électronique contiendra un lien hypertexte et un mot de passe. Vous pouvez utiliser le lien hypertexte pour télécharger le correctif logiciel de Microsoft Dynamics NAV ou les fichiers de mise à jour. Lorsque vous cliquez sur le lien hypertexte, la boîte de dialogue Téléchargement de fichier – Avertissement de sécurité s’ouvre. Puis, vous êtes invité à exécuter, à enregistrer ou à annuler le téléchargement.


Si vous cliquez sur exécuter, les fichiers de démarrer le téléchargement et le processus d’extraction. Vous devez spécifier un dossier pour les nouveaux fichiers et ensuite fournir le mot de passe.


Si vous cliquez sur Enregistrer, vous devez spécifier un chemin d’accès pour enregistrer le fichier compressé. Lorsque vous ouvrez le fichier que vous avez enregistré, vous êtes invité à spécifier un chemin d’accès pour les fichiers. Vous devez ensuite fournir le mot de passe fourni dans le message électronique.


Si vous cliquez sur Annuler, le processus de téléchargement s’arrête.

Comment installer un correctif Microsoft Dynamics NAV ou un fichier de mise à jour

Les mises à jour et correctifs logiciels de plate-forme Microsoft Dynamics NAV sont accessibles sous forme de fichiers unique.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Mapihelper.dllNe s'applique pas87,50419-Aug-200721:06x86
Microsoft.dynamics.nav.olsync.common.dll1.0.0.2355950,64020-Aug-200702:19x86
Microsoft.dynamics.nav.olsync.navsyncaddin.dll5.0.25074.0759,24819-Aug-200721:06x86
Pour appliquer ce correctif, procédez comme suit.
  1. Fermez Microsoft Dynamics NAV.
  2. Ajoutez le fichier Microsoft.dynamics.nav.olsync.common.dll dans le global assembly cache. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarreret cliquez sur Panneau de configuration, double-cliquez sur Outils d’administration, puis double-cliquez sur Configuration de Microsoft.NET Framework 2.0.
    2. Cliquez sur le Cache de l’Assemblyet puis ajoutez le fichier Microsoft.Dynamics.NAV.OLSync.Common.dll dans le Cache de l’Assembly.
  3. Placez les fichiers Microsoft.dynamics.nav.olsync.navsyncaddin.dll et Mapihelper.dll dans le dossier racine de la suite Microsoft Office.

    Remarque Par défaut, le dossier racine de la suite Microsoft Office est le dossier suivant :
    C:\Program Files\Microsoft Office\Office12
  4. Exécutez le fichier .bat à partir du dossier Office12. Les lignes suivantes sont les lignes du fichier .bat.
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm.exe Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.dll
    /tlb:Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.tlb
    copy Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.tlb "C:\Program Files\Microsoft Dynamics NAV
    \CSIDEClient\Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.tlb"

    Remarque Le fichier Regasm.exe se trouve généralement dans le dossier suivant :
    C:\Windows\Microsoft .NET\Framework\v2.0.50727

État


Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations


Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft