Le spouleur d’imprimante peut se bloquer de façon aléatoire sur un ordinateur Windows Server sur lequel une imprimante HP est installée

Cet article fournit une solution à un problème où le spouleur d’imprimante se bloque de façon aléatoire sur un ordinateur Windows Server sur lequel une imprimante HP est installée.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 947477

Symptômes

Sur un ordinateur Windows Server sur lequel une imprimante HP est installée, le spouleur d’imprimante peut se bloquer de façon aléatoire.

Cause

Ce problème se produit en raison de l’un des fichiers suivants :

  • Hpbmmon.dll (HP Master Monitor)
  • Hpzpi4wm.dll (processeur d’impression HP)
  • Hpzpp4wm.dll (processeur d’impression HP)
  • HPtcpMon.dll (moniteur de port TCP HP)

Résolution

Pour résoudre ce problème, contactez le fabricant tiers pour obtenir de l’aide.

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.

Solution de contournement pour le problème causé par Hpbmmon.dll

Pour contourner ce problème, supprimez hp Master Monitor. Pour cela, procédez comme suit :

  1. Démarrez l’Éditeur du Registre.

  2. Recherchez et cliquez sur la sous-clé de HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Master MonitorRegistre .

  3. Dans le menu Fichier , cliquez sur Exporter.

  4. Dans la zone Nom de fichier , tapez HPprinter, puis cliquez sur Enregistrer.

    Remarque

    Si vous souhaitez restaurer cette sous-clé de Registre, double-cliquez sur le fichier HPprinter.reg que vous enregistrez à cette étape.

  5. Cliquez avec le bouton droit sur l’entrée de Registre HP Master Monitor , puis cliquez sur Supprimer.

  6. Cliquez sur Oui.

  7. Quittez l’Éditeur du Registre, puis redémarrez l’ordinateur.

  8. Renommez le fichier Hpbmmon.dll hpbmmon.old. Le fichier se trouve à l’emplacement C:\WINDOWS\system32\Hpbmmon.dll fichier.

Solution de contournement pour le problème causé par Hpzpi4wm.dll ou Hpzpp4wm.dll

Remarque

Si cette imprimante ne fonctionne pas avec WinPrint, les étapes suivantes peuvent ne pas fonctionner. Si cette situation se produit, contactez HP pour mettre à niveau le processeur d’impression HPZPP4WM vers la version la plus récente.

  1. Cliquez sur Démarrer, puis sur Panneau de configuration.
  2. Double-cliquez sur Imprimantes et télécopies.
  3. Cliquez avec le bouton droit sur l’imprimante que vous souhaitez utiliser, puis cliquez sur Propriétés.
  4. Cliquez sur l’onglet Avancé , puis sur Processeur d’impression.
  5. Cliquez sur WinPrint dans la zone Processeur d’impression , cliquez sur RAW dans la zone Type de données par défaut , puis cliquez deux fois sur OK .
  6. Renommez le fichier Hpzpi4wm.dll hpzpi4wm.old. Le fichier se trouve à l’emplacement : C:\WINDOWS\system32\spool\drivers\w32x86\3\Hpzpi4wm.dll.
  7. Renommez le fichier Hpzpp4wm.dll hpzpp4wm.old. Le fichier se trouve à l’emplacement : C:\WINDOWS\system32\spool\PRTPROCS\W32X86\Hpzpp4wm.dll.

Solution de contournement pour le problème causé par HPtcpMon.dll

  1. Démarrez l’Éditeur du Registre.

  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Standard TCP/IP Port.

  3. Dans le menu Fichier , cliquez sur Exporter.

  4. Dans la zone Nom de fichier , tapez HPprinter, puis cliquez sur Enregistrer.

    Remarque

    Si vous souhaitez restaurer cette sous-clé de Registre, double-cliquez sur le fichier HPprinter.reg que vous enregistrez à cette étape.

  5. Cliquez avec le bouton droit sur l’entrée de registre HP Standard TCP/IP Port , puis cliquez sur Supprimer.

  6. Cliquez sur Oui.

  7. Recherchez et cliquez sur la sous-clé de HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP PortRegistre .

  8. Double-cliquez sur Pilote, puis vérifiez que la valeur de la zone Données de la valeur est tcpmon.dll.

    Remarque

    Si l’entrée de Registre Driver n’existe pas ou si sa valeur n’est pas tcpmon.dll, créez l’entrée de Registre Driver , puis définissez sa valeur sur tcpmon.dll. Pour cela, procédez comme suit :

    1. Dans le menu Modifier , pointez sur Nouveau, puis cliquez sur Valeur de chaîne.
    2. Tapez Pilote, puis appuyez sur Entrée.
    3. Cliquez avec le bouton droit sur Pilote, puis cliquez sur Modifier.
    4. Dans la zone Données de la valeur , tapez tcpmon.dll, puis cliquez sur OK.
  9. Quittez l’Éditeur du Registre, puis redémarrez l’ordinateur.

  10. Renommez le fichier HPtcpMon.dll HPtcpMon.old. Le fichier se trouve à l’emplacement : C:\WINDOWS\system32\HPTcpMon.dll.

Plus d’informations

Les produits tiers mentionnés dans le présent article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.