Lorsque vous essayez d’installer Windows XP Service Pack, vous recevez le message d’erreur « Accès refusé » ou « installation du Service Pack ne s’est pas terminé »

Symptômes

Lorsque vous installez Windows XP Service Pack 2 (SP2) ou Service Pack 3 (SP3), vous pouvez recevoir un message d’erreur semblable à l’un des éléments suivants :
Erreur d’installation du Service Pack 3. L'accès est refusé.
Erreur d’installation du Service Pack 3. Installation du Service Pack ne s’est pas terminée.
Ou bien, le fichier Svcpack.log peut contenir le message d’erreur suivant :
Échec de DoRegistryUpdates

Cause

Ces erreurs peuvent se produire si les autorisations pour une ou plusieurs clés de Registre sont restreintes de sorte que le service pack empêche la mise à jour des clés. Clés de Registre peuvent être autorisées par certains programmes qui modifient les listes de contrôle d’accès système (SACL) dans le Registre afin que les comptes d’administrateur ne peut pas modifier les. Le programme d’installation du pack de service s’exécute sous un compte d’administrateur (utilisateur) et par conséquent ne peut pas accéder aux clés de Registre restreintes. Si Windows XP Service Pack ne peut pas mettre à jour une clé de Registre car elle est limitée par un autre programme, l’installation du service pack échoue.

Pour déterminer si une mise à jour du Registre a échoué, passez à la section « Informations complémentaires ».

Résolution

Utilisez les méthodes de dépannage suivantes dans l’ordre dans lequel elles sont présentées pour résoudre le problème. Ces méthodes sont destinées aux utilisateurs de niveau intermédiaires et expérimentés.



Remarque Vous devez être connecté à Windows avec un compte d’utilisateur qui est administrateur de l’ordinateur pour exécuter ces méthodes. S’il s’agit de votre ordinateur personnel, vous êtes probablement déjà ouvert une session avec un compte d’administrateur. S’il s’agit d’un ordinateur qui fait partie d’un réseau au travail, vous devrez peut-être contacter l’administrateur système pour obtenir une aide. Pour vérifier que vous êtes connecté à Windows avec un compte d'utilisateur qui est administrateur de l'ordinateur, visitez le site Web de Microsoft à l'adresse suivante :

Méthode 1 : Redémarrez l’ordinateur et réessayez de télécharger et d’installer Windows XP SP3 à partir du Microsoft Download Center

Si un programme s’exécute avec un fichier verrouillé, le redémarrage de l’ordinateur peut déverrouiller le fichier. Pour essayer de déverrouiller le fichier, quittez tous les programmes et redémarrez l’ordinateur. Essayez à nouveau de télécharger et d’installer le service pack.

Si vous avez initialement essayé d’installer Windows XP SP3 via Windows Update et il a échoué, téléchargez le package de téléchargement complet de Windows XP SP3 à partir du Microsoft Download Center. Après avoir téléchargé le service pack, essayez de l’installer. Pour plus d’informations sur la façon de télécharger Windows XP Service Pack 3, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

322389 comment obtenir le dernier service pack Windows XP

Si cette méthode a résolu le message d’erreur et si vous avez installé avec succès Windows XP SP3, vous avez terminé.

Pour plus d’informations sur la restauration des paramètres de sécurité par défaut de Windows XP, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

313222 comment restaurer les paramètres de sécurité par défaut ?



Si cette méthode ne résout pas le problème, passez à la méthode 2.

Méthode 2 : Redémarrez l’ordinateur, puis fermez ou désactivez tout programme antivirus ou anti-espion peut être en cours d’exécution

Avertissement Cette solution de contournement peut rendre un ordinateur ou un réseau plus vulnérable aux attaques d'utilisateurs malintentionnés ou de logiciels malveillants comme les virus. Nous ne recommandons pas cette solution de contournement, mais nous fournissons cette information afin que vous puissiez l'implémenter à votre convenance. Utilisez cette solution de contournement à vos risques et périls.

Vous pouvez réduire le risque d’attaque par des utilisateurs malveillants ou de logiciels malveillants par pas de visiter d’autres sites Web ou de télécharger des fichiers si votre logiciel antivirus et anti-espion est fermée ou désactivée.

Une des causes plus courantes de l’échec de l’installation est un programme tiers, tel qu’un antivirus, qui laisse ouvert ou verrouille un fichier requis par le programme d’installation du service pack. Pour éviter ce problème, procédez comme suit avant d’installer Windows XP SP3 :
  1. Quittez tous les programmes et redémarrez l’ordinateur.
  2. Après le redémarrage de l’ordinateur, fermez ou désactivez tous les programmes antivirus ou anti-espion peuvent être en cours d’exécution.

    Remarque Vous pouvez désactiver les programmes à partir de la zone de notification. Pour ce faire, cliquez sur l’icône du programme tiers, puis cliquez sur une option pour fermer ou désactiver l’application. Si cette option n’est pas disponible, consultez la documentation du programme ou contactez le fabricant du programme pour obtenir des instructions.
  3. Après avoir fermé l’antivirus ou le logiciel anti-espion, installez Windows XP SP3 à partir du package de téléchargement complet que vous avez téléchargé dans la méthode 1.
  4. Une fois l’installation de Windows XP SP3 terminée, redémarrez l’antivirus ou le logiciel anti-espion que vous avez désactivé à l’étape 2.
Si cette méthode a résolu le message d’erreur et si vous avez installé avec succès Windows XP SP3, vous avez terminé.

Si cette méthode ne résout pas le problème, et si vous êtes à l’aise de dépannage avancées, consultez la section « Dépannage avancé ». Si vous n’êtes pas à l’aise avec le dépannage avancé, passez à la section « Étapes suivantes ».

DÉPANNAGE AVANCÉ

Cette section contient une méthode avancée de résolution des problèmes à essayer si les étapes décrites dans la section « Résolution » ne fonctionnent pas. Cette méthode est destinée aux utilisateurs expérimentés uniquement.

Réinitialisation du Registre et les autorisations de fichier

Afin que nous puissions réinitialiser les autorisations de fichier et de Registre pour vous, consultez la section «Aidez-moi». Si vous voulez activer les mises à jour automatiques vous-même, consultez la section «Je résous le problème moi-même».


Aidez-moi

Pour résoudre ce problème automatiquement, cliquez sur le lien résoudre ce problème . Cliquez sur exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez les étapes de cet Assistant.
Résoudre ce problème
Microsoft Fix it 50389

Remarque Cet Assistant peut exister en anglais uniquement. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.

Remarque Si vous n'êtes pas sur l'ordinateur qui rencontre le problème, vous pouvez enregistrer la résolution automatique sur un lecteur flash ou sur un CD-ROM et ensuite l'exécuter sur l'ordinateur qui rencontre le problème.

Je résous le problème moi-même

Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Vous pourriez alors restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder et de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 comment sauvegarder et restaurer le Registre dans Windows
Pour réinitialiser les autorisations de fichier et de Registre, procédez comme suit :
  1. Téléchargez, puis installez le fichier Subinacl.exe. Pour ce faire, visitez le site Web de Microsoft à l'adresse suivante :
  2. Démarrez le bloc-notes.
  3. Copiez et collez le texte suivant dans le bloc-notes.
    CD /d « %ProgramFiles%\Windows Resource Kits\Tools »
    Subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant = administrators = f/grant = system = f
    Subinacl /subkeyreg HKEY_CURRENT_USER /grant = administrators = f/grant = system = f
    Subinacl /subkeyreg HKEY_CLASSES_ROOT /grant = administrators = f/grant = system = f
    subinacl /subdirectories % Lecteur_système % / grant = administrators = f/grant = system = f
    subinacl /subdirectories %windir%\*.* /grant = administrators = f/grant = system = f
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    Microsoft fournit des exemples de programmation à titre d'illustration uniquement, sans garantie expresse ou implicite. Ceci inclut, mais n'est pas limité à, les garanties implicites de qualité marchande ou d'adéquation à un usage particulier. Cet article suppose que vous êtes familiarisé avec le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les ingénieurs du support technique Microsoft peuvent aider à expliquer la fonctionnalité d'une procédure particulière. Toutefois, ils ne modifieront pas ces exemples pour fournir des fonctionnalités supplémentaires ou créer des procédures répondant à vos besoins spécifiques.
  4. Enregistrez ce fichier sous Reset.cmd.
  5. Double-cliquez sur le fichier Reset.cmd pour exécuter le script.

    Remarque Ce fichier de script peut prendre beaucoup de temps à s’exécuter. Vous devez exécuter ce script en tant qu’administrateur.
  6. Installer Windows XP SP3.
Si cette méthode a résolu le message d’erreur et si vous avez installé avec succès Windows XP SP3, vous avez terminé.


Si cette méthode ne résout pas le problème, passez à la section « Étapes suivantes ».

Plus d'informations

Comment faire pour déterminer si la mise à jour du Registre a échoué

  1. Cliquez sur Démarrer, sur exécuter, tapez %windir%\svcpack.log, puis cliquez sur OK. Le fichier Svcpack.log s’ouvre.
  2. Dans le menu Edition , cliquez sur Rechercher.
  3. Dans la zone Rechercher , tapez Échec de DoRegistryUpdates, puis cliquez sur Suivant.

    S’il y a un échec de la mise à jour du Registre, un message d’erreur « DoRegistryUpdates failed » s’affiche dans le fichier. Cela indique qu’un problème empêchant la mise à jour du Registre. Ce message d’erreur semblable au suivant :
    xxxx.xxx: DoInstallation a échoué.
    xxxx.xxx: l’accès est refusé.

    xxxx.xxx: Message affiché à l’utilisateur : l’accès est refusé.
    Remarque Dans ce message, xxxx.xxx représente l’horodatage de chaque entrée.

Logiciel antivirus

Un programme antivirus est conçu pour aider à protéger votre ordinateur contre les virus. Vous ne devez pas télécharger ou ouvrir des fichiers provenant de sources non fiables, visiter des sites Web que ne pas faire confiance, ou ouvrir les pièces jointes lorsque votre antivirus est désactivé. Pour plus d’informations sur les virus informatiques, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
129972 virus informatiques : description, prévention et récupération

ÉTAPES SUIVANTES

Si ces méthodes n’a pas fonctionné pour vous, vous pouvez utiliser le site Web des Services de Support client Microsoft pour trouver d’autres solutions à votre problème. Certains services proposés par les sites Web des Services de Support client Microsoft sont les suivants :
  • Base de connaissances : rechercher des informations de support technique et des outils d'auto-assistance pour les produits Microsoft.
  • Centres de solutions: permet d’afficher des informations de support importantes et les questions fréquemment posées spécifiques aux produits.
  • Autres options de support : utilisez le web pour poser une question, contacter les Services de Support client Microsoft ou envoyer vos commentaires.
Si vous continuez à rencontrer des problèmes, vous souhaiterez peut-être contacter le support technique :
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ID d'article : 949377 - Dernière mise à jour : 17 janv. 2017 - Révision : 2

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