Le processus RunOnce.exe peut cesser de répondre pendant le processus d’installation de pilote sur un ordinateur Windows XP

Symptômes

Sur un ordinateur Windows XP, l’outil de déploiement de droits élevés (RunOnce.exe) vous permet d’installer un pilote tiers. Toutefois, le processus RunOnce.exe peut cesser de répondre (se bloquer) au cours du processus d’installation de pilote.

Cause

Ce problème se produit en raison d’un blocage dans le fichier Shimeng.dll.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n’apparaît pas, soumettez une demande au Service Clients et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Vous devez disposer de Windows XP Service Pack 2 ou une version ultérieure d’un service pack Windows XP installé sur l’ordinateur.

Nécessite un redémarrage

Vous devez redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif


Ce correctif ne remplace aucun autre correctif préalablement publié.

Informations concernant le Registre


Pour utiliser ce correctif logiciel, vous n'avez aucune modification à apporter au Registre.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
Windows XP avec SP2, versions x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Shimeng.dll5.1.2600.332566,04804-Mar-200813:40x86
Windows XP avec le SP3, les versions basées sur x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Shimeng.dll5.1.2600.555566,04804-Mar-200816:09x86

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Ce problème affecte le processus de Windows Installer (Msiexec.exe) également et peut provoquer des installations d’applications cesse de répondre (se bloquer). Vous pouvez rencontrer ce problème au cours d’un déploiement automatisé. Par exemple, ce problème se produit lorsque vous utilisez une séquence de tâches dans System Center Configuration Manager 2007 pour installer une application.

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

Propriétés

ID d'article : 949900 - Dernière mise à jour : 17 janv. 2017 - Révision : 1

Commentaires