Performances d’impression lorsque vous imprimez vers une imprimante LPR à partir d’un ordinateur Windows XP

Symptômes

Considérez le scénario suivant :
  • Sur un ordinateur qui exécute Windows XP, vous essayez d’imprimer sur un port TCP/IP sur une imprimante à distance LPR (Line Printer) à l’aide du logiciel de moniteur de port LPR.
  • La fonction de comptage des octets LPR sur l’imprimante LPR pour activer ou désactiver les options TCP/IP avancées sur l’imprimante LPR.
Dans ce scénario, vous rencontrez des performances d’impression.


Si vous suivez le trafic réseau lorsque ce problème se produit, les résultats de traçage réseau indiquent que pour chaque trois paquets qui sont envoyés à partir de l’ordinateur à l’imprimante LPR, il existe un paquet « ACK retardé » avant de l’imprimante LPR envoie un accusé de réception.

Cause

Ce problème se produit car certaines imprimantes LPR utilisent des algorithmes de retard accusé de réception (ACK) pour diminuer la charge TCP. Un accusé de réception retardée peut se produire si une imprimante qui utilise ces algorithmes reçoit un nombre impair de paquets à partir d’un ordinateur qui envoie des travaux d’impression à l’imprimante. Pendant ce délai, l’ordinateur attend d’envoyer d’autres données à l’imprimante.


En outre, le processeur d’impression Windows et le moniteur de Port TCP/IP utilisent une mémoire tampon de 4 kilo-octets pour envoyer des données à l’imprimante. Une taille de mémoire tampon de 4 kilo-octets provoque des délais plus longs pour les accusés de réception. Ces délais s’accumulent au fil du temps et éventuellement provoquent une réduction significative de la vitesse de transfert globale du travail d’impression lors de l’impression de documents volumineux.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique.


Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n’apparaît pas, soumettez une demande au Service Clients et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez disposer de Windows XP Service Pack 2 ou Windows XP Service Pack 3 installé sur l’ordinateur.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322389 comment obtenir le dernier service pack Windows XP

Nécessite un redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
Windows XP avec Service Pack 2, versions basées sur les x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Tcpmon.dll5.1.2600.355545,56815-Apr-200914:48x86
Windows XP avec Service Pack 3, versions x86
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Tcpmon.dll5.1.2600.579545,56815-Apr-200914:35x86

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft
Propriétés

ID d'article : 970048 - Dernière mise à jour : 14 janv. 2017 - Révision : 1

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