Un ou plusieurs serveurs de gestion et de leurs équipements gérés sont estompées dans la Console Gestionnaire d’Operations Manager

Symptômes

Dans un environnement Microsoft System Center Operations Manager, un ou plusieurs serveurs d’administration qui hébergent les rôles suivants, ainsi que des équipements gérés de ces serveurs d’administration, peuvent apparaître grisée ou grisé dans la Console :
  • Serveur d’administration racine
  • Serveur d’administration
  • Serveur de passerelle
  • Agent
En outre, un événement semblable au suivant est enregistré dans le journal d’Operations Manager sur ces ordinateurs :

Remarque Cet événement peut signaler le problème avec d’autres processus d’Operations Manager, en fonction du rôle affecté.

Cause

Ce problème se produit généralement dans un grand environnement Operations Manager dans lequel un serveur d’administration ou sur un ordinateur agent gère de nombreux flux de travail. Cette situation peut se produire pour l’une des raisons suivantes :
  • De nombreux Packs de gestion sont installés.
  • Un serveur d’administration ou un agent agissant en tant que proxy pour de nombreux périphériques.
Le service de santé du Gestionnaire des opérations stocke les enregistrements des transactions qui ne sont pas terminées dans ce que l'on appelle la « banque des versions ». La banque des versions permet le moteur ESE (Extensible Storage) de suivre et de gérer les transactions en cours. La banque des versions contient une liste des opérations qui sont effectuées par des transactions actives qui sont gérées par le service HealthService. Cette liste est une liste en mémoire des modifications apportées à la base de données de la banque HealthService. Il existe une taille par défaut optimisée pour une installation par défaut de chaque rôle d’Operations Manager. Toutefois, la taille par défaut peut être insuffisante pour certains environnements d’Operations Manager.

Résolution

Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Vous pourriez alors restaurer le Registre si un problème survient. Pour plus d’informations sur la façon de sauvegarder et de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 comment sauvegarder et restaurer le Registre dans Windows
Pour résoudre le problème, appliquez la configuration sur les ordinateurs qui hébergent les rôles affectés de Registre suivante :
Sous-clé : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters
Type : REG_DWORD
Nom : Maximum de la banque des versions de persistance
Valeur : Nombre de pages de 16 kilo-octets
Base : Décimal
La taille par défaut de la banque des versions dépend du rôle d’Operations Manager et est définie comme le nombre de pages de 16 kilo-octets à allouer de la mémoire. Les valeurs par défaut sont les suivantes :
  • Agent (systèmes d’exploitation de poste de travail) : 640 (10 mégaoctets)
  • Agent (systèmes d’exploitation de serveur) : 1920 (30 Mo)
  • Serveur de gestion : 5120 (80 mégaoctets)
Si vous rencontrez ce problème, nous vous conseillons de définir la taille du magasin de version pour doubler sa taille par défaut. Par exemple, si vous définissez la taille du magasin de version sur un ordinateur qui héberge un rôle de serveur de gestion, définissez la valeur de Registre à 10240 (décimal).

Après avoir appliqué la modification du Registre, redémarrez le service HealthService.

Remarques
Propriétés

ID d'article : 975057 - Dernière mise à jour : 13 janv. 2017 - Révision : 1

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