Vous ne pourrez pas effectuer certaines opérations liées au disque après une exception lorsqu’un fournisseur de matériel tente de créer une capture instantanée dans Windows Server 2008 R2 ou Windows 7

Symptômes

Considérez le scénario suivant :


  • Vous créez un volume qui couvre un ou plusieurs disques sur un ordinateur qui exécute Windows Server 2008 R2 ou Windows 7.
  • Un fournisseur de matériel tente de créer une capture instantanée pour le volume. Toutefois, une exception se produit et l'action échoue.
Dans ce scénario, vous ne pouvez pas effectuer certaines opérations liées aux disques. Ces opérations peuvent être les suivants :
  • Vous sauvegardez une de ces disquettes à l’aide d’une application de sauvegarde tels que System Center Date Protection Manager (DPM).
  • Un de ces disques est utilisé comme un disque partagé dans un cluster de basculement Windows. Toutefois, vous ne pouvez pas mettre en ligne le disque partagé.
  • Vous exécutez une application qui appelle la fonction de rappel de ResourceControl avec le code de contrôle de ressource CLUSCTL_RESOURCE_STORAGE_GET_DISK_INFO_EX par rapport à ces disques. Toutefois, l’application retourne le code erreur 1168.

Cause

La capture instantanée d’un volume est en cours de création, Volume Shadow Copy Service (VSS) affecte les disques qui sont couverts par le volume à un état particulier. Lorsque la capture instantanée est terminée, le service VSS re définit les disques avec l’état correct. Si une exception se produit lorsqu’un fournisseur de matériel crée un instantané d’un volume, VSS réinitialise jamais les disques avec l’état correct.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, l’ordinateur doit exécuter l’un des systèmes d’exploitation suivants :
  • Windows Server 2008 R2
  • Windows 7

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif. Vous devez arrêter le Service de cliché instantané de Volume avant d’installer ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.
Note d’information de fichier Windows Server 2008 R2 et Windows 7
Les fichiers MANIFEST (.manifest) et MUM (.mum) qui est installés pour chaque environnement est répertoriés séparément. Les fichiers MUM et MANIFEST, ainsi que les fichiers de catalogue sécurité (.cat) associées, sont essentiels pour conserver l'état du composant mis à jour. Les fichiers de catalogue de sécurité (attributs non répertoriés) sont signés avec une signature numérique Microsoft.
Pour toutes les versions prises en charge x86-de Windows Server 2008 R2 et Windows 7
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Vssvc.exe6.1.7600.205321,025,53622-Sep-200905:57x86
Pour toutes les versions prises en charge x64-de Windows Server 2008 R2 et de Windows7
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Vssvc.exe6.1.7600.205321,599,48822-Sep-200906:22x64
Pour toutes les versions Itanium et Windows Server 2008 R2
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Vssvc.exe6.1.7600.205322,168,83222-Sep-200905:01IA-64


État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

Informations sur les fichiers supplémentaires pour Windows Server 2008 R2 et Windows 7

Fichiers supplémentaires pour toutes les versions prises en charge x86-de Windows Server 2008 R2 et Windows 7

Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Package_for_kb975921_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNe s'applique pas1,89123-Sep-200900:31Ne s'applique pas
X86_microsoft-windows-vssservice_31bf3856ad364e35_6.1.7600.20532_none_5b5fd2099222ce6f.manifestNe s'applique pas18,23522-Sep-200906:22Ne s'applique pas
Fichiers supplémentaires pour toutes les versions prises en charge x64-de Windows Server 2008 R2 et Windows 7

Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Amd64_microsoft-windows-vssservice_31bf3856ad364e35_6.1.7600.20532_none_b77e6d8d4a803fa5.manifestNe s'applique pas18,24122-Sep-200906:59Ne s'applique pas
Package_for_kb975921_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNe s'applique pas2,12523-Sep-200900:31Ne s'applique pas
Fichiers supplémentaires pour toutes les versions Itanium et prise en charge de Windows Server 2008 R2

Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Ia64_microsoft-windows-vssservice_31bf3856ad364e35_6.1.7600.20532_none_5b6175ff9220d76b.manifestNe s'applique pas18,23822-Sep-200906:49Ne s'applique pas
Package_for_kb975921_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNe s'applique pas1,68323-Sep-200900:31Ne s'applique pas

Références

Pour plus d’informations sur la fonction ResourceControl, cliquez sur l’article suivant sur le site Web de Microsoft :Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

975832 , vous ne pourrez pas exécuter certains disques des opérations liées après qu’un fournisseur de matériel ne peut pas créer des instantanés dans Windows Server 2008 ou Windows Vista

Propriétés

ID d'article : 975921 - Dernière mise à jour : 13 janv. 2017 - Révision : 1

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