Message d’erreur lorsque vous installez le package de mise à jour de base de données Office Communications Server 2007 R2 datée de juillet 2009 : « Erreur 1722 »

Symptômes

Lorsque vous essayez d’installer le package de mise à jour de base de données Microsoft Office Communications Server 2007 R2 qui est daté juillet 2009, l’installation échoue. En outre, le message d’erreur suivant s’affiche :

Produit : Microsoft Office Communications Server 2007 R2 (KB969834) : erreur 1722. Il existe un problème avec ce package Windows Installer. Un programme exécuté dans le cadre de l’installation ne s’est pas terminée comme prévu. Contactez votre personnel de support ou le fournisseur du package. Action CA_DBUpdateSE, emplacement : lecteur : \Program Files\Microsoft Office Communications Server 2007 R2\DBSetupQfe\, commande : Drive:\Windows\SysWOW64\cscript.exe dbqfeupdate.wsf /Role:SE


Le message d’erreur suivant est également enregistré dans le journal QFE_DBSetup :

Procédures stockées de mise à jour de la base de données du serveur SE. Cela prendra un certain temps...
cscript dbsetup.wsf /SqlServer : (local) \rtc /Role:se /Verbose

Microsoft (R) Windows Script Host Version 5.7
Copyright (C) Microsoft Corporation. Tous droits réservés.

Connexion à SQL Server sur (local) \rtc
SqlMajorVersion : 9
Chiffre : 00
SqlBuildNo : 3042
Validation de SQL : Reconfigure a rencontré aucune erreur et version SQL est acceptable : 9.00.3042.00
Ouverture de la base de données rtc
Version du schéma de base de données est de 37
Version de la procédure stockée de base de données est de 70
Version de correctif de base de données est 2
(Mise à niveau majeure de la base de données requise.)

Cette base de données contient une version plus récente de Qfe et ne peut donc être réutilisée. Il doit être supprimé et un nouveau créé si nécessaire.

Pour conserver les données, vous devez utiliser la solution de restauration/importation/exportation de la sauvegarde de ce produit. Examinez la documentation du produit pour obtenir des instructions.


En outre, le composant des Services de l’utilisateur échoue sur le serveur frontal Office Communications Server 2007 R2 ou sur le serveur Office Communications Server 2007 R2 Standard Edition qui se connectent à la base de données back-end. Lorsque ce problème se produit, le message d’erreur suivant s’affiche :

Échec de la connexion pour l’utilisateur 'Contoso\RTCService'. [CLIENT : < ordinateur local >]

------------------------

Impossible de se connecter à la base de données back-end. Office Communications Server tentera de continuer à se reconnecter au back-end. Tant que cette condition persiste, les messages entrants pour recevoir les réponses de l’erreur.

Serveur de back-end : base de données (local) \rtc : rtc des chaîne de connexion de :
pilote = {SQL Native Client} ; Trusted_Connection = yes ; AutoTranslate = no ; server = (local) \rtc;database=rtc;network=dbmslpcn ;

Cause : Des problèmes possibles avec la base de données back-end.
Résolution :

Vérifiez que le principal fonctionne correctement.

------------------------

Échec du traitement des demandes d’état de conférence. Cette erreur peut retarder la libération de conférence PSTN ID dans les répertoires de conférence hébergés sur ce pool.

Code d’erreur : 0x800407D0

Cause : Problèmes de Possible avec back-end ou le fonctionnement d’Office Communications Server.
Résolution :
Assurez-vous que le service Office Communications Server est en bon état.

Cause

Ce problème se produit lorsque vous installez le package de mise à jour de base de données Office Communications Server 2007 R2 datée de janvier 2010, avant d’installer le package de mise à jour de base de données Office Communications Server 2007 R2 datée de juillet 2009.

Solution de contournement

Lorsque ce problème se produit, le niveau du paramètre Restreindre l’accès de la base de données RTC et de la base de données RTCDyn a RESTRICTED_USER. Lorsque le niveau RESTRICTED_USER est défini, les connexions de base de données échouent. Pour contourner ce problème, procédez comme suit :
  • Se connecter à Microsoft SQL Server.
  • Fermez toutes les connexions aux bases de données RTC et aux bases de données RTCDyn.
  • Définir le niveau du paramètre Restreindre l’accès des bases de données RTC et des bases de données RTCDyn à MULTI_USER.
  • Redémarrez le processus du service RTCSRV sur le serveur frontal.
Propriétés

ID d'article : 978377 - Dernière mise à jour : 13 janv. 2017 - Révision : 1

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