Nouveaux en-têtes X-Header d’un élément de message ne s’affichent pas lorsque le message est extrait par IMAP4 ou POP3 dans un environnement Exchange Server 2007 SP2

Symptômes

Dans un environnement Microsoft Exchange Server 2007 SP2, vous utilisez le IMAP4 commande APPEND pour ajouter un élément de message qui a des nouveaux en-têtes X-Header. Lorsque l’élément de message est récupérée par IMAP4 ou récupérée par POP3, les nouveaux en-têtes X-Header n’apparaisse pas. Toutefois, les nouveaux en-têtes X-Header s’affichent si l’élément de message est récupérée par MAPI ou par des clients Outlook Web Access (OWA).

Remarque Lorsque ce problème se produit, le paramètre HeaderPromotionModeSetting est défini à MayCreate à l’aide de l’applet de commande Set-TransportConfig .

Cause

Ce problème se produit car les nouveaux en-têtes X ne sont pas promus aux propriétés nommées par le serveur Exchange Server 2007. Par conséquent, aucune donnée pour les nouveaux en-têtes X-Header peut être converti à partir de MAPI à MIME lorsque vous essaient de clients POP3/IMAP4 récupérer l’élément de message.

Résolution

Pour résoudre ce problème, installez le correctif cumulatif suivant :
Description de 2602324 du correctif cumulatif 5 pour Exchange Server 2007 Service Pack 3

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d’informations sur l’applet de commande Set-TransportConfig , visitez le site Web Microsoft suivant :Pour plus d’informations sur les propriétés nommées, visitez le site Web Microsoft suivant :
Propriétés

ID d'article : 981820 - Dernière mise à jour : 12 janv. 2017 - Révision : 2

Commentaires