Restauration des associations de fichiers .lnk

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 172053
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Lorsque vous sélectionnez les programmes à partir du menu Démarrer ou des raccourcis que rien ne se produit, la boîte de dialogue « Ouvrir avec » s'affiche ou l'exécution d'un programme spécifique.
Cause
L'association de .lnk est manquante, incorrecte ou endommagée. Raccourcis de la Becauseall et les éléments de Menu du programme sont les fichiers avec l'extension .lnk. Sélection de l'un affiche la boîte de dialogue « Ouvrir avec », une specificapplication tel que Notepad.exe ou Wordpad.exe ou ne fait rien.
Résolution
Pour corriger ce problème en restaurant la clé de Registre à partir de l'ordinateur d'anotherworking ou manuellement remplacer la clé de Registre.

Avertissement: l'utilisation incorrecte de l'Éditeur du Registre peut provoquer des sérieux, wideproblems système peut vous obliger à réinstaller Windows NT pour les résoudre. Microsoft ne garantit pas que les problèmes résultant de l'ofRegistry d'utilisation que éditeur peut être résolu. Vous utilisez cet outil à vos risques et périls.

Pour restaurer la clé de Registre depuis un autre ordinateur, procédez comme suit :
  1. Démarrez la Base de Registre (Regedt32.exe) et sélectionnez la sous-clé suivante :
       HKEY_CLASSES_ROOT\.lnk						
  2. Dans le menu Edition, cliquez sur Supprimer.
  3. Sur un autre ordinateur Windows NT 4.0, démarrez la Base de registre (Regedt32.exe) et sélectionnez la clé de Registre HKEY_CLASSES_ROOT\.lnk.
  4. Dans le menu Registre, cliquez sur Exporter la clé.
  5. Copiez ce fichier sur l'ordinateur présentant le problème ou sur une disquette.
  6. Sur l'ordinateur qui présente le problème, recréez la clé de Registre en sélectionnant HKEY_CLASSES_ROOT puis, dans le menu Edition, cliquez sur Ajouter une clé. Tapez .lnk pour le nom de la clé.
  7. Sélectionnez la nouvelle clé, cliquez sur Restaurer dans le menu Registre et sélectionnez le fichier à partir de l'autre ordinateur ou de la disquette.
  8. Quittez la Base de Registre et redémarrez l'ordinateur. Testez un élément du menu Programmes ou un raccourci.
Pour saisir manuellement les informations, effectuez les opérations suivantes :
  1. Démarrez la Base de registre (Regedt32.exe), sélectionnez la sous-clé HKEY_CLASSES_ROOT, puis cliquez sur Ajouter une clé dans le menu Edition.
  2. Dans la zone Nom de clé tapez ".lnk" (sans les guillemets), puis cliquez sur OK. Notez que vous devez laisser la zone de classe vide.
  3. Dans la boîte de dialogue Ajouter une Valeur, cliquez sur OK pour laisser le Nom de Valeur vide et cliquez sur REG_SZ dans la Liste des type de Données.
  4. Dans la zone de l'Editeur de chaînes, tapez « lnkfile » (sans guillemets), puis cliquez sur OK.
  5. Sélectionnez la clé .lnk que vous venez de recréer sous la sous-clé HKEY_CLASSES_ROOT. Dans le menu Edition, cliquez sur Ajouter une clé et tapez « ShellNew » (sans les guillemets). Notez que vous devez laisser la zone de classe vide.
  6. Cliquez sur Ajouter une Valeur dans le menu Edition, tapez "command" (sans les guillemets) dans la zone Nom des données, cliquez sur REG_SZ dans la zone Nom des données, puis tapez "RunDLL32 AppWiz.Cpl,NewLinkHere %1 » (sans les guillemets) comme valeur de chaîne.
  7. Quittez la Base de Registre et redémarrez l'ordinateur.
Comment faire pour les types de fichiers

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 172053 - Dernière mise à jour : 12/04/2015 17:30:42 - Révision : 12.0

Microsoft Windows NT Workstation 4.0 Édition Développeur, Microsoft Windows NT Server 4.0 Standard Edition

  • kbnosurvey kbarchive kbfile kbhowto kbmt KB172053 KbMtfr
Commentaires