XADM : banque d'informations ne démarre pas après une défragmentation hors ligne avec 4294966277

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

La version anglaise de cet article est la suivante: 242364
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Après que vous exécutez une défragmentation hors connexion (la commande eseutil / d ), la banque d'informations ne démarre pas et renvoie un message d'erreur 4294966277.

Les événements suivants sont enregistrés dans le journal des événements Applications :
L'ID d'événement: 0
Source : ESE97
Type : erreur
Catégorie : enregistrement/récupération
Description : MSExchangeIS (451) 1019

L'ID d'événement : 1120
Source : MSExchangeIS
Type : erreur
Catégorie : général
Description : erreur 0xfffffc05 l'initialisation de la base de données de la banque d'informations Microsoft Exchange Server.
Le fichier Tempdfrg.edb (ce nom de fichier peut être différent si vous avez utilisé un commutateur / t dans la commande de défragmentation) qui est créé lors de la défragmentation est toujours sur le lecteur ; supprime une défragmentation normale.
Cause
La défragmentation de banque d'informations ne termine pas la copie de la base de données dans le fichier (défragmenté temporaire à l'emplacement d'origine. La base de données est donc endommagé et inutilisable. Le message d'erreur 4294966277 est une erreur JET_errPageNotInitialized, ce qui signifie qu'une page dans la base de données est vide ou n'a pas été initialisée correctement.
Résolution
Lorsque la défragmentation hors connexion ne termine pas la copie, la base de données temporaire n'est pas supprimée. Si la base de données temporaire est la base de données intacte, été défragmenté, vous pouvez il copier manuellement vers l'emplacement correct.

Si vous défragmenté uniquement une base de données et que vous connaissez la base de données est endommagé, passez à la section « Copie du Database temporaires » de cet article. Si vous défragmentation des bases de données à la fois le Priv.edb et Pub.edb et vous ne sont pas que la base de données a provoqué le problème, procédez comme suit pour déterminer la base de données à l'origine du problème :
  1. Vérifier l'intégrité de la Priv.edb et Pub.edb bases de données :
    • Pour vérifier la base de données Priv1.edb, à une invite de commandes, exécutez suivantes :
      ESEUTIL /g /ispriv
    • Pour vérifier la base de données pub.edb, à une invite de commandes, exécutez suivantes :
      ESEUTIL /g /ispub
  2. Notez la base de données ne réussit pas la vérification d'intégrité et renvoie un message d'erreur 1019.
  3. Notez la taille du fichier de base de données qui ne transmettent pas le contrôle d'intégrité.
  4. Comparez cette taille à la taille du fichier temporaire.
En comparant la taille des deux fichiers, vous pouvez déterminer si le fichier Tempdfrg.edb est la version défragmentée du fichier de base de données endommagée. Dans la plupart des cas, les fichiers sont la même taille. Le processus de copie définit part l'espace au début du processus, et bien que le processus ne se termine pas, la taille du fichier de base de données correspond à toujours le fichier source.

Copie de la base de données temporaire

Pour vous assurer que la défragmentation de la base de données terminée avec succès et copier le fichier défragmenté vers l'emplacement correct :

  1. Remarque : Ces étapes supposent que les bases de données de banque d'informations se trouvent sur le serveur dans le dossier D:\Exchsrvr\Mdbdata et le fichier temporaire de défragmentation se trouve sur le lecteur D (D:\Tempdfrg.edb).

  2. Effectuer un contrôle d'intégrité sur le fichier temporaire. À l'invite de commandes, exécutez suivantes :
    ESEUTIL /g d:\tempdfrg.edb
    Si le contrôle d'intégrité se termine correctement, passez à l'étape suivante. Si le contrôle d'intégrité ne se termine pas correctement, les deux copies de la base de données sont endommagés et vous devez restaurer la base de données à partir d'une sauvegarde.
  3. Renommez la base de données endommagée (base de données soit le Priv.edb ou Pub.edb).
  4. Copiez-le défragmentation temporaire du lecteur D (D:\Tempdfrg.edb) dans le dossier D:\Exchsrvr\Mdbdata.
  5. Dans le dossier D:\Exchsrvr\Mdbdata, renommez le fichier Tempdfrg.edb du nom de fichier de base de données correct (Priv.edb ou Pub.edb).
  6. Démarrer la banque d'informations.
Remarque : Si un message d'erreur-1011 s'affiche lorsque vous démarrez la banque d'informations, il n'indique pas un problème. La banque d'informations et le répertoire doivent être a resynchronisé. Pour synchroniser les informations banque et le répertoire, à une invite de commandes, exécutez suivantes :
\exchsrvr\bin\isinteg - correctif
Plus d'informations
Une défragmentation hors connexion copie des données à partir de la base de données en cours vers un nouveau fichier de base de données. Lorsque le processus de défragmentation atteint 100 % le fichier temporaire est une base de données complète et défragmenté. À ce stade, l'utilitaire copie le fichier temporaire à l'emplacement d'origine, qui remplace la base de données d'origine.

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 242364 - Dernière mise à jour : 02/13/2014 14:22:15 - Révision : 3.2

Microsoft Exchange Server 5.5 Standard Edition

  • kbnosurvey kbarchive kbmt kbprb KB242364 KbMtfr
Commentaires