Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

Incompatibilité entre les profils errants et l'impression à partir d'Internet car les profils ne sont pas enregistrés

Ancien nº de publication de cet article : F247574
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Lorsque vous vous déconnectez d'une session Services Terminal, les modifications apportées à votre profil errant peuvent ne pas être enregistrées.

Par ailleurs, les impressions en attente sur une imprimante Internet peuvent ne pas s'imprimer si vous vous déconnectez avant que ces derniers n'aient été entièrement mis en file d'attente sur l'imprimante Internet. Les impressions figurant dans la file d'attente peuvent être arrêtées sur le serveur Services Terminal.

Vous pouvez également remarquer une perte de mémoire sur le port d'imprimante Internet (en particulier, Wininet.dll).
Cause
Comme le processus d'impression Internet conserve une entrée du Registre ouverte dans HKEY_CURRENT_USER, le service Winlogon ne peut pas décharger votre Registre ni récrire votre profil à l'emplacement spécifié dans le Gestionnaire des utilisateurs pour les domaines. Cela a pour effet une perte de mémoire car le Registre reste chargé dans la mémoire. Bien que ce problème se produise chaque fois qu'un profil errant est utilisé lors d'une impression à partir d'Internet, la perte de mémoire peut éventuellement n'apparaître que sur un serveur Terminal Services sur lequel plusieurs utilisateurs se connectent et se déconnectent plusieurs fois entre les redémarrages du serveur.
Résolution
Pour résoudre ce problème, procurez-vous le dernier Service Pack Windows 2000. Pour plus d'informations, consultez l'article suivant dans la Base de connaissances Microsoft :
260910 Procédure pour obtenir le dernier Service Pack Windows 2000
Pour contourner temporairement ce problème, n'utilisez pas l'impression à partir d'Internet avec des profils errants si vous souhaitez que ceux-ci soient enregistrés.Aussi, n'utilisez pas l'impression à partir d'Internet avec des profils errants dans un environnement Terminal Services, ce qui pourrait provoquer une perte de mémoire et un arrêt des impressions en file d'attente.
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article".

Ce problème a été corrigé dans le Service Pack 1 Windows 2000.
IPP 1.0 web webpnp
Propriétés

ID d'article : 247574 - Dernière mise à jour : 02/03/2014 10:00:24 - Révision : 4.0

Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professionel, Microsoft Windows 2000 Server

  • kbnosurvey kbarchive kbprint kbenv kbprb KB247574
Commentaires