Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

Comment les administrateurs système peuvent dépanner un message d'erreur « HTTP 404 - Fichier introuvable » sur un serveur qui exécute IIS

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 248033
Symptômes
Lorsqu'une page Web est demandée, le message d'erreur suivant s'affiche en haut du navigateur Web :
La page ne peut pas être trouvée.
La page que vous recherchez a été supprimée, que son nom ait changé ou est temporairement indisponible.
Vous recevez le message d'erreur suivant plus bas sur la page Web :
HTTP 404 - Fichier non trouvé
Services Internet (IIS).
Cause
Le serveur Web renvoie le message d'erreur « HTTP 404 - Fichier introuvable » lorsqu'il ne peut pas extraire la page demandée.

Certaines causes courantes de ce message d'erreur sont les suivantes :
  • Le fichier demandé a été renommé.
  • Le fichier demandé a été déplacé vers un autre locationand / ou supprimé.
  • Le fichier demandé est temporairement indisponible, tomaintenance, mises à niveau, ou de toute autre cause inconnue.
  • Le fichier demandé n'existe pas.
  • IIS 6.0 : L'extension de service Web appropriée ou le type MIME n'est pas activé.
  • Un répertoire virtuel est mappé à la racine d'un lecteur sur un autre serveur.
Résolution
Pour résoudre ce problème, vérifiez que le fichier demandé dans l'URL du navigateur existe sur l'ordinateur IIS et qu'il est dans l'emplacement correct.

Utilisez le composant logiciel enfichable Console de gestion Microsoft (MMC) IIS pour déterminer où le fichier demandé doit exister dans le système de fichiers de l'ordinateur IIS.

Ceci est particulièrement important si le site Web utilise un répertoire virtuel (VDIR). Un répertoire virtuel est un répertoire qui n'est pas contenu dans le répertoire de base du site Web, mais qui s'affiche dans le navigateur client comme si c'est le cas. Ce répertoire virtuel doit être mappé vers un sous-dossier sur un lecteur ou référencer les fichiers par nom.

Par exemple, supposons que l'URL qui a provoqué l'erreur 404 soit http://Microsoft.Com/Test/File1.htm, et que le composant logiciel enfichable IIS indique que pour le site Microsoft.Com Web, le répertoire /Test/ est en fait un répertoire virtuel mappé sur l'emplacement c:\Information sur l'ordinateur IIS. Cela signifie que vous devez vérifier que le fichier File1.htm se trouve dans le répertoire c:\Information (et que le nom de fichier est orthographié correctement).

IIS6 Contenu dynamique : une entrée 404.2 dans le journal W3C étendu est enregistrée lorsqu'une Extension Web n'est pas activée. Utilisez le composant logiciel enfichable de la Console de gestion Microsoft (MMC) IIS pour activer l'extension Web appropriée. Inclure les Extensions Web par défaut : ASP, ASP.net, Server-Side Includes, le WebDAV de publication, les Extensions serveur FrontPage, Interface CGI (Common Gateway). Les extensions personnalisées doivent être ajoutées et explicitement activées. Consultez le fichier d'aide IIS 6.0 pour plus d'informations.
IIS6 Contenu statique : une entrée 404.3 dans le journal W3C étendu est enregistrée lorsqu'une extension n'est pas mappée à une extension connue dans la propriété mappage MIME. Utilisez le composant logiciel enfichable de la Console de gestion Microsoft (MMC) IIS pour configurer l'extension appropriée dans le mappage MIME. Consultez le fichier d'aide d'IIS 6.0 pour plus d'informations.

Pour plus d'informations sur d'autres, moins les causes courantes de ce message d'erreur, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
247714 À l'aide de la commande PUT pour un nom de fichier long provoque l'erreur « HTTP 404 - Fichier introuvable »
221553 Définition des attributs de fichier de contenu Web provoque 404 - Fichier introuvable
216803 Les fichiers statiques masqués IIS renvoient HTTP 404 ou erreurs de refus d'accès
288123 Erreur HTTP 404 « Impossible d'afficher la Page » lorsque vous essayez de vous connecter au serveur OWA après la mise à niveau à partir d'Exchange Server 5.5 vers Exchange 2000 Server
Plus d'informations
Pour plus d'informations sur les répertoires virtuels, consultez la rubrique « À propos de gestion de site Web » dans la documentation IIS 5.0 à l'emplacement suivant :
Administration\Gestion Site propos de la gestion du Site Web
Remarque Si vous disposez de la documentation IIS 5.0 est installée sur votre ordinateur local, vous pouvez utiliser l'URL suivante pour trouver la rubrique :Pour afficher cette rubrique sur un ordinateur basé sur Microsoft Windows Server 2003 sur lequel IIS est installé, collez le lien suivant dans la barre d'adresses de votre navigateur et appuyez sur ENTRÉE :
mk:@MSITStore:C:\WINDOWS\help\iismmc.chm::/htm/qss_wss_troubleshooting.htm
Remarque C:\Windows est la racine du système. Si votre système d'exploitation Windows est installé sur un lecteur différent, vous devez modifier le lien.

Vous pouvez également accéder à la documentation du produit par l'intermédiaire du Gestionnaire des services IIS. Pour plus d'informations sur la façon d'accéder à cette fonctionnalité aide, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
815127 Comment faire pour accéder à la documentation d'aide d'IIS 6.0
RemarqueNous recommandons fortement que tous les utilisateurs se mettent à niveau vers la version 7.0 de Microsoft Internet Information Services (IIS) en cours d'exécution sur Microsoft Windows Server 2008. IIS 7.0 augmente considérablement la sécurité d'infrastructure Web. Pour plus d'informations sur les questions liées à la sécurité IIS, visitez le site Web de Microsoft à l'adresse suivante :Pour plus d'informations sur IIS 7.0, visitez le site Web de Microsoft à l'adresse suivante :
IIS 5 iis5 iis 6 iis 6.0 iis6 lien ie Internet Explorer Netscape navigateur Opera Mosaic page introuvable à wkz

Avertissement : cet article a été traduit automatiquement

Propriétés

ID d'article : 248033 - Dernière mise à jour : 08/16/2015 22:28:00 - Révision : 10.0

Microsoft Internet Information Server 1.0, Microsoft Internet Information Server 2.0, Microsoft Internet Information Server 3.0, Microsoft Internet Information Services 6.0, Microsoft Internet Information Services 7.0

  • kbresolve kbhttp404 kbprb kbprod2web kbmt KB248033 KbMtfr
Commentaires
=">")[0].appendChild(m);