Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

L'importation d'une solution peut ne pas aboutir dans Microsoft Dynamics CRM 2011

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

La version anglaise de cet article est la suivante: 2491352
Symptômes
Lorsque vous essayez d'importer une solution dans Microsoft Dynamics CRM 2011, l'importation ne peut pas réussir. En outre, vous pouvez recevoir le message d'erreur suivant :

0x80048298 - System.Web.Services.Protocols.SoapException : la définition de rapport n'est pas valide. Détails : La définition de rapport a une cible non valide espace de noms « http://schemas.microsoft.com/sqlserver/reporting/2010/01/reportdefinition » ne peut pas être mis à niveau.

à Microsoft.ReportingServices.WebServer.ReportingService2005Impl.CreateReport (chaîne rapport, chaîne Parent, remplacer Boolean, Byte [] définition, propriété [], propriétés de [] Avertissement & des avertissements)

à Microsoft.ReportingServices.WebServer.ReportingService2005.CreateReport (chaîne rapport, chaîne Parent, remplacer Boolean, Byte [] définition, propriété [], propriétés de [] Avertissement & des avertissements)


Cause
Ce problème se produit car un des rapports personnalisés de la solution est créé dans SQL Reporting Services 2008 R2. La première section de la message d'erreur signifie que le rapport a été créé dans SQL Reporting Services 2008 R2. Si vous essayez d'importer la solution dans un environnement CRM qui a été configuré à l'aide de SQL Reporting Services 2008, vous recevez le message d'erreur car l'espace de noms de cette version ne reconnaît pas le schéma SQL Reporting Services 2008 R2.
Résolution
Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1

Importer la solution dans un environnement qui a été configuré à l'aide de SQL Reporting Services 2008 R2.

Méthode 2

Créer le même rapport dans un environnement SQL Reporting Services 2008. Ensuite, chargez le nouveau rapport dans Microsoft Dynamics CRM et inclure le nouveau rapport dans votre solution.
Échec de la solution, rapports, SRS 2008 R2, importation,

Avertissement : cet article a été traduit automatiquement

Propriétés

ID d'article : 2491352 - Dernière mise à jour : 02/25/2011 15:14:00 - Révision : 1.2

Microsoft Dynamics CRM 2011, Microsoft Dynamics Live CRM Professional Edition

  • kbmbsmigrate kbsurveynew kbprb kbmt KB2491352 KbMtfr
Commentaires
>d")[0].appendChild(m);