Vous ne pouvez pas installer les mises à jour dans Windows Vista, Windows 7, Windows Server 2008 ou Windows Server 2008 R2

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La version anglaise de cet article est la suivante: 2509997
Symptômes

Utilisateurs à domicile
: Veuillez ne pas essayer ça chez vous ! Cet article est destiné à une utilisation par les agents du support et des professionnels de l’informatique. Si vous recherchez plus d’informations sur les erreurs Windows Update ou Microsoft Update, consultez les sites Web Microsoft suivants :

Lorsque vous essayez d’installer une mise à jour pour Windows, un composant de Windows, ou un Microsoft ou le logiciel tiers, vous rencontrez un ou plusieurs des problèmes suivants :
  • Vous ne pouvez pas afficher les rôles de Windows ou des fonctionnalités.
  • Installation du service pack échoue.
  • Lorsque vous essayez de vous connecter au site Web Windows Update ou Microsoft Update, un des codes d’erreur suivants est enregistré dans le journal de Windows Update (windowsupdate.log) ou dans le journal de Component Based Servicing (CBS.log) :
    • 0xC80001FE
    • 0x80200010
    • 0x80070643
    • 0x80246002
    • 0x80070490
    • 0x80070420
    • 0x80073712
    • 0x80246007
    • 0x8000ffff
    • 0 x 80070424
    • 0x80248007
    • 0x8007064C
    • 0x8024D00C
    • 0x8007066A
    • 0 x 80245003
    • 0x8024402C
Cause
Ce problème peut se produire si une ou plusieurs des conditions suivantes sont remplies :
  • La base de données mise à jour de Windows est endommagée.
  • Un logiciel antivirus est configuré pour analyser le dossier %Windir%\SoftwareDistribution.
  • Le service Service de transfert Intelligent en arrière-plan (BITS) ne reçoit pas un lien en-tête de contenu.
  • Un fichier système requis est incorrectement enregistré.
  • Le programme d'installation de Windows a rencontré une erreur.
  • Le manifeste Component Based Servicing (CBS) est endommagé.
  • Le service de mise à jour de Windows s'arrête pendant le processus d'installation.
  • Il existe un conflit de version de fichier avec les fichiers de l’agent de mise à jour de Windows.
Résolution
Pour résoudre ce problème, essayez successivement chacune des méthodes suivantes. Après chaque méthode, effectuez un test pour voir si le problème est résolu avant de passer à la méthode suivante. Si le problème est résolu avec une méthode, vous n'êtes pas obligé d'essayer les autres méthodes.


Méthode 1: Exécutez l'outil de dépannage Windows Update

Pour ce faire, allez à la Outil de dépannage Windows Update.

Méthode 2: Télécharger et installer manuellement la mise à jour

Pour ce faire, procédez comme suit :
  1. Déterminer le numéro de l'article de Base de connaissances Microsoft correspondant à la mise à jour qui a échoué. Pour ce faire, effectuez l'une des actions suivantes : afficher le message de code d'erreur.
    • Permet d'afficher le message de code d'erreur.
    • Permet d’afficher l’historique de mise à jour sur le site Web Windows Update ou sur le site Web Microsoft Update. Pour ce faire, procédez comme suit :
      1. Accédez au site Web Microsoft Update suivant :
      2. Sous Options, cliquez sur consulter l’historique de mise à jour.
      3. Dans la colonne mise à jour, déterminer le numéro de l’article de Base de connaissances Microsoft de la mise à jour qui a échoué.
  2. Accédez au site Web de téléchargement de Windows suivant :
  3. Dans la zone de recherche sur la page Web de téléchargements, tapez le numéro de l'article que vous avez localisé à l'étape 1 et puis cliquez sur OK.
    Remarque Si l'article que vous avez localisé porte le numéro "kb123456", par exemple, tapez seulement"123456" (sans les lettres). Par exemple, tapez « kb123456 » en tant que 123456.
  4. Parcourez la liste de contenu renvoyé pour rechercher l’article de la Base de connaissances qui contient un lien vers le téléchargement.
    Remarque Vous pouvez être invité à valider Windows. Si vous y êtes invité, suivez les instructions pour valider Windows et poursuivez la mise à jour.
  5. Cliquez sur Télécharger, puis cliquez sur Enregistrer lorsque vous êtes invité à enregistrer le fichier téléchargé. Enregistrer le téléchargement sur votre bureau.
  6. Une fois le téléchargement terminé, cliquez sur Ouvrir pour installer la mise à jour.
    Remarque L'installation de la mise à jour peut échouer si la mise à jour est incorrecte pour votre version de Windows.

Méthode 3 : Redémarrez votre ordinateur, puis essayez de nouveau d’installer les mises à jour

Quittez tous les programmes en cours d'exécution et redémarrez votre ordinateur puis essayez de nouveau d'installer les mises à jour.

Remarque Le redémarrage de l'ordinateur va assurer que toutes les installations précédentes ont terminé et qu'aucun processus restant ne nécessite un redémarrage système pour pouvoir terminer.

Méthode 4 : Exécutez l’outil de préparation de mise à jour système (CheckSur.exe)

Téléchargez et exécutez l'outil de préparation de mise à jour système. Cet outil exécute une analyse ponctuelle des incohérences qui peuvent empêcher les futures opérations de maintenance. Pour plus d’informations sur la façon de télécharger et d’exécuter l’outil CheckSur.exe, consultez l’article suivant dans la Base de connaissances Microsoft :
Corriger les erreurs de corruption de Windows en utilisant le (outil DISM ou de préparation de mise à jour systèmehttps://support.Microsoft.com/kb/947821)
Essayez d'installer les mises à jour à nouveau.

Remarque Après avoir exécuté l’outil, le fichier CheckSur.log est enregistré à l’emplacement suivant :
%SystemRoot%\Logs\CBS

Méthode 5 : Exécuter l’outil Vérificateur des fichiers système (SFC.exe)

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. À l'invite de commandes, tapez sfc/scannow, puis appuyez sur entrée.
  3. Une fois l’analyse terminée, essayez de réinstaller les mises à jour.

Méthode 6 : Réinitialiser le contenu du dossier Catroot2

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. Tapez les commandes suivantes et appuyez sur ENTRÉE après chaque commande :
    • net stop cryptsvc
    • MD %systemroot%\system32\catroot2.old
    • xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.old /s
  3. Supprimer tout le contenu du dossier catroot2, mais ne supprimez pas le dossier catroot2.
  4. Tapez la commande suivante et appuyez sur ENTRÉE :
    Net start cryptsvc
  5. Fermez la fenêtre d'invite de commande.

Méthode 7 : Supprimer toutes les valeurs du Registre

Supprimez toutes les valeurs incorrectes qui peuvent exister dans le Registre. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, puis tapez Regedit dans la zone Rechercher .
  2. Dans la liste des programmes, cliquez sur regedit.exe.
  3. Recherchez, puis sélectionnez la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\COMPONENTS
  4. Cliquez (bouton droit) sur composants.
  5. Cliquez sur Exporter.
  6. Dans la zone Nom de fichier , tapez composants.
  7. Dans la zone Enregistrer dans , cliquez sur Bureauet cliquez sur Enregistrer, puis enregistrez le fichier sur votre bureau.
  8. Dans le volet d'informations, cliquez droit sur PendingXmlIdentifieret puis cliquez sur Supprimer. Si cette valeur n’existe pas, passez à l’étape suivante.
  9. Dans le volet de détails, NextQueueEntryIndexd’avec le bouton droit, puis cliquez sur Supprimer. Si cette valeur n’existe pas, passez à l’étape suivante.
  10. Dans le volet de détails, AdvancedInstallersNeedResolvingd’avec le bouton droit, puis cliquez sur Supprimer. Si la valeur n’existe pas, passez à l’étape suivante.
  11. Redémarrez l'ordinateur.
  12. Essayez de nouveau d’installer les mises à jour.

Méthode 8 : Enregistrer les fichiers de mise à jour de Windows

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. À l’invite de commandes, tapez la commande suivante :
    REGSVR32 WUPS2.DLL /SREGSVR32 WUPS.DLL /SREGSVR32 WUAUENG.DLL /SREGSVR32 WUAPI.DLL /SREGSVR32 WUCLTUX.DLL /SREGSVR32 WUWEBV.DLL /SREGSVR32 JSCRIPT.DLL /SREGSVR32 MSXML3.DLL /S
  3. Essayez d'installer les mises à jour à nouveau.

Méthode 9 : Assurez-vous que votre application antivirus n’analyse pas certains fichiers

Assurez-vous que votre application antivirus n’analyse pas les fichiers dans le répertoire % windir % \SoftwareDistribution sur n’importe quel ordinateur sur lequel l’Agent de mise à jour de Windows est installé.

Pour les ordinateurs qui exécutent Windows Server 2003, Microsoft Windows 2000, Windows XP, Windows Vista ou Windows Server 2008, ne pas analyser les fichiers et les dossiers suivants.

Remarque Ces fichiers ne sont pas en risque d'infection. Si vous analysez ces fichiers, des problèmes de performance graves peuvent se produire car certains fichiers peuvent être verrouillés. Si un jeu spécifique de fichiers est identifié par son nom, excluez uniquement ces fichiers au lieu du dossier entier. Parfois, le dossier complet doit être exclu. N’excluez pas ces éléments en fonction de l’extension de nom de fichier. Par exemple, n’excluez pas tous les fichiers ayant une extension .dit. Microsoft n'a aucun contrôle sur les autres fichiers qui peuvent utiliser les mêmes extensions que ces fichiers.
  • Fichiers qui sont associés à Microsoft Windows Update ou à la mise à jour automatique
  • Le fichier de base de données mise à jour de Windows ou le fichier de base de données mise à jour automatique

    Remarque Ce fichier (Datastore.edb) se trouve dans le répertoire suivant :
    %windir%\SoftwareDistribution\Datastore
  • Les fichiers journaux des transactions

    Remarque Ces fichiers sont situés dans le dossier suivant :
    %windir%\SoftwareDistribution\Datastore\Logs
Excluez les fichiers suivants :
  • Edb*.log

    Remarque Le caractère générique indique la présence possible de plusieurs fichiers.
  • Res1.log
  • Res2.log
  • Edb.chk
  • Tmp.edb

Méthode 10 : Renommer le dossier SoftwareDistribution

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. Exécutez les commandes suivantes et appuyez sur ENTRÉE après chaque commande :
    • Net stop wuauserv
    • CD %systemroot%
    • Ren SoftwareDistribution SoftwareDistribution.old
    • Net start wuauserv
  3. Essayez d'installer les mises à jour à nouveau.
Important Les problèmes suivants se produisent lorsque vous utilisez cette méthode :
  • Mises à jour qui sont actuellement téléchargés mais qui n’ont pas encore été installés doivent être téléchargés de nouveau à l’aide de Windows Update ou Microsoft Update.
  • Lorsque vous supprimez le dossier de Distribution de logiciels, l’historique des téléchargements sont supprimé.
  • Si vous recevez actuellement des mises à jour à partir de Microsoft Update et de Windows Update, vous devrez resélectionner cette option à partir du site Web Windows Update.
Remarque Si le problème est résolu (si vous pouvez télécharger et installer les mises à jour), vous pouvez supprimer en toute sécurité le dossier SoftwareDistribution.old afin de récupérer de l'espace sur votre disque.

Méthode 11 : Efface la file d’attente de BITS de tous les travaux en cours

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. À l’invite de commandes, tapez les commandes suivantes et appuyez sur ENTRÉE après chaque commande :

    Net stop bitsNet stop wuauservIpconfig /flushdnscd \documents and settings\all users\application data\microsoft\network\downloaderDel qmgr0.datDel qmgr1.datNet start bitsNet start wuauserv
    Remarque
    Après avoir terminé ces étapes, la file d’attente de BITS est désactivée.
  3. Essayez d'installer les mises à jour à nouveau.

Méthode n° 12 : Renommer Pending.xml

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. À l’invite de commandes, tapez la commande suivante :
    takeown /f C:\Windows\winsxs\pending.xml
  3. Renommez le chemin d’accès c:\windows\winsxs\pending.xml à l’aide de la commande suivante :
Ren c:\windows\winsxs\pending.xml pending.old

Méthode 13 : Exécuter Chkdsk sur la partition Windows

Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d’invite de commandes d’administration.
  2. À l’invite de commandes, tapez la commande suivante :
    Chkdsk volume: /f /r

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 2509997 - Dernière mise à jour : 08/27/2016 23:29:00 - Révision : 42.0

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