ImageX.exe ne peut pas capturer une image de Windows PE 3.0 sur un ordinateur qui exécute Windows 7 ou Windows Server 2008 R2

IMPORTANT : Cet article est issu d'une traduction automatique réalisée par un logiciel Microsoft et non par un traducteur professionnel. Cette traduction automatique a pu aussi être révisée par la communauté Microsoft grâce à la technologie Community Translation Framework (CTF). Pour en savoir plus sur cette technologie, veuillez consulter la page http://support.microsoft.com/gp/machine-translation-corrections/fr. Microsoft vous propose en effet des articles traduits par des professionnels, des articles issus de traductions automatiques et des articles issus de traductions automatiques révisées par la communauté Microsoft, de manière à ce que vous ayez accès à tous les articles de notre Base de connaissances dans votre langue. Il est important de noter que les articles issus de la traduction automatique, y compris ceux révisés par la communauté Microsoft, peuvent contenir des erreurs de vocabulaire, de syntaxe ou de grammaire. Microsoft ne pourra être tenu responsable des imprécisions, erreurs, ainsi que de tout dommage résultant d’une traduction incorrecte du contenu ou de son utilisation par les clients.

La version anglaise de cet article est la suivante: 2525084
Symptômes
Considérez le scénario suivant :
  • Vous avez un ordinateur qui exécute Windows 7 ou Windows Server 2008 R2 et qui dispose de plusieurs processeurs.
  • Vous exécutez l'outil Imagex.exe pour capturer une image dans l'environnement de préinstallation Windows (Windows PE) 3.0 sur l'ordinateur.
Dans ce scénario, Imagex.exe échoue de manière aléatoire. En outre, un des messages d'erreur suivants peut s'afficher :
Le processus ne peut pas accéder au fichier car il est utilisé par un autre processus.


L'instruction à adresse mémoire a référencé la mémoire à adresse mémoire. La mémoire n'a pas pu être écriture. Cliquez sur OK pour terminer le programme.

Cause
Ce problème se produit en raison d'un problème de synchronisation dans l'outil Imagex.exe.

Lorsque le problème de synchronisation se produit, deux threads essaient d'ouvrir un fichier en même temps. Par conséquent, vous recevez le message d'erreur qui est mentionné dans la section « Symptômes ».
Résolution
Pour résoudre ce problème, installez la dernière version d'évaluation de Windows et le Kit de déploiement Windows (Windows ADK), ou le correctif logiciel qui est décrit dans la section « Informations sur le correctif ».

Méthode 1: Installation de Windows ADK

  1. Télécharger la version la plus récente de Windows ADK.
  2. Montez le fichier Winpe.wim problématique à l'aide de l'outil Imagex.exe avec la syntaxe /mountrw . Pour ce faire, exécutez la commande suivante à une invite de commande :
    IMAGEX. EXE /mountrw chemin d'accès de la zone de mise en œuvre de Winpe.wim 1
  3. Copiez le fichier de mise à jour imagex (par défaut, il est situé dans C:\Program Files (x 86) \Windows Kits\8.1\Assessment et déploiement Kit\Deployment Tools\amd64\DISM\Imagex.exe) dans le répertoire Outils du fichier Winpe.wim monté.
  4. Démontez le fichier Winpe.wim à l'aide de l'outil Imagex.exe avec la syntaxe /commit . Pour ce faire, exécutez la commande suivante à une invite de commande :
    IMAGEX. EXE /commit

Méthode 2: Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, soumettre une demande à Microsoft Services de Support technique pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et soutien technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante : Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez exécuter un des systèmes d'exploitation suivants :
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Pour plus d'informations sur la façon d'obtenir un service pack Windows 7 ou Windows Server 2008 R2, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
976932 Informations sur le Service Pack 1 pour Windows 7 et Windows Server 2008 R2

Instructions d'installation

Pour les utilisateurs qui ont déjà installé Win7 RTM OPK ou outil WAIK Kit:

Ce téléchargement propose une version mise à jour du fichier imagex.exe qui remplacent le fichier imagex.exe sur système. Par défaut, ImageX est installé dans le dossier suivant :

Utilisateurs de Windows AIK :
C:\Program Files\Windows AIK\Tools\<architecture>

Utilisateurs du Kit de préinstallation OEM :
C:\Program Files\Windows OPK\Tools\<architecture>
Remarque : <architecture>est x 86 ou amd64 ou IA64.

Pour mettre à jour imagex.exe, procédez comme suit :
1. Téléchargez le fichier .cab ImageX lancement pour toutes les architectures dans un dossier sur votre ordinateur.
2. dans l'Explorateur Windows, recherchez le fichier .cab 86 x sur votre ordinateur.
3. dans l'Explorateur Windows, double-cliquez sur le fichier .cab pour afficher le contenu du fichier.
4. Appuyez sur CTRL + A pour sélectionner imagex.exe.
5. la sélection avec le bouton droit, puis cliquez sur Extraire.
6. dans la fenêtre Sélectionnez une Destination, sélectionnez le dossier qui contient le fichier .cab.
7. Cliquez sur Créer un nouveau dossier et tapez x 86 pour le nom du dossier.
8. Cliquez sur Extraire pour extraire les fichiers.
9. dans l'Explorateur Windows, recherchez le dossier où vous avez extrait les fichiers dans les étapes précédentes.
10. Appuyez sur CTRL + A pour sélectionner ImageX dans le dossier.
11. Cliquez sur la sélection, puis cliquez sur Copier.
12. Recherchez le dossier où le fichier imagex.exe 86 x est installé sur votre ordinateur. Par exemple, le fichier imagex.exe 86 x peut être installé dans le dossier C:\Program Files\Windows AIK\Tools\x86 ou C:\Program Files\Windows OPK\Tools\x86 par les utilisateurs de Windows AIK ou kit de préinstallation OEM.
13. avec le bouton droit n'importe où dans le dossier, puis cliquez sur Coller.
14. lorsque vous y êtes invité, cliquez sur Copier et remplacer pour remplacer le fichier imagex.exe avec la nouvelle version qui inclut cette version.
15. Si une fenêtre vous invitant à des autorisations d'administrateur, cliquez sur Continuer. Si d'autres fenêtres de l'opération de fichier vous y invite, cliquez sur Oui dans ces fenêtres.
16. Répétez les étapes 2 à 15 à l'aide du fichier .cab de ImageX amd64, en tapant amd64 pour le nom du dossier et en sélectionnant ce dossier comme destination pour le fichier d'ImageX amd64 extraits. Par exemple, le fichier imagex.exe amd64 peut être installé dans le dossier C:\Program Files\Windows AIK\Tools\amd64 OR C:\Program Files\Windows OPK\Tools\amd64 par les utilisateurs de Windows AIK ou kit de préinstallation OEM.
17. Répétez les étapes 2 à 15 à l'aide du fichier .cab IA64 ImageX, en tapant IA64 pour le nom du dossier et en sélectionnant ce dossier comme destination pour le fichier extrait ImageX IA64. Par exemple, le fichier imagex.exe amd64 peut être installé dans le dossier C:\Program Files\Windows AIK\Tools\IA64 OR C:\Program Files\Windows OPK\Tools\IA64 par les utilisateurs de Windows AIK ou kit de préinstallation OEM.

Pour les utilisateurs qui sont à l'aide de imagex.exe en tant qu'exécutable autonome, procédez comme suit :
</architecture></architecture></architecture>
  1. Extraire manuellement ce correctif logiciel dans un emplacement temporaire.
  2. Montez le fichier Winpe.wim problématique à l'aide de l'outil Imagex.exe avec la syntaxe /mountrw . Pour ce faire, exécutez la commande suivante à une invite de commande :
    IMAGEX. EXE /mountrw chemin d'accès de la zone de mise en œuvre de Winpe.wim 1
  3. Copiez le fichier de mise à jour imagex au répertoire Tools du fichier Winpe.wim monté.
  4. Démontez le fichier Winpe.wim à l'aide de l'outil Imagex.exe avec la syntaxe /commit . Pour ce faire, exécutez la commande suivante à une invite de commande :
    IMAGEX. EXE /commit

Informations concernant le Registre

Pour utiliser le correctif dans ce package, il est inutile d'apporter des modifications au Registre.

Nécessite un redémarrage

Vous n'êtes pas obligé de redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace pas un correctif précédemment publié.

Informations sur les fichiers

La version globale de ce correctif logiciel installe des fichiers dont les attributs sont répertoriés dans les tableaux ci-dessous. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Les dates et heures de ces fichiers sur votre ordinateur local sont affichées dans votre heure locale en tenant compte de l'heure d'été (DST). En outre, les dates et heures peuvent changer lorsque vous effectuez certaines opérations sur les fichiers.
Remarques sur les fichiers Windows 7 et Windows Server 2008 R2
Important Les correctifs logiciels Windows 7 et Windows Server 2008 R2 sont inclus dans les mêmes packages. Toutefois, les correctifs dans la page demande de correctif sont répertoriés sous les deux systèmes d'exploitation. Pour demander le package de correctif qui s'applique à un ou aux deux systèmes d'exploitation, sélectionnez le correctif logiciel répertorié sous Windows 7/Windows Server 2008 R2 » sur la page. Reportez-vous toujours à la section « S'applique à » dans les articles pour déterminer le système d'exploitation actif auquel s'applique chaque correctif.
  • Les fichiers qui s'appliquent à un produit spécifique, SR_Level (RTM, SPn), et de dossier (LDR, GDR) peut être identifié en examinant les numéros de version de fichier comme indiqué dans le tableau suivant.
    VersionProduitSR_LevelBranche de service
    6.1.760 1. 21xxxWindows 7 et Windows Server 2008 R2SERVICE PACK 1LDR
Pour toutes les versions x86 de Windows 7 prises en charge
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
ImageX.exe6.1.7601.21716475,64828-avr-201102:34x 86
Pour toutes les versions 64 bits de Windows 7 et Windows Server 2008 R2
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
ImageX.exe6.1.7601.21716574,97628-avr-201102:51x64
Pour toutes les versions de Windows Server 2008 R2 basées sur IA-64 prises en charge
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
ImageX.exe6.1.7601.217161,188,35228-avr-201102:12IA-64
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Plus d'informations
Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft
Pour plus d'informations sur l'outil ImageX, visitez le site Web TechNet suivant :
Problème de course ImageX WinPE

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 2525084 - Dernière mise à jour : 07/09/2015 07:37:00 - Révision : 5.0

Windows 7 Édition Starter, Windows 7 Édition Familiale Premium, Windows 7 Professionnel, Windows 7 Édition Familiale Basique, Windows 7 Entreprise, Windows 7 Édition Integrale, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 for Itanium-Based Systems

  • kbqfe kbfix kbhotfixserver kbautohotfix kbsurveynew kbexpertiseinter atdownload kbmt KB2525084 KbMtfr
Commentaires