CORRECTIF : Utilisateurs standard ne peut pas ouvrir la base de données VSS sur les ordinateurs Windows 2000

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

La version anglaise de cet article est la suivante: 253301
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Si vous vous connectez à Visual SourceSafe sur un ordinateur Microsoft Windows 2000, message d'erreur suivant s'affiche :
La base de données n'existe pas. Veuillez en sélectionner un autre.
Si vous accédez à l'emplacement du fichier srcsafe.ini, sélectionnez le fichier, puis cliquez sur OK, vous revenez à une liste vide de bases de données SourceSafe disponibles.
Cause
Ce problème se produit car les utilisateurs qui ne font pas partie du groupe d'administrateurs ont l'autorisation en lecture seule de la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe.
Résolution
Pour résoudre ce problème, utilisez Regedt32 pour accorder à un contrôle total ou accès spécial à la clé de Registre.
Statut
Microsoft a confirmé l'existence de ce bogue dans les produits Microsoft répertoriés au début de cet article.

Ce bogue a été corrigé dans Microsoft Visual Studio 6.0 Service Pack 5 (SP5).

Pour télécharger service pack 5, consultez la page mises à jour du produit Visual Studio sur le site Web Microsoft suivante à :
Plus d'informations

Étapes à suivre pour reproduire le comportement

  1. Installer Visual SourceSafe sur un ordinateur Windows 2000.
  2. Créez un utilisateur normal sans privilèges administratifs.
  3. Connectez-vous à l'ordinateur Windows 2000 en tant qu'utilisateur que vous avez créé à l'étape 2.
  4. Ouvrez l'Explorateur Visual SourceSafe et connectez-vous en tant qu'Admin sans mot de passe. Notez que message d'erreur répertoriés dans la section «Symptômes» s'affiche.
Srcsafe

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 253301 - Dernière mise à jour : 02/11/2014 13:56:23 - Révision : 2.4

Microsoft Visual SourceSafe 6.0 Standard Edition

  • kbnosurvey kbarchive kbmt kbbug kbfix kbsetup kbvs600sp5fix KB253301 KbMtfr
Commentaires