Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

XL2000 : Comment faire pour réduire la chance d'infections de virus de macro

IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d’articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d’avoir accès, dans votre propre langue, à l’ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s’exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s’efforce aussi continuellement de faire évoluer son système de traduction automatique.

La version anglaise de cet article est la suivante: 269613
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Résumé
Cet article explique comment vous pouvez réduire le risque d'infection de Microsoft Excel, y compris vos feuilles de calcul, les modèles et compléments--avec les virus de macro.
Plus d'informations
Pour réduire les risques d'au maximum et réduit toute infection par un virus de macro, appliquez une ou plusieurs des méthodes suivantes.

Remarque : Utilisation de ces méthodes ne fournit pas une garantie de 100 % est non contrat d'un virus de macro.

Méthode 1: installer un logiciel Antiviru

Pour une solution à long terme pour les virus de macro, installez un logiciel antivirus est conçu spécifiquement pour détecter les virus de macro.

Remarque : après l'installation d'un programme antivirus, vous devez garder à jour pour s'assurer que nouveaux virus macro sont détectés et supprimés. Pour plus d'informations sur la mise à jour votre logiciel antivirus, veuillez contacter votre fournisseur de logiciels antivirus.

Méthode 2: augmentez le niveau de sécurité

Microsoft Excel propose les niveaux de sécurité afin de réduire les chances qu'un virus de macro s'infecter vos feuilles de calcul, modèles ou compléments suivants.

Security Level

Description

High

You can run only macros that have been digitally signed and that you confirm are from a trusted source. Before trusting a source, you should confirm that the source is responsible and uses a virus scanner before signing macros. Unsigned macros are automatically disabled, and Excel opens the worksheet without any warning.

Medium

Excel displays a warning whenever it encounters a macro from a source that is not on your list of trusted sources. You can choose whether to enable or disable the macros when you open the worksheet. If the worksheet might contain a virus, you should choose to disable macros.

Low

If you are sure that all the documents and add-ins that you open are safe, you can select this option -- it turns off macro virus protection in Excel. At this security level, macros are always enabled when you open worksheets.

Pour modifier le niveau de sécurité dans Excel, procédez comme suit :
  1. Dans le menu Outils , pointez sur macro et cliquez sur sécurité .
  2. Sous l'onglet niveau de sécurité , sélectionnez le niveau de sécurité souhaité, puis cliquez sur OK .
Pour plus d'informations sur les niveaux de sécurité, cliquez sur l'aide de Microsoft Excel dans le menu Aide , tapez le niveau de sécurité dans le Compagnon Office ou l'aide intuitive et puis cliquez sur Rechercher pour consulter les rubriques correspondantes.


Pour plus d'informations sur « recommandées » pour éviter toute infection par virus de macro dans Microsoft Word, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
233396 WD2000 : Comment faire pour réduire la chance d'infections de virus de macro

Méthode 3: Verrouiller le projet

Pour verrouiller votre projet Excel avec un mot de passe et réduire le risque d'accès non autorisé par un virus de macro, procédez comme suit :
  1. Dans le menu Outils , pointez sur macro , puis cliquez sur Visual Basic Editor .
  2. Dans le l'Explorateur de projets, sélectionnez la propriété ThisWorkbook .

    Remarque : si l'Explorateur de projets n'apparaît pas, cliquez sur Explorateur de projets dans le menu Affichage .
  3. Dans le menu Outils , cliquez sur Propriétés VBAProject .
  4. Sous l'onglet Protection , cliquez pour sélectionner la case à cocher Verrouiller le projet pour affichage .
  5. Tapez un mot de passe dans la zone mot de passe .
  6. Tapez le même mot de passe dans la zone Confirmer le mot de passe .
  7. Cliquez sur OK .
  8. Dans le menu Fichier , cliquez sur Fermer et retourner à Microsoft Excel .
Pour plus d'informations sur le verrouillage de votre projet VBA dans Visual Basic Editor, cliquez sur l'aide de Microsoft Visual Basic dans le menu Aide , tapez onglet protection dans le Compagnon Office ou l'aide intuitive et puis cliquez sur Rechercher pour afficher la rubrique.
Pour savoir comment contacter votre fournisseur de logiciel antivirus, Afficher les matériels et logiciels tiers fournisseur contacts informations suivantes : http://support.microsoft.com/gp/vendors/en-us
XL2000 vba

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 269613 - Dernière mise à jour : 02/10/2014 14:13:25 - Révision : 4.0

Microsoft Excel 2000 Standard

  • kbnosurvey kbarchive kbmt kbdtacode kbhowto kbinfo KB269613 KbMtfr
Commentaires