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Symptômes

Considérez le scénario suivant :

  • Vous avez une base de données de boîtes aux lettres qui contient de nombreuses boîtes aux lettres dans un environnement Microsoft Exchange Server 2010.

  • Le serveur de boîtes aux lettres qui héberge la base de données est en mode hors connexion.

  • Vous exécutez la cmdlet Set-Mailbox pour configurer les boîtes aux lettres dans la base de données de boîtes aux lettres sur un serveur de boîtes aux lettres différentes.

Dans ce scénario, l’applet de commande prend beaucoup de temps pour terminer la configuration.


Par exemple, vous exécutez l’applet de commande suivante pour configurer le GUID de la base de données pour toutes les 100 boîtes aux lettres dans une base de données de boîtes aux lettres sur un serveur de boîtes aux lettres Exchange Server 2010 :

Get-mailbox-identity * | set-mailbox - database « de la base de données de boîtes aux lettres DUID»-Force : $True

Il peut prendre 45 minutes pour terminer la configuration si le serveur de boîte aux lettres est en mode hors connexion. Toutefois, il ne prend que 15 à 20 secondes pour terminer la configuration si le serveur de boîte aux lettres est en ligne.

Cause

Lorsque le Gestionnaire Active appelle une procédure distante (RPC) sur le serveur de boîtes aux lettres pour récupérer l’état de la base de données, le Gestionnaire Active rencontre un problème de délai d’attente lorsque le serveur de boîte aux lettres est en mode hors connexion. Toutefois, l’état de défaillance n’est pas mis en cache, Gestionnaire Active continue à effectuer un appel RPC pour extraire l’état de chaque boîte aux lettres. Par conséquent, s’il y a beaucoup de boîtes aux lettres dans la base de données, ce processus peut prendre beaucoup de temps.


Résolution

Pour résoudre ce problème, installez le correctif cumulatif de mise à jour qui est décrite dans l’article suivant dans la Base de connaissances Microsoft :

Description de 2685289 de mise à jour du correctif cumulatif 3 pour Exchange Server 2010 Service Pack 2

État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d’informations sur la cmdlet Set-Mailbox , accédez au site Web de Microsoft suivant :

Set-MailboxPour plus d’informations sur le Gestionnaire Active, accédez au site Web de Microsoft suivant :

Présentation du Gestionnaire Active

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