Ralentissement des performances lorsque vous épinglez des vues dans Microsoft Dynamics CRM

Cet article vous aide à résoudre le problème qui se produit lorsque vous épinglez des vues dans Microsoft Dynamics CRM Client pour Microsoft Office Outlook.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2741514

Symptômes

Microsoft Dynamics CRM Client pour Microsoft Office Outlook peut s’exécuter lentement lors de l’épinglage de vues.

Cause

Lorsqu’une vue est épinglée, les enregistrements de la vue sont extraits vers le bas dans la base de données SQL CE locale dans le {orgid.sdf} et mis en cache. Lorsque des vues sont épinglées, elles sont présentées à un utilisateur en mode liste et non paginées. Chaque fois qu’une vue épinglée est accessible, elle retourne les résultats des fichiers .sdf locaux.

Ces données sont régulièrement mises à jour en tant que processus en arrière-plan. Si un utilisateur a plusieurs vues épinglées ou sur des ordinateurs qui n’ont pas beaucoup de ressources, cela peut entraîner des problèmes de performances et de chargement.

Résolution

Pour empêcher les vues épinglées d’extraire des informations dans les caches CE SQL locaux, une clé de Registre peut être définie sur les clients Outlook Microsoft Dynamics CRM 2011. Cela peut également aider à réduire le trafic réseau global envoyé d’un serveur Microsoft Dynamics CRM 2011 vers un ordinateur client Outlook Microsoft Dynamics CRM 2011.

Lorsque cette valeur est définie sur 1, les utilisateurs ont toujours la possibilité d’épingler les vues ; Toutefois, la requête est envoyée au serveur CRM pour récupérer les résultats au lieu du cache local.

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.

Pour résoudre ce problème, procédez comme suit :

  1. Connectez-vous aux ordinateurs clients Outlook Microsoft Dynamics CRM 2011 en tant qu’utilisateur qui a installé le client Outlook Microsoft Dynamics CRM 2011.
  2. Cliquez sur Démarrer et sur Exécuter, tapez regedit, puis cliquez sur OK. Accédez à la clé de Registre, HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient. Dans le menu Modifier, pointez sur Nouveau, puis cliquez sur Valeur DWORD (32 bits).
  3. Tapez DisableMapiCaching, puis appuyez sur Entrée.
  4. Cliquez avec le bouton droit sur DisableMapiCaching, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  5. Cliquez avec le bouton droit sur DisableMapiCaching, puis cliquez sur Modifier.
  6. Dans la zone Données de la valeur , tapez 1, puis cliquez sur OK.
  7. Fermez l’Éditeur du Registre.

Informations supplémentaires

Le correctif cumulatif 6 ou version ultérieure doit être installé pour que la clé de Registre DisableMapiCaching fonctionne. Pour plus d’informations sur le correctif cumulatif 6, consultez Correctif cumulatif 6 de la base de connaissances Microsoft Dynamics CRM 2011.

Remarque

Cette clé de Registre n’est pas valide après l’application du correctif cumulatif 14. Il doit être mis à jour à l’aide de l’outil OrgDbOrgSettings.

Outil OrgDBOrgSettings pour Microsoft Dynamics CRM 2011