Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

Si l'ordinateur est verrouillé la fonction ExitWindowsEx() ne peut pas déconnecter l'utilisateur ni éteindre l'ordinateur

Ancien nº de publication de cet article : F288180
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Symptômes
Si un programme utilise la fonction ExitWindowsEx pour déconnecter un utilisateur ou pour éteindre l'ordinateur et que l'ordinateur est verrouillé, le programme ne peut effectuer aucune de ces actions et un écran vide de la même couleur de fond que le Bureau s'affiche.

Le même problème se produit si vous utilisez le programme Shutdown.exe pour éteindre l'ordinateur à distance lorsqu'il est verrouillé. Notez que le programme Shutdown.exe est inclus dans le Kit de ressources Windows 2000.
Cause
Ce problème peut se produire lorsque le process Winlogon ne gère pas correctement la déconnexion de l'utilisateur ni l'arrêt de l'ordinateur lorsqu'il est verrouillé.

Ce problème se produit également avec le programme Shutdown.exe car il utilise la fonction ExitWindowsEx.
Résolution
Un correctif est désormais disponible auprès de Microsoft, mais il est conçu uniquement pour corriger le problème décrit dans cet article, et doit être appliqué uniquement sur les systèmes rencontrant ce problème spécifique. Ce correctif peut recevoir des modifications supplémentaires à tout moment pour augmenter la qualité du produit. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, Microsoft vous recommande d'attendre la prochaine version du Service Pack Windows 2000 qui contiendra ce correctif.

Pour résoudre ce problème immédiatement, contactez les Services de Support technique Microsoft afin d'obtenir le correctif. Pour obtenir la liste complète des numéros de téléphone du Support technique Microsoft, ainsi que des informations relatives aux frais de support technique, consultez le site Microsoft à l'adresse Web suivante :
REMARQUE : Dans certains cas, aucun frais de support technique par téléphone ne vous sera facturé si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les frais de support technique concernent les questions et problèmes supplémentaires qui n'entrent pas dans le cadre de la mise à jour en question.

La version en anglais de ce correctif doit disposer des attributs de fichier suivants ou ceux d'une version ultérieure :
   Date        Heure  Version         Taille   Nom de fichier   ----------------------------------------------------------   12/03/2001  14:41  5.0.2195.3357   331 536  Msgina.dll   12/03/2001  14:40  5.0.2195.3357   178 448  Winlogon.exe

Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article".
Plus d'informations
Pour plus d'informations sur les procédures d'installation de Windows 2000 et des correctifs pour Windows 2000, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
249149 Installation de Microsoft Windows 2000 et des correctifs pour Windows 2000
Propriétés

ID d'article : 288180 - Dernière mise à jour : 12/06/2015 00:25:08 - Révision : 4.4

  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • kbnosurvey kbarchive kbqfe kbhotfixserver kbbug kbenv kbfix kbwin2000presp3fix kbwin2000sp3fix KB288180
Commentaires
p://go.microsoft.com/?linkid=9851308" class="ctl_footerNavLink" data-bi-name="Footer_Trademarks" data-bi-slot="3"> Marques commerciales
  • © 2015 Microsoft