Symptômes
Considérez le scénario suivant :
-
Microsoft System Center Virtual Machine Manager (SCVMM) vous permet de créer un cluster de basculement de Hyper-V. Les hôtes Hyper-V en cluster sont installés avec Windows Server 2012 R2 ou Windows Server 2008 R2 Service Pack 1 (SP1).
-
Vous affectez une ressource de stockage tiers au cluster Hyper-V.
-
Vous créez un ordinateur virtuel qui réside sur le volume de stockage tiers.
-
SCVMM actualise l’ordinateur virtuel.
Dans ce scénario, les messages d’erreur suivants s’affiche :
Chemin d’accès de disque «chemin d’accès du volume» n’est pas un chemin d’accès au stockage du cluster ou de stockage qui peut être ajouté au cluster. Vous devez vous assurer de que ce système de stockage est disponible pour tous les nœuds du cluster pour rendre cet ordinateur virtuel hautement disponible.
Une erreur s’est produite lors de l’ajout de nouveaux requis de stockage pour le rôle de l’ordinateur virtuel. La clé donnée n’était pas présente dans le dictionnaire.
Une erreur s’est produite lors de la mise à jour de la configuration du stockage pour le rôle «nom de l’ordinateur virtuel» de la machine virtuelle. La clé donnée n’était pas présente dans le dictionnaire.
Cause
Ce problème se produit car la ressource de stockage tiers n’a pas de propriété privée qui est nommée « Signature_disque » ou « DiskIdGuid ». Par conséquent, il n'est pas ajouté à la machine virtuelle automatiquement lors de sa création.
Résolution
Pour résoudre ce problème dans Windows Server 2012 R2, installez la mise à jour 2955164.
Pour résoudre ce problème dans Windows Server 2008 R2, installez le correctif qui est décrit dans cet article.
Mettre à jour pour Windows Server 2012 R2
Pour plus d’informations sur la façon d’obtenir 2955164 de mise à jour, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
2955164 Windows RT 8.1, 8.1 de Windows et Windows Server 2012 R2 cumulatif : mai 2014
Informations sur le correctif pour Windows Server 2008 R2
Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.
Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.
Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.
Conditions préalables
Pour appliquer ce correctif, vous devez exécuter Windows Server 2008 R2 Service Pack 1 (SP1). Pour plus d’informations sur l’obtention d’un service pack Windows 7 ou Windows Server 2008 R2, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
976932 les informations sur le Service Pack 1 pour Windows 7 et Windows Server 2008 R2
Informations concernant le Registre
Pour appliquer ce correctif, vous n'avez à apporter aucune modification au Registre.
Nécessite un redémarrage
Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué ce correctif.
Informations de remplacement du correctif
Ce correctif ne remplace pas un correctif précédemment publié.
La version globale de ce correctif logiciel installe des fichiers dont les attributs sont répertoriés dans les tableaux ci-dessous. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Les dates et heures de ces fichiers sur votre ordinateur local sont affichées dans votre heure locale en tenant compte de l'heure d'été (DST). En outre, les dates et heures peuvent changer lorsque vous effectuez certaines opérations sur les fichiers.
Remarques sur les fichiers Windows Server 2008 R2Important Les correctifs logiciels Windows 7 et Windows Server 2008 R2 sont inclus dans les mêmes packages. Toutefois, les correctifs dans la page de demande de correctif logiciel sont répertoriés sous les deux systèmes d’exploitation. Pour demander le package de correctif qui s’applique à un ou deux systèmes d’exploitation, sélectionnez le correctif logiciel qui est répertorié sous « Windows 7/Windows Server 2008 R2 » sur la page. Reportez-vous toujours à la section « S’applique à » dans les articles pour déterminer le système d’exploitation actif auquel s’applique chaque correctif.
-
Les fichiers qui s'appliquent à un produit spécifique, un jalon (RTM, SPn) et à un dossier (LDR, GDR) peuvent être identifiés en examinant les numéros de version de fichier comme indiqué dans le tableau suivant :
Version francaise
Produit
Jalon
Dossier
6.1.760
1.22 xxxWindows Server 2008 R2
SP1
LDR
-
Les dossiers GDR contiennent uniquement les correctifs généralement publiés pour résoudre les problèmes critiques répandus. Les branches de service LDR contiennent des correctifs en plus des correctifs généralement publiés.
-
Les fichiers MANIFEST (.manifest) et MUM (.mum) qui est installés pour chaque environnement est répertoriés séparément dans la section « Informations pour Windows Server 2008 R2 de fichiers supplémentaires ». Les fichiers MUM et MANIFEST, ainsi que les fichiers de catalogue sécurité (.cat) associées, sont essentiels pour conserver l'état du composant mis à jour. Les fichiers de catalogue de sécurité, pour lesquels les attributs ne sont pas répertoriés, sont signés avec une signature numérique Microsoft.
Pour toutes les versions basées sur les x64 de Windows Server 2008 R2
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
---|---|---|---|---|---|
Failoverclusters.objectmodel.dll |
6.1.7601.22492 |
830,976 |
24-Oct-13 |
5:31 |
x64 |
Clusres.dll |
6.1.7601.22492 |
1,282,560 |
24-Oct-13 |
5:21 |
x64 |
Failoverclusters.wizards.dll |
6.1.7601.22492 |
659,456 |
24-Oct-13 |
5:31 |
x86 |
Pour toutes les versions IA-64 prises en charge de Windows Server 2008 R2
Nom de fichier |
Version de fichier |
Taille du fichier |
Date |
Heure |
Plateforme |
---|---|---|---|---|---|
Failoverclusters.objectmodel.dll |
6.1.7601.22492 |
891,392 |
24-Oct-13 |
1:58 |
IA-64 |
Clusres.dll |
6.1.7601.22492 |
2,128,896 |
24-Oct-13 |
1:51 |
IA-64 |
Failoverclusters.wizards.dll |
6.1.7601.22492 |
659,456 |
24-Oct-13 |
1:58 |
x86 |
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Plus d'informations
Pour plus d'informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft
Informations sur les fichiers supplémentaires