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CORRECTIF : Enterprise Single Sign-On déclenche l'événement 10536 et le code d'erreur 0x80090005

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La version anglaise de cet article est la suivante: 3000847

Recommandation de mise à jour

Après avoir appliqué le correctif fourni dans la section « Résolution », le service de l'entreprise simple Sign-On (ENTSSO) subit une fuite de mémoire. Par conséquent, nous vous conseillons d'installerle correctif d'une version ultérieure à la place.
Symptômes
Considérez le scénario suivant :
  • Vous avez installé le composant de la version 5 de Enterprise Single Sign-On (SSO) includedin Microsoft BizTalk Server 2013 R2 ou Host Integration Server 2013.
  • Dans un des scénarios suivants, vous restaurez la clé de secret principal à partir d'un fichier de sauvegarde :
    • Lorsque vous configurez un cluster SSO d'entreprise
    • Lors de la reprise après sinistre de l'authentification unique d'entreprise
    • Lors de la promotion d'un serveur d'authentification unique d'entreprise pour le serveur de Secret principal (MSS)
    • Lors de la migration à partir d'une version antérieure de l'authentification unique de l'entreprise
    • Au cours d'une mise à niveau à partir d'une version antérieure de l'authentification unique de l'entreprise
    • Lorsque vous effectuez plusieurs de séquences de sauvegarde et de restauration de l'Enterprise SSO V5
Après la restauration de la clé secrète principale dans un de ces scénarios, SSO d'entreprise ne peut pas décrypter les données qui sont contenues dans la base de données de l'authentification unique de l'entreprise. Dans ce cas, l'authentification unique de l'entreprise enregistre l'événement suivant dans le journal d'Application :
L'ID d'événement : 10536
Source : ENTSSO
Niveau : avertissement
Fonction d'AUDIT de l'authentification unique: ID GetConfigInfo ({11111111-6055-4cda-89CD-389E8A2B1640}) suivi : ordinateur Client de b084f15b-43fd-474e-a075-398943753c91 : nom d'ordinateur (nom d'exécutable: PID) Client utilisateur : nom d'utilisateur nom de l'Application : nom de l'application Code d'erreur : 0x80090005, des données erronées.

En outre, l'erreur suivante peut être enregistré lorsque vous ouvrez le composant logiciel enfichable MMC d'Administration BizTalk Server :
Administration de BizTalk Server
Données incorrectes.
(WinMgmt)
Boutons :
OK
Cause
Enterprise SSO V5 ajoute un horodatage à la clé de secret principal afin de limiter la durée de vie de la clé. En outre, une vérification a été ajoutée afin de déterminer si la clé de secret principal inclut la date et l'heure. Le problème qui est décrit dans la section "Symptômes" se produit car le service d'authentification unique d'entreprise détermine de façon incorrecte que l'horodatage est manquant lors de la restauration de la clé secrète principale. Parce que la date et l'heure a été ajouté à la clé de secret principal restaurée, la clé restaurée ne correspond pas à la clé utilisée pour crypter les données dans la base de données de l'authentification unique de l'entreprise. Par conséquent, les données ne peuvent pas être déchiffrées, et cela déclenche les messages d'erreur décrits précédemment.
Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif sur tous les systèmes d'entreprise SSO V5 pour éviter ce problème et à tous les systèmes qui rencontrent déjà ce problème. Ce correctif logiciel ne requiert aucune action supplémentaire afin de prévenir et de résoudre le problème.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, soumettre une demande au Service clientèle de Microsoft et prise en charge pour obtenir le correctif.

Remarque : Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :

http://support.Microsoft.com/contactus/?ws=support

Remarque : Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez avoir V5 ouverture de session unique de l'entreprise (9.0.2096) installé.

Informations sur le redémarrage

Vous devrez peut-être redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est converti en heure locale. Pour trouver la différence entre l'UTC et l'heure locale, utilisez l'onglet fuseau horaire dans l'élément de Date et heure dans le panneau de configuration.

version 32 bits (x 86)
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Infocache.dll9.0.2187.0130,53601-Oct-2014.22:00x 86
Microsoft.enterprisesinglesignon.systemmmc.dll9.0.2187.0198,63201-Oct-2014.22:00x 86
Ssoss.dll9.0.2187.0113,12801-Oct-2014.22:00x 86
version 64 bits (x 64)
Nom de fichierVersion de fichierTaille du fichierDateHeurePlateforme
Infocache.dll9.0.2187.0130,53601-Oct-2014.22:00x 86
Microsoft.enterprisesinglesignon.systemmmc.dll9.0.2187.0198,63201-Oct-2014.22:00x 86
Ssoss.dll9.0.2187.0113,12801-Oct-2014.22:00x 86
Infocache.dll9.0.2187.0151,52801-Oct-2014.22:00x64
Microsoft.enterprisesinglesignon.systemmmc.dll9.0.2187.0198,63201-Oct-2014.22:00x 86
Ssoss.dll9.0.2187.0124,39201-Oct-2014.22:00x64

Remarque
en raison des dépendances de fichiers, le correctif le plus récent qui contient ces fichiers peut également contenir des fichiers supplémentaires.
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».
Plus d'informations
Vous pouvez appliquer cette mise à jour à n'importe quel serveur de l'authentification unique d'entreprise qui rencontre le problème sans nécessiter des modifications supplémentaires. En outre, cette mise à jour doit être appliquée à tous les systèmes d'entreprise SSO V5 pour éviter ce problème lorsque vous effectuez une opération de restauration de la clé secrète principale.

Avertissement : Cet article a été traduit automatiquement.

Propriétés

ID d'article : 3000847 - Dernière mise à jour : 02/18/2016 21:16:00 - Révision : 3.0

Microsoft Host Integration Server 2013, Microsoft BizTalk Server 2013 R2 Branch, Microsoft BizTalk Server 2013 R2 Developer, Microsoft BizTalk Server 2013 R2 Enterprise, Microsoft BizTalk Server 2013 R2 Standard

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