Erreur « Accès refusé » lors de la tentative d’accès à un dossier partagé

Symptômes

Prenons l’exemple du scénario suivant :

  • Vous disposez d’un site SharePoint ou OneDrive.
  • La fonctionnalité de collection de sites en mode de verrouillage des autorisations utilisateur à accès limité est activée sur le site.
  • Vous partagez un dossier spécifique avec un autre utilisateur.
  • L’autre utilisateur tente d’accéder au dossier partagé.

Dans ce scanario, l’autre utilisateur reçoit l’un des messages d’erreur suivants :

  • Accès refusé
  • Vous avez besoin d’une autorisation pour accéder à cette ressource

Cause

Lorsque vous partagez un dossier avec un utilisateur qui ne peut pas accéder au dossier ou au site parent, SharePoint attribue à l’utilisateur un accès limité aux éléments parents. Plus précisément, SharePoint permet à l’utilisateur d’accéder au dossier sans obtenir l’autorisation d’accéder au dossier parent et aux autres éléments (autres que l’accès limité). Toutefois, lorsque le mode de verrouillage des autorisations utilisateur à accès limité est activé, l’utilisateur n’a pas accès au dossier, car l’autorisation d’accès limité nécessaire sur d’autres éléments ne fonctionne plus correctement.

Solution de contournement

Pour contourner ce problème, utilisez l’une des options suivantes, en fonction de votre situation :

  • Partagez des fichiers individuels, mais pas des dossiers.

  • Partagez toute une collection de sites ou tout un sous-site.

  • Si votre site ne nécessite pas le mode de verrouillage des autorisations utilisateur à accès limité, désactivez cette fonctionnalité de collection de sites.

    Note: D’autres fonctionnalités, telles que la publication, peuvent nécessiter le bon fonctionnement de cette fonctionnalité.