Les messages de mise à jour de réparation sont déclenchés par les échecs de TimeZoneMatchCheck dans Exchange Server

Numéro de la base de connaissances d’origine : 3019798

Symptômes

Dans Exchange Server 2016, Exchange Server 2013 ou Exchange Server 2010, vous recevez un ou plusieurs messages de mise à jour de réparation sur un iOS 8.x ou iOS 7. x appareil. Ces messages indiquent que l’Assistant Réparation de calendrier (CRA) a mis à jour une réunion.

Le corps du message contient les éléments suivants :

Your meeting was found to be out of date and has been automatically updated.

Updated meeting details:
Meeting Recurrence

L’analyse des journaux d’activité de l’ARC montre que le processus TimeZoneMatchCheck a échoué :

<CleanGlobalObjectId>040000008200E00074C5B7101A82E00800000000F076BAF92303D001000000000000000010000000F75B1C45DB47C344BF73214BACD3ED66</CleanGlobalObjectId>
<OwnerAppointmentId>-281888802</OwnerAppointmentId>
<Attendees>
<Attendee EmailAddress="jim@tailspintoys.com">
<ConsistencyChecks>
<ConsistencyCheck Type="CanValidateOwnerCheck" Result="Passed">
<Description>Checks whether the counterpart user can be validated or not.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="ValidateStoreObjectCheck" Result="Passed">
<Description>Calls Validate() on the base calendar item.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="MeetingExistenceCheck" Result="Passed">
<Description>Checkes whether the item can be found in the owner's calendar or not.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="MeetingCancellationCheck" Result="Passed">
<Description>Checkes to make sure that the meeting cancellations statuses match.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="TimeZoneMatchCheck" Result="Failed">
<Description>Checks to make sure that the attendee has correct recurring time zone information with the organizer.</Description>
<Inconsistencies>
<Inconsistency Owner="Attendee" ShouldFix="True" Flag="RecurringTimeZone" />
</Inconsistencies>
</ConsistencyCheck>
<ConsistencyCheck Type="MeetingPropertiesMatchCheck" Result="Passed">
<Description>Checks to make sure that the attendee has the correct critical properties for the meeting.</Description>
</ConsistencyCheck>
</ConsistencyChecks>
<RUMs>
<RUM IsOccurrence="False" Type="Update" Sent="True" Time="DateTime">
<Flags>
<Flag>RecurringTimeZone</Flag>
</Flags>
</RUM>
</RUMs>
</Attendee>
</Attendees>
</Meeting>
<Meeting Subject="Test Recurring TimeZone Meeting" MeetingType="RecurringMaster" StartTime="DateTime" EndTime="DateTime" Organizer="sarah@tailspintoys.com">
<InternetMessageId>&lt;fc699217a05d40dc867c497754df16e5@CLT-EX13-MBX1.tailspintoys.com&gt;</InternetMessageId>

Remarque

L’emplacement par défaut des journaux d’activité cra est %ExchangeInstallPath%\Logging\Calendar Repair Assistant.

Cause

Les messages de mise à jour de réparation de réunion peuvent apparaître dans la boîte de réception du participant 12 à 48 heures après que le participant a mis à jour la réunion sur un iOS 8. x ou iOS 7. x appareil. L’ARC tente de corriger une différence qui a été introduite par l’appareil iOS à la propriété fuseau horaire de la copie de la réunion du participant.

Résolution

Ce problème a été résolu dans la mise à jour d’iOS 8.3.

Exclusion de responsabilité de tiers

Les produits tiers mentionnés dans le présent article sont fabriqués par des sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.