Des flux de travail Gestionnaire de services ne s'exécutent pas, et les modifications apportées aux éléments de liste ne sont pas enregistrées

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La version anglaise de cet article est la suivante: 3029574
Symptômes
Lorsque les nouvelles demandes de service (SRs) sont envoyés dans Microsoft System Center 2012 Service Manager (SCSM 2012), l'état de la SRs ne change pas de « New ». En outre, des flux de travail correspondant ne s'exécutent pas pour les autres éléments de travail et les workflows affichent « Nécessitant attention » dans la console sous Administration -> Workflows -> état.

En outre, une fois que vous modifiez un élément de liste dans la console, fermez la console et puis rouvrez la console, la modification n'est plus présente dans la liste.
Cause
Ce problème peut se produire si Microsoft SQL Server Service Broker n'est pas activé sur la base de données SCSM. Lors de la création de la base de données SCSM, Service Broker est activé. Toutefois, si un scénario de reprise après sinistre est rencontré et que la base de données doit être restaurée, Service Broker sera désactivé lors de la restauration est terminée, et Service Broker doit être activé manuellement.
Résolution
Pour résoudre ce problème, activez SQL Server Service Broker. Pour ce faire, procédez comme suit.

Remarque Pour ce faire un temps lorsque les services de serveur d'administration peuvent être arrêtés.
  1. Sur le serveur d'administration ou les serveurs, ouvrez le composant logiciel enfichable Services.msc Microsoft Management Console (MMC).
  2. Prendre l'une des actions suivantes, en fonction de votre version du Gestionnaire de Service :
    • Pour System Center 2012 Service Manager et System Center 2012 Service Manager Service Pack 1 (SP1), arrêtez les services suivants :
      • Service de Configuration de gestion de System Center
      • Service de gestion de System Center
      • Service d'accès de données de System Center
    • Pour System Center 2012 R2 Service Manager, arrêtez les services suivants :
      • Service de Configuration de gestion de System Center
      • Service d'accès de données de System Center
      • Service de l'Agent de surveillance Microsoft
  3. Démarrez Microsoft SQL Server Management Studio sur le serveur de base de données de gestionnaire de services ou sur un ordinateur qui possède le SQL Server outils installés et peuvent se connecter au serveur de base de données Gestionnaire de services.
  4. Sélectionnez la nouvelle requête.
  5. Dans le volet de navigation, développez bases de données, puis cliquez sur ServiceManager.
  6. Dans le volet d'informations, tapez la commande suivante et sélectionnez Execute:
    SELECT is_broker_enabled FROM sys.databases WHERE name = « ServiceManager »
  7. Dans les résultats affichés, vérifiez que la valeur qui s'affiche dans le champ is_broker_enabled . SQL Server Service Broker est désactivé si cette valeur est 0 (zéro).
  8. Dans le volet d'informations, tapez la commande suivante et sélectionnez Execute:
    MODIFICATION de base de données ServiceManager jeu ENABLE_BROKER
  9. Vérifiez que la commande a réussi. Si c'était le cas, SQL Server Service Broker est maintenant activé.
  10. Sur le serveur d'administration ou serveurs, prendre une des actions suivantes, en fonction de votre version du Gestionnaire de Service :
    • pour System Center 2012 Service Manager et System Center 2012 Service Manager Service Pack 1, démarrez les services suivants :
      • Service de Configuration de gestion de System Center
      • Service de gestion de System Center
      • Service d'accès de données de System Center
    • Pour System Center 2012 R2 Service Manager, démarrez les services suivants :
      • Service de Configuration de gestion de System Center
      • Service d'accès de données de System Center
      • Service de l'Agent de surveillance Microsoft
  11. Fermez toutes les fenêtres et boîtes de dialogue.
  12. Tester le flux de travail en redémarrant tout flux de travail qui nécessite une attention.
  13. Soumettre une nouvelle demande de service et vérifiez qu'elle est déplacée vers l'état « En cours ».
Plus d'informations

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Propriétés

ID d'article : 3029574 - Dernière mise à jour : 01/26/2015 17:52:00 - Révision : 1.0

Microsoft System Center 2012 Service Manager, Microsoft System Center 2012 Service Manager Service Pack 1, Microsoft System Center 2012 R2 Service Manager

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