Vous êtes actuellement hors ligne, en attente de reconnexion à Internet.

COMMENT FAIRE : Créer une requête analyse croisée dans Microsoft Access 2002

Ancien nº de publication de cet article : F304349
Niveau débutant : exige une connaissance de l'interface utilisateur sur des ordinateurs mono-utilisateur.

Cet article s'applique uniquement aux bases de données Microsoft Access (.mdb).

Pour obtenir une version de cet article appliquée à Microsoft Access 2000, reportez-vous au document 304348.

Contenu de cette tâche

Résumé
Les requêtes analyse croisée vous permettent de créer des vues de synthèse de vos données pour en faciliter l'analyse. Cet article explique comment créer une requête analyse croisée dans Microsoft Access avec ou sans l'aide de l'Assistant.

ATTENTION : si vous suivez les étapes décrites dans cet exemple, vous modifiez la base de données exemple Northwind.mdb. Le cas échéant, vous pouvez effectuer une copie de sauvegarde de ce fichier, puis exécuter la procédure sur la copie de la base de données.

Début de page

Création d'une requête analyse croisée à l'aide de l'Assistant Requête analyse croisée

  1. Démarrez Microsoft Access.
  2. Dans le menu Aide (?), cliquez sur Exemples de base de données, puis sur Exemple de base de données Les Comptoirs. Cliquez sur OK à l'ouverture de l'écran de démarrage, puis fermez le formulaire Menu général lorsqu'il s'affiche.
  3. Dans le menu Insertion, cliquez sur Requête.
  4. Dans la boîte de dialogue Nouvelle requête, cliquez sur Assistant Requête analyse croisée, puis sur OK.
  5. Toujours dans cette page de l'Assistant Requête analyse croisée, cliquez sur Commandes dans la liste des tables, puis sur Suivant.
  6. Double-cliquez sur RéfEmployé dans la liste des Champs disponibles pour l'ajouter à la liste des Champs sélectionnés, puis cliquez sur Suivant. Une requête comportant un enregistrement par employé est créée.
  7. Dans la liste des champs, cliquez sur DateCommande, puis sur Suivant.
  8. Cliquez sur Année pour spécifier l'intervalle de dates, puis sur Suivant. Une requête comportant une colonne par année est créée pour les dates de commande.
  9. Cliquez sur RéfCommande dans la liste des champs, sur Nombre dans la liste des Fonctions, puis sur Suivant.
  10. Cliquez sur Terminer dans la dernière page de l'Assistant.Une requête qui affiche le nombre de commandes par employé et par an est créée.
Début de page

Création d'une requête analyse croisée sans l'aide de l'Assistant

  1. Démarrez Microsoft Access.
  2. Dans le menu Aide (?), cliquez sur Exemples de base de données, puis sur Exemple de base de données Les Comptoirs. Cliquez sur OK à l'ouverture de l'écran de démarrage, puis fermez le formulaire Menu général lorsqu'il s'affiche.
  3. Dans le menu Affichage, pointez sur Objets de la base, puis cliquez sur Requêtes.
  4. Dans le menu Insertion, cliquez sur Requête.
  5. Dans la boîte de dialogue Nouvelle requête, cliquez sur Mode Création, puis sur OK.
  6. Dans la boîte de dialogue Afficher la table, cliquez sur la table Commandes, sur Ajouter, puis sur Fermer.
  7. Dans la liste des champs de la table Commandes figurant dans la moitié supérieure de la fenêtre de création d'une requête, double-cliquez sur les champs suivants pour les ajouter à la grille de création de la requête : PaysExpédition, VilleExpédition, ExpéditionVia et Fret.
  8. Dans le menu Requête, cliquez sur Requête analyse croisée. Notez qu'une ligne nommée Analyse croisée est ajoutée à la grille de création de la requête.
  9. Cliquez sur la cellule Analyse croisée de la colonne PaysExpédition, puis sur la flèche qui s'affiche et cliquez ensuite sur En-tête de ligne.
  10. Cliquez sur la cellule Analyse croisée de la colonne VilleExpédition, puis sur la flèche qui s'affiche et cliquez ensuite sur En-tête de ligne.
  11. Cliquez sur la cellule Analyse croisée de la colonne ExpéditionVia, puis sur la flèche qui s'affiche et cliquez ensuite sur En-tête de ligne.
  12. Cliquez sur la cellule Analyse croisée de la colonne Fret, puis sur la flèche qui s'affiche et cliquez ensuite sur Valeur. Notez qu'un seul champ peut être défini à Valeur.
  13. Cliquez sur la cellule Total de la colonne Fret, puis sur la flèche qui s'affiche et cliquez ensuite sur Somme.
  14. Dans le menu Requête, cliquez sur Exécuter pour afficher les résultats de la requête analyse croisée.
Début de page


Références
Pour plus d'informations sur la création de requêtes, cliquez sur Aide sur Microsoft Access dans le menu Aide (?), tapez création d'une requête analyse croisée dans le Compagnon Office ou l'Aide intuitive, puis cliquez sur Rechercher pour afficher les rubriques renvoyées.

Pour plus d'informations sur la création de requêtes analyse croisée avec des champs de valeurs multiples, cliquez sur le numéro d'article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304458 ACC2002 : Création d'une requête analyse croisée avec des champs de valeurs multiples
Pour plus d'informations sur la création de requêtes Sélection, cliquez sur le numéro d'article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304325 ACC2002 : Comment créer une requête Sélection dans Microsoft Access
Pour plus d'informations sur la création de requêtes avec paramètres, cliquez sur le numéro d'article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304352 ACC2002 : Comment créer une requête avec paramètres dans Microsoft Access
Pour plus d'informations sur la conversion d'une requête Sélection en une requête Action, cliquez sur le numéro d'article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304354 ACC2002 : Comment convertir une requête Sélection en une requête Action
Pour plus d'informations sur la modification des propriétés d'une requête, cliquez sur le numéro d'article ci-dessous afin d'afficher le document correspondant de la Base de connaissances Microsoft :
304356 ACC2002 : Comment modifier les propriétés d'une requête dans Microsoft Access


Début de page







OfficeKBHowTo inf
Propriétés

ID d'article : 304349 - Dernière mise à jour : 11/06/2003 17:54:00 - Révision : 1.0

  • Microsoft Access 2002
  • kbhowto kbhowtomaster kbdta KB304349
Commentaires